Usplash progress bar not centered on the monitor

Bug #135319 reported by fhucho on 2007-08-28
24
Affects Status Importance Assigned to Milestone
edubuntu-artwork (Ubuntu)
Medium
Paul Sladen
usplash (Ubuntu)
Medium
Paul Sladen
xubuntu-artwork (Ubuntu)
Medium
Paul Sladen

Bug Description

Binary package hint: usplash

When Gutsy Tribe 5 is booting, the usplash progress bar is not centered, it's a bit to right. The Ubuntu logo is OK.
I have LCD monitor Philips 170B, resolution 1280x1024.
Another thing is that usplash is not using the full resolution.

fhucho (fhucho) wrote :
fhucho (fhucho) wrote :

This bug is related to https://bugs.launchpad.net/ubuntu/+source/usplash-theme-ubuntu/+bug/88895, but its status is Fix Released, so I created new one.

Scott Beamer (angrykeyboarder) wrote :

I can also confirm this in Gutsy with the latest updates.

theducks (dragonsclaw) wrote :

Confirmed on multiple systems: Toshiba Notebook, Dell GX60, Video Intel, Nvidia. Processors Celeron, P4 and AMD Athelon.
It still exists in in Feisty release I have burnt to CD.

Brian Murray (brian-murray) wrote :

I have also noticed this bug when running the "Check CD" test on Edubuntu AMD64 daily build from 20070925. It was particularly noticeable after the check had finished. I have an Intel 945 graphics controller with pci id 8086:27a2. It would be helpful to know what type of graphics cards everyone else has. Thanks in advance.

Changed in usplash:
importance: Undecided → Medium
status: New → Confirmed
Brian Murray (brian-murray) wrote :

Photograph of usplash bar after checking the CD's integrity.

Martin Pitt (pitti) wrote :

Paul looked at this yesterday and already has a patch for it.

Changed in usplash:
assignee: nobody → sladen
status: Confirmed → In Progress
Paul Sladen (sladen) wrote :

 xubuntu-artwork (0.18) gutsy; urgency=low
 .
   * Ensure throbber is centred; Change all 'theme' resolution (except
     640x400x4) -> hardcoded 320px wide throbber, to match the pixmap.

 gobuntu-artwork-usplash (0.2) gutsy; urgency=low
 .
   * Ensure throbber is centred; Change all 'theme' resolution (except
     640x400x4) -> hardcoded 320px wide throbber, to match the pixmap.

 edubuntu-artwork (0.1.0-51) gutsy; urgency=low
 .
   * Ensure throbber is centred; Change all 'theme' resolution (except
     640x400x4) -> hardcoded 320px wide throbber, to match the pixmap.

 usplash-theme-ubuntu (0.17) gutsy; urgency=low
 .
   * Ensure throbber is centred; Change all 'theme' resolution (except
     640x400x4) -> hardcoded 320px wide throbber, to match the pixmap.

And riddell already did:

kubuntu-default-settings (1:7.10-23) gutsy; urgency=low

  * Add kmplayerrc to stop volume being set on playing
  * Merge usplash/usplash-theme-kubuntu.c with Ubuntu

Changed in usplash:
status: In Progress → Fix Committed
Paul Sladen (sladen) wrote :

NB: In the 'gobuntu' usplash, the first initial theme uses an 800x600 image, so I've centred the progress bar based on a width of 800; though I think the entry in the linked list is probably expecting 640...

Vincent (vinnl) wrote :

I don't know whether it's still of importance, but this is still present in the Xubuntu Gutsy Beta. I took a picture too, see attachment.

Vincent (vinnl) wrote :

With yesterday's daily build of Xubuntu the progress bar was not moved to far *right*, but too far *left*...

lenooh (lenooh) wrote :

hmm, are the usplash programers on a boat?

Brian Murray (brian-murray) wrote :

I was iso testing with an Edubuntu 2007-10-09 daily build of the Desktop CD which has edubuntu-artwork 0.1.0-52 and the throbber was not centered.

Changed in usplash:
status: Fix Committed → Triaged
Paul Sladen (sladen) wrote :

17:18 <bdmurray> The picture I took for the bug report is still accurate:

  http://launchpadlibrarian.net/9504212/dscf4686.jpg

this one?

Changed in xubuntu-artwork:
status: New → Confirmed
Changed in edubuntu-artwork:
status: New → Confirmed
Paul Sladen (sladen) wrote :

Vincent, can I have a photo. And or VMware screen capture.

With a photograph, I can estimate the offset (you say it's to the left now?). With a screenshot I can find out the exact mode and count the exact number of pixels of error:

Current situation as I understand it; edubuntu integrity check is slight off to the right, and xubuntu is slightly off to the left:

  (a) when does this occur:
  (a1) livecd boot
  (a2) installed boot
  (b) paste xrandr | grep \*
  (c) paste cat /etc/usplash.conf
  (d) paste dpkg -l | awk '/usplash/{print $2,$3}'
  (e) digital photo, showing whole edges of monitor/display
  (f) screenshot from vmware/virtualbox if exhibitied there.

Brian Murray (brian-murray) wrote :

This only happens for me when booting off the Live CD.

  (a) using Live CD
  (b) 1280x800 60.0*+ 60.0
  (c) xres=
       yres=
  (d) edubuntu-artwork-usplash 0.1.0-52
        libusplash0 0.5.6
        usplash 0.5.6

On an installed system the answer to (c) is xres=1280 and yres=1024 .

Brian Murray (brian-murray) wrote :

I reproduced this in vmware and have included a picture of the check cd.

Brian Murray (brian-murray) wrote :

When booting from the Edubuntu Live CD in vmware the throbber is also shifted right.

Paul Sladen (sladen) wrote :

brian-murray: excellent, from this edubuntu screen shot, I believe we can tell the following

  (0) theme: edubuntu-artwork
  (1) when: livecd integrity check
  (2) mode: 640x480
  (3) offset of throbber: x=212,y=352
  (4) width of throbber: 320
  (5) progress bar lies within defined text box area (so gets scrolled).

The off-centre is caused by:

  212 + 320 + 212 being bigger than 640.

The disjoint is caused by overlapping scrolled text area and progress bar.

Paul Sladen (sladen) wrote :

brian-murray: second image confirms:

  (0) theme: edubuntu-artwork
  (1) when: install boot (from IRC message)
  (2) mode: 640x480
  (3) offset of throbber: x=212,y=352
  (4) width of throbber: 320

Problem lies in:

  edubuntu-artwork-0.1.0/art/usplash/usplash-theme-edubuntu.c

struct usplash_theme usplash_theme = {
  ...
        /* Progress bar position and size in pixels */
        .progressbar_x = 212, /* 640/2-216/2 */
        .progressbar_y = 351,
  ...
        .text_y = 307,

(a) the maths in the comment is wrong; (b) 351 is a bigger number than 307-18.

Changed in usplash:
status: Triaged → Invalid
Changed in xubuntu-artwork:
status: Confirmed → Incomplete
Changed in edubuntu-artwork:
assignee: nobody → sladen
Brian Murray (brian-murray) wrote :

When using vmware and a Live CD boot the answer to the questions are:

  (a) when does this occur:
  using a livecd boot
  (b) paste xrandr | grep \*
   1680x1050 60.0* 0.0
  (c) paste cat /etc/usplash.conf
  # Usplash configuration file
   xres=
   yres=
  (d) paste dpkg -l | awk '/usplash/{print $2,$3}'
   edubuntu-artwork-usplash 0.1.0-52
   libusplash0 0.5.6
   usplash 0.5.6

Paul Sladen (sladen) wrote :
Changed in edubuntu-artwork:
status: Confirmed → In Progress
Paul Sladen (sladen) wrote :

Bring priority across.

Changed in edubuntu-artwork:
importance: Undecided → Medium
Paul Sladen (sladen) wrote :

20:40 < joebob777as7_ > sladen, trying again
20:42 < sladen > joebob777as7_: the initramfs needs to be updated
20:42 < joebob777as7_ > sladen, works

Before/after image attached.

Paul Sladen (sladen) wrote :

 edubuntu-artwork (0.1.0-53) gutsy; urgency=low
 .
   * Edubuntu doesn't have a 16-colour theme, so will
     always use a 320px wide throbber.
     - Adjust .progress_x leftwards to centre throbber.
   * Move .progress_y upwards to avoid scrolling text-area overlap.
     (LP: #135319)

Changed in edubuntu-artwork:
status: In Progress → Fix Committed
Vincent (vinnl) wrote :

Paul, I'll boot into the LiveCD this afternoon and take a picture, and paste the things you posted, and I'll try to run it in VirtualBox too (if that's OK).

Vincent (vinnl) wrote :

OK, I'm currently in the Xubuntu LiveCD. I've attached the pictures.

ubuntu@ubuntu:~$ xrandr | grep \*
   1280x1024 60.0*

ubuntu@ubuntu:~$ cat /etc/usplash.conf
# Usplash configuration file
xres=
yres=

ubuntu@ubuntu:~$ dpkg -l | awk '/usplash/{print $2,$3}'
libusplash0 0.5.6
usplash 0.5.6
xubuntu-artwork-usplash 0.18

If I get to boot in VirtualBox I'll post another comment, but I hope this'll help for now.

Vincent (vinnl) wrote :

OK, here are some screenshots of Xubuntu booting in VirtualBox.

Paul Sladen (sladen) wrote :

Note to self: Re: (95.6 KiB, application/x-tar), xubuntu, 640x480, x=122, width=320.

Changed in xubuntu-artwork:
assignee: nobody → sladen
status: Incomplete → Confirmed
Paul Sladen (sladen) wrote :

 xubuntu-artwork (0.19) gutsy; urgency=low
 .
   * One line change; for 640x480 non-vga theme mode,
     centre throbber too far off to left. Set .progress_x = 160.
     (LP: #135319)

Changed in xubuntu-artwork:
importance: Undecided → Medium
status: Confirmed → Fix Committed
Changed in edubuntu-artwork:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

xubuntu-artwork (0.19) gutsy; urgency=low

  * One line change; for 640x480 non-vga theme mode,
    centre throbber too far off to left. Set .progress_x = 160.
    (LP: #135319)

 -- Paul Sladen <email address hidden> Fri, 12 Oct 2007 18:43:32 +0300

Changed in xubuntu-artwork:
status: Fix Committed → Fix Released
Vincent (vinnl) wrote :

Paul, I just dumped Xubuntu's latest daily build on my USB drive and yet the progress bar was still as much off to the left as it used to be.

I do recall, however, that when I upgraded the Release Candidate's packages to the latest version the progress bar was centered again on shutdown.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers