usb-creator-gtk fails to install bootloader: "System policy prevents installing the bootloader"

Bug #859539 reported by Lex Ross on 2011-09-26
620
This bug affects 143 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
Undecided
Unassigned

Bug Description

When creating USB stick from Ubuntu CD ISO image (or any other bootable CD ISO image for that matter) upon finishing copying files onto the USB stick I am getting an error message "System policy prevents installing the bootloader"followed by password prompt. When I enter the password, I get an error message "Failed to install bootloader". The result is the USB stick with all necessary files on it, but it is not bootable. I do have all administrative rights for the account I am using.

And if I start usb-creator-gtk from a command line after "sudo -s" it crashes with a segmentation fault just after copying files onto the USB stick.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: usb-creator-gtk 0.2.28.3
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Sep 26 14:18:09 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=ru:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: Upgraded to natty on 2011-04-15 (163 days ago)

Lex Ross (lross) wrote :
Lex Ross (lross) on 2011-09-26
description: updated
Brian Murray (brian-murray) wrote :

From UsbCreatorLog.txt:

usb-creator 2011-09-25 23:32:59,955 (DEBUG) install.py:191: install_bootloader
usb-creator 2011-09-25 23:43:00,057 (CRITICAL) install.py:94: Не удалось установить загрузчик.
usb-creator 2011-09-25 23:43:00,068 (ERROR) frontend.py:676: Installation failed.
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/usbcreator/install.py", line 215, in install_bootloader
    timeout=MAX_DBUS_TIMEOUT)
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.7/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
usb-creator 2011-09-26 14:17:40,865 (DEBUG) backend.py:21: UDisksBackend

Lex Ross (lross) wrote :

Thank you Brian for pointing this out. Using the "usb-creator-gtk --allow-system-internal" command I then was able to complete the job. Still, I was prompted for password 3 times in the process which is a bit too much I believe. And since usb-creator is crucial for netbook owners it is better to fixed soon.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in usb-creator (Ubuntu):
status: New → Confirmed
Hein (hhanssen) wrote :

It applies to me as well, but after entering my password my USB stick works: it boots nicely with Lubuntu. Question is: is this (still) a bug? It isn't very user friendly though to provide a pop up message referring to system policies.

This bug affects me.

I invoked usb-creator-gtk without knowing that was its name: I used "Startup Disk Creator" from the "Dash Home" thing on my Unity desktop (Oneiric + updates). It would be wise to keep names consistent.

The thing failed after 10 minutes of copying files to the thumb drive. This makes retries quite tedious.

I also hit https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/884008

I don't see any log.

Nowhere is there an explanation of how or why to give Startup Disk Creator the --allow-system-internal. Certainly not in the broken help button.

Even usb-creator-gtk(8) doesn't explain the flag well. What is a "system internal device"???

This is very unfriendly. I wonder how many users can even find there way here?

I will attach a couple of screen shots showing windows left after this failure.

It is extremely confusing and stupid that authenticating to policykit (or whatever puts this up) has no effect on the outcome. Failure has already happened.

This Oneiric bug looks a lot like https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/722019 (Maveric).

Hmm. Still fails for me with --allow-system-internal.

This time I ran from the command line:
  usb-creator-gtk --iso=Ubuntu11.10/ubuntu-11.10-desktop-i386.iso --allow-system-internal
No logging appeared on stderr (or stdout for that matter).
The command did not complete until I had entered the authenticating password.

The only logging that I've found is in /var/log/authlog

Jan 8 02:04:50 redemption polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as unix-user:boss to gain TEMPORARY authorization for action com.ubuntu.usbcreator.format for unix-process:3567:733366 [/usr/bin/python /usr/bin/usb-creator-gtk --iso=Ubuntu11.10/ubuntu-11.10-desktop-i386.iso --allow-system-internal] (owned by unix-user:boss)
Jan 8 02:18:10 redemption gnome-screensaver-dialog: gkr-pam: unlocked login keyring
Jan 8 02:19:02 redemption polkitd(authority=local): Operator of unix-session:/org/freedesktop/ConsoleKit/Session2 successfully authenticated as unix-user:boss to gain TEMPORARY authorization for action com.ubuntu.usbcreator.bootloader for unix-process:3567:733366 [/usr/bin/python /usr/bin/usb-creator-gtk --iso=Ubuntu11.10/ubuntu-11.10-desktop-i386.iso --allow-system-internal] (owned by unix-user:boss)

There were two authorizations: one for formatting the USB drive and one for the bootloader.

I don't imagine that this is relevant, but the Oneric system I'm using is AMD64 but the system I'm trying to create is i386 (as is the .iso).

Interestingly, I seem to have a parentless "/usr/bin/python /usr/share/usb-creator/usb-creator-helper" process running as root. I'll kill it and try again.

Hmmm. This time it seems to work. Note: I was again trying with --allow-system-internal.

sdowney717 (sdowney717) wrote :

I get the same error message
Trying to setup 11.10 on a USB drive case with a 320gb IDE drive inside
shows a picture with the message
http://ubuntuforums.org/showthread.php?t=1959764

If you run like this, when it gets to installing bootloader it now prompts you to authenticate and works
usb-creator-gtk --allow-system-internal

Brijam (brian-opensourcery) wrote :

This bug also affects me, and the --allow-system-internal flag did not help.

Mark Williams (mark-666) wrote :

64-bit Precise, writing a 32-bit Oneiric file out; --allow-system-internal works for me, though the 'Linux is easy' demo had already failed by then.

My best guess of what the problem is:

The application is trying to install the bootloader while some buffers (linux buffers, or hardware buffers, I don't know and I don't care) are not finished writing data on the usb key.

After 10 failed attempts I finally succeeded by waiting for my usb key led to stop flashing before entering the password required for installing bootloader.

so until this bug is fixed I would not recommend to run this app as root.

Tobiasz Jarczyk (dotnokato-q) wrote :

Happens in Quantal also.

The Bright Side (me-knowingme) wrote :

Confirmed in Quantal. None of the solutions suggested above work.

the following worked for me on Quantal:
$ usb-creator-gtk --allow-system-internal
(select image, erase disk, create)
Now wait until the LED on the USB has stopped flashing before entering root-password required for writing bootloader to the usb-stick.

This did finish with a:
"Segmentation fault (core dumped)"

But the USB-disk created seems to boot and work.
If I do not wait for the LED to stop blinking (i.e. disk-writes to complete) before entering root-password it always fails.

Dave Cheney (dave-cheney) wrote :

Still happens in 12.10 ~ Feb 1 2013 with all updates applied. Appears to be related to the amount of data buffered to be written to the USB device.

Doctor P (coffeeonmars) wrote :

I can confirm that this still happens in 12.10. I can also confirm that waiting before typing the password seems to allow avoid the problem .

I have the same problem.
$ sudo usb-creator-gtk --allow-system-internal
does the trick for me.

pablomme (pablomme) wrote :

This continues being a problem in raring.

ggjj11 (ggjj11) wrote :

I confirm this really annoying bug in ubuntu 13.04 x64.

junomedia (junomedia) wrote :

On 13.04 x64, to avoid the segmentation fault in usb-creator-gtk, the following works:
$ sudo usb-creator-gtk --allow-system-internal

Thanks @merlijn-sebrechts

WIth --allow-system-internal

I get a system crash with following message:
Ihr System besitzt nicht genug Speicher, um den Absturzbericht zu verarbeiten und einen Bericht an die Entwickler zu senden.

Translated: Your system has not enough memory to create a crash report.

I have 12GB ram installed.

James Lewis (james-fsck) wrote :

I'm still getting this failure on 13.10 as of June 22... When it happens I get this logged:-

==> syslog <==
Jun 22 19:00:14 trinity kernel: [169553.030872] usb-creator-gtk[27266]: segfault at 4 ip 00007f11ebc67db0 sp 00007fff2a69a4e8 error 6 in libdbus-1.so.3.7.3[7f11ebc44000+44000]

Vadim Peretokin (vperetokin) wrote :

Ubuntu 12.04 64bit, even "sudo usb-creator-gtk --allow-system-internal" is crashing. It's crashing everytime in various permutations.

Not really encouraging when you're trying to use to install another Ubuntu.

For those looking for an alternative, try UNetbootin. It did the job for me, where usb-creator-gtk kept crashing.

florin (florin-arjocu) wrote :

Still not working. I use an updated 13.04 Ubuntu, amd64. I tried to creat bootable for 13.10beta amd64. UNetbootin works, but I would like the native software to work, too.

Stefano Mtangoo (mtangoo) wrote :

Not working for 13.04 32bit!

Benjamin Xiao (ben-r-xiao) wrote :

Not working in 13.10 even with the --allow-system-internal option set.

sdowney717 (sdowney717) wrote :

I just tried it again and does not work.
unetbootin completes without error.

Then when I boot the thumb drive, it dumps me at a busybox prompt after i tell it to boot from the first drive. Telling it to 'try ubuntu' and it sits and sits and sits and sits and sits and sits. Then you pull the power plug and go eat dinner and wonder what happened.

sdowney717 (sdowney717) wrote :

It did eventually boot ubuntu using unetbootin but it takes a while,

Luigi R. (xluigi84) wrote :

It is affecting me in both raring and saucy. Under raring apparently I did not have a crash of the application when writing the bootloader by creating again from scratch the table partition of the usb key in gparted, formatting it in fat32 and setting the flag to boot.

Luigi R. (xluigi84) wrote :

But it seems that it not writing anything I'm still not able to boot from it.

I'm suspecting a problem in grub in ubuntu 13.10 iso. I have downloaded it several times. The first time I have tried I have been able to create a bootable usb and then I tried to install saucy on another usb key as standard installation but grub was not showing up at the startup.

Runar Ingebrigtsen (ringe) wrote :

I have this memory segmentation fault in 13.04, but the USB boots just fine still. But if I remove the USB disk too early, there are files missing causing the installation (from the USB drive) to fail.

Affects me in 64-bit Saucy writing the desktop 64-bit distribution onto a USB key (Lacie). Got progressively slower during writing process. Eventually grinds to a halt on 99%, or similar, and crashes.

I've been plagued by this bug for years - it's pretty fundemental to installing Ubuntu so would have thought it was worth someone spending time on it.

From syslog:

Oct 30 21:59:27 david-Aspire-5750 kernel: [ 2795.845553] ISO 9660 Extensions: Microsoft Joliet Level 3
Oct 30 21:59:27 david-Aspire-5750 kernel: [ 2795.845600] ISO 9660 Extensions: RRIP_1991A
Oct 30 22:01:46 david-Aspire-5750 whoopsie[1273]: online
Oct 30 22:02:47 whoopsie[1273]: last message repeated 2 times
Oct 30 22:02:54 david-Aspire-5750 kernel: [ 3002.682166] usb-creator-gtk[4648]: segfault at 4 ip 00007fad665bbd80 sp 00007fffb805f3e8 error 6 in libdbus-1.so.3.7.4[7fad66598000+44000]

There does seem to be some issue between usb-creator and dbus.

Nicola Heald (notnownikki) wrote :

Same here trying to write a 64bit 13.10 image from 64bit 13.10

Alf Haakon Lund (alf-c) wrote :

This bug affects me on Ubuntu Studio 12.10, 32-bit.

It seems waiting until light on USB drive stops blinking before typing password (as suggested in this thread) might be a workaround. I managed to successfully create an image once, and it could be that it was some waiting before typing the password.

Run from cli "usb-creator-gtk --allow-system-internal" it asks for system password, seems to run as root and crashes with the message "Segmentation fault (core dumped)" while creating the persistence file.

Run from cli "sudo usb-creator-gtk --allow-system-internal" it crashed without any error message while still copying files (before the creation of a persistence file.

Run from cli "sudo usb-creator-gtk" it crashed without any error message while finishing. Will try if it created a bootable stick and report back.

Testing requires patience as each run is ~ 10-15 mins or more...

Alf Haakon Lund (alf-c) wrote :

See my previous comment. Even if crashing, it seems "sudo usb-creator-gtk" made a working USB boot stick.

Luigi R. (xluigi84) wrote :

memory corruption when using:

sudo usb-creator-gtk --allow-system-internal
*** Error in `/usr/bin/python3': malloc(): memory corruption: 0x00000000019deee0 ***

mmalmeida (mmalmeida) wrote :

Same issue here - I've always reported the issue when the crash happened, so the team might have a few crash bug reports on it.

mmalmeida (mmalmeida) wrote :

Also, since this bug makes the software completely useless - it doesn't do the one thing it's supposed to do - I suggest making the importance of this bug "critical".

Always ask for password before installing bootloader. And when i entered it too late, it just failed, render the long awaited process useless. This is serious anoying bug. One password at start should be enough, no need to ask it repeately.

Ubuntu Precise 64.

Destan Sarpkaya (destan) wrote :

This issue is also present on 13.04!

I agree with @mmalmeida, importance should be critical.

tags: added: raring
rduplain (ron.duplain) wrote :

My latest workaround is to run from the command-line, in a fresh terminal:

    unset DBUS_SESSION_BUS_ADDRESS
    sudo usb-creator-gtk --allow-system-internal

This provided a working boot media for me after several repeat runs hitting the bug in this thread. I am using bash shell (Ubuntu's default), so change the unset call if you are running a different shell. I found the variable to unset by running `env | grep -i dbus`.

I found this workaround based on the clue from @cppege-david-9ei9ny regarding a segfault log in syslog related to dbus. I found this in my /var/log/syslog:

    May 10 19:40:03 hostname kernel: [ 9015.534921] usb-creator-gtk[13914]: segfault at 4 ip 00007f2d37ae2820 sp 00007fff9c185c88 error 6 in libdbus-1.so.3.5.8[7f2d37abe000+42000]

OS: Ubuntu 12.04 x86_64 with all system updates applied. I'm running a dbus/fluxbox X session and not ubuntu-desktop.

rduplain (ron.duplain) wrote :

Note that usb-creator will provide a definitive confirmation window when it succeeds. If you don't see a clear message telling you that it's done, assume it crashed and the media may not boot.

Lex Ross (lross) wrote :

usb-creator-gtk 0.2.56.3 still fails to install bootloader with Ubuntu 14.04.2 LTS

"Wait until the LED stops flashing", some have recommended. But there are plenty of USB sticks, even ones from well advertised brands such as SanDisk, that don't have an LED. Presumably users of such sticks are expected to be psychic?

Lex Ross (lross) wrote :

It does fail in my case, LED or no LED. The workaround described in #46 by Ron Duplain still works for me though.

MikeR (mike-rechtman) wrote :

Problem appeared on 14.04 fully updated system. (several attempts)
as a workaround: used Unetbootin which created a bootable 8GB memory stick

Matt Hanyok (matthew-hanyok) wrote :

Can confirm I'm getting this on 14.04, fully updated, trying to make a USB 15.04 installer.

Lex Ross (lross) wrote :

Same thing on 14.04.2. Upon entering admin user password the script fails with the error message, 'Failed to install boot loader' and quits. In fact, it's getting even worse as on top of it the script now fails to erase the USB stick as well with the error message:

org.freedesktop.DBus.Python.gi._glib.GError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 239, in Format
    block.call_format_sync('vfat', GLib.Variant('a{sv}', {'label': GLib.Variant('s', '')}), None)
gi._glib.GError: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object

and from that point on the erasing takes forever. Not only that but when I finally close the USB Stick creator window, I am left with the USB stick labelled with the chosen distribution name, and appropriate files appear to be copied over. This is very confusing, given the instructions on official Ubuntu site claim the process of making the bootable stick is straightforward and is easy.

SoloTurn (soloturn) wrote :

same on 15.10. workaround above does not work any more.

Vadim Peretokin (vperetokin) wrote :

While it does not work for me in Ubuntu 14.04 LTS, Ubuntu 15.10 was able to get past the error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers