Help button opens yelp on a wrong URI

Bug #884008 reported by Thibault D on 2011-10-30
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Brian Murray
Precise
Medium
Unassigned
usb-creator (Ubuntu)
Low
Martin Pitt
Precise
Low
Martin Pitt

Bug Description

1. ALT+F2 usb-creator
2. Click on the "help" button

Yelp should show the help page of usb-creator.

Instead you will get something like : "The URI « ghelp:usb-creator » does not refer to a valid page."

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: usb-creator-gtk 0.2.34
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic-pae 3.0.6
Uname: Linux 3.0.0-13-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
CheckboxSubmission: 81cb0decfb0005ccfe5f69fb8adb5547
CheckboxSystem: b8f3ec504801f13fc208edb5c785b099
Date: Sun Oct 30 23:28:54 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: usb-creator
UpgradeStatus: No upgrade log present (probably fresh install)

Thibault D (thibdrev) wrote :
Phil. V (philip.v) wrote :

I was able to reproduce this on my machine.
I think it should point to: https://help.ubuntu.com/community/Installation/FromUSBStick#From_Ubuntu_Linux

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Changed in usb-creator (Ubuntu):
status: New → Confirmed
Kent Lin (kent-jclin) on 2012-01-31
no longer affects: usb-creator
Thibault D (thibdrev) wrote :

This papercut is still true on today's Precise daily build.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: oem-priority → ubuntu
Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → oem-priority
Changed in oem-priority:
assignee: nobody → Brian Murray (brian-murray)
Changed in usb-creator (Ubuntu):
importance: Undecided → Low
no longer affects: ubuntu-docs (Ubuntu)
James M. Leddy (jm-leddy) wrote :

I couldn't find any docbook documentation in the source. I think we should back out the help button, and then merge the help button functionality once the documentation is written for usb-creator.

Changed in usb-creator (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Martin Pitt (pitti) wrote :

ubuntu-docs also does not have help, so let's just hide the button for now.

Changed in usb-creator (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package usb-creator - 0.2.36

---------------
usb-creator (0.2.36) precise; urgency=low

  [ Colin Watson ]
  * Use Python 3-compatible print functions.
  * Use "except Exception as e" syntax rather than the old-style "except
    Exception, e".
  * Use "raise Exception(value)" syntax rather than the old-style "raise
    Exception, value".
  * Use absolute imports.

  [ Martin Pitt ]
  * usbcreator/frontends/gtk/frontend.py: We do not have any help for
    usb-creator, so hide the Help button. (LP: #884008)
 -- Martin Pitt <email address hidden> Sun, 11 Mar 2012 10:14:12 +0100

Changed in usb-creator (Ubuntu Precise):
status: Confirmed → Fix Released
Chris Van Hoof (vanhoof) on 2012-03-19
no longer affects: oem-priority/q-series
Changed in oem-priority:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers