Failed to install the bootloader

Bug #722019 reported by Phillip Griego on 2011-02-20
146
This bug affects 34 people
Affects Status Importance Assigned to Milestone
usb-creator (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: usb-creator

I am trying to run usb-creator-gtk to create either a Maverick 32bit or Karmic 32bit LIVE CD on my USB Flash Drive or Hard Drive but when usb-creator-gtk FINISHES it says "Failed to install the bootloader". I find all the files placed on my USB but when I try to boot it says there is no bootloader found.

I have tried usb-creator-gtk with BOTH reserving extra space option and discarding extra space option
I have tried usb-creator-gtk -n & usb-creator-gtk -s
It is still not working.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: usb-creator-gtk 0.2.25
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Feb 19 21:29:27 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: usb-creator

papukaija (papukaija) wrote :

Maverick's release notes say: "It is not possible to create Ubuntu 10.04 USB disks from the Startup Disk Creator in Ubuntu 10.10 due to a backwards incompatibility in the syslinux program." Not sure about why you can't create Maverick live USBs.

description: updated
David Young (dove-young) wrote :

Similar problem occured in my laptop which is Ubuntu 11.04 Natty Narwhal

I wanted to create an startup USB start up image for Debian 6.0.1 with following commands, then it said "An uncaught exception was raised: Invalid version string 'GNU/Linux' " in the end on a pop up message panel.

0 : 2006 : 22:16:19 : ~
<email address hidden>$ usb-creator-gtk

0 : 2007 : 22:17:10 : ~
<email address hidden>$ usb-creator-gtk --version
0.2.23

0 : 2008 : 22:23:55 : ~
<email address hidden>$ parted --version
parted (GNU parted) 2.3
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by <http://git.debian.org/?p=parted/parted.git;a=blob_plain;f=AUTHORS>.

0 : 2009 : 22:24:02 : ~
<email address hidden>$ usb-creator-gtk -i debian/6.0.1-iso-hybrid/debian-live-6.0.1-i386-gnome-desktop.iso -n

You can find screen shot in the attachment

Jordon Bedwell (envygeeks) wrote :

I haven't had a chance to look at the script yet, but after testing, it seems that using the switch --allow-system-internal you will be able to install the bootloader on a USB stick, I tested this with 11.04 making an 11.04 startup disk to a PNY stick. Would one of you who reported this also try to use that switch and confirm if it works for you?

Changed in usb-creator (Ubuntu):
status: New → Confirmed
QC_NZ (geoffthorpe) wrote :

I wasn't one of the reporters of this bug, but I found this bug because I've been seeing the exact same problem. I tried your suggestion (Jordon) of passing "--allow-system-internal" to usb-creator-gtk (0.2.23) and it does indeed seem to allow the bootloader installation to succeed where it was previously failing.

BTW, the "polkit" authorisation dialogs come up at least 3 times during the process of creating the USB device, which can make you think that perhaps the process is borked and trying to do something it wasn't originally authorised to do (like write a bootloader to the hard-drive instead of the USB device). Is there any way things could be improved to not require multiple authorisation steps? For one thing, it encourages a click-through mentality that will sooner or later catch someone out. Anyway, that's just general feedback.

But, yeah - the --allow-system-internal workaround seems to work for me.

This Maverick bug looks a lot like https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/859539 (Oneiric).

John John Doe (johnjohndoe) wrote :

I have the same problem running Startup Disk Creator 0.2.23 on Ubuntu Precise 12.04. I also tried `usb-creator-gtk --allow-system-internal`, however, the same error message "Installation Failed. An uncaught exception was raised: Invalid version string 'GNU/LINUX'" pops up.

Stew (stew-schneider) wrote :

OK...I added --allow-system-internal, but the bootloader failed as previously noted. Seems like a pretty big "Uh-Oh"

tester (tester-5) wrote :

"the --allow-system-internal workaround" fails with 12.04, the same bug.

martini (mr-owner-gmail) wrote :

The same happens in 12.10 EVERY time. Can't make startup usb disk at ALL.

I had the problem and my workaround was to run usb-creator-gtk as a regular user (i.e.: not as root) and also by slowly take my time to enter my password when usb-creator-gtk is trying to install the bootloader.

My best guess as the why: I believe the partition table is set to be re-read just before installing the bootloader and since a USB device can sometimes take a while to disappear/reappear the application is just trying too fast to install the bootloader.

There could be something also with the FTL layer being busy as hell with the copying/unmount/sync that just happened. (FTL being an important component in the USB key's firmware)

Looks the same as bug 572611.

sm8ps (sm8ps) wrote :

I found this thread as the first and only reference to a work-around, so I dare resurrecting it.
I had successfully used usb-creator-gtk many times until now, but today it refused to install the bootloader. Today I let it sit and do its thing while checking back after a while, finding I had to give my sudo password. So quickly I entered it and hit enter which failed three times in a row.
The work-around was -- as Denis-Carl Robidoux (deniscarl) wrote on 2012-11-22 -- to enter the password slowly and not hitting enter immediately. Funny, eyh? :)

linfidel (linfidel) wrote :

According to the documentation, startup disk creator will create Ubuntu startup disks. It seems to look for the Ubuntu tag in the disk type, and if you try to make a Debian disk, it will fail with that error message "Invalid version string 'GNU/LINUX'". This is the type for a Debian ISO, but not for Ubuntu.

My solution is to use UNetBootin, especially for non-Ubuntu disks.

Changed in usb-creator (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
tags: added: raring saucy trusty utopic
removed: maverick
Susan Cragin (susancragin) wrote :

I have the same problem with utopic lubuntu, with all updates current as of 10-Sep-2014.

PeterPall (peterpall) wrote :

Did try to make an Ubutu utopic key with the final release of Utopic (AMD64 Desktop). Same result.

PeterPall (peterpall) wrote :

sudo usb-creator-gtk works just fine.

Kevin (wittyman37) wrote :

I can confirm that this still exists in Ubuntu 14.04 with all updates installed as of today May 1st, 2015. The bootable USB drives I create with usb-creator-gtk work fine but I still get the "failed to install bootloader" complaint. This is not a good look for an LTS one year in as this is a key part of sharing and installing Ubuntu.

Marcel Krause (mk.pmb) wrote :

I'm trying to install Ubuntu 14.04.3 LTS (trusty). With UNetBootin I managed to install it in a semi-broken way (freezes shorty after local user login), so I try and use that to re-create a Live USB. So effectively, I'm using
 * usb-creator-gtk=0.2.56.3ubuntu0.2
 * on Ubuntu 14.04.3 LTS (trusty)
 * via SSH and X-Forwarding (avoiding local user login)
to create a Live USB from ubuntu-14.04.3-trusty-desktop-i386.iso.
For speculative cargo-cult I also installed mbr=1.1.11-5.

Still it fails to install the bootloader.

I noticed that after UCG quit, the squashfs and the USB disk were still mounted. The latter could be a reason to scare boot loader installers.

Whatever the reason is, please
 * display the reason if it can be detected,
 * offer to open a shell in the same environment that the boot loader installer would run,
 * offer to retry installing it.

I'll even try and help patching as soon as you provide a git proxy to your repos.

Marcel Krause (mk.pmb) wrote :

Also tried --allow-system-internal, same failure.

Marcel Krause (mk.pmb) wrote :

Patched /usr/share/pyshared/usbcreator/install.py to show details:
| @@ -241,3 +241,3 @@
| except dbus.DBusException as dbus_err:
| - self._failure(message)
| + self._failure(message + ':\n' + repr(dbus_err))
| self.progress_pulse_stop()

New error message, whitespace adjusted for readability:

> Failed to install the bootloader.:
> DBusException('Traceback (most recent call last):\n
> File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 707,
> in _message_cb\n
> retval = candidate_method(self, *args, **keywords)\n
> File "/usr/share/usb-creator/usb-creator-helper", line 188,
> in InstallBootloader\n
> target_mounts = obj.get_filesystem().get_cached_property(
> \'MountPoints\').get_bytestring_array()\n
> NameError: global name \'obj\' is not defined\n',)

Hope this helps.

Marcel Krause (mk.pmb) wrote :

Copy of previous post with indentations visible:
http://pastebin.ubuntu.com/14091231/
(LaunchPad's current layout merges spaces.)

Changed in usb-creator (Ubuntu):
importance: Medium → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers