update-notifier instructs to click "check for updates" although there is no such option

Bug #934517 reported by Jiri Grönroos on 2012-02-17
50
This bug affects 7 people
Affects Status Importance Assigned to Milestone
update-notifier (Ubuntu)
Medium
Unassigned

Bug Description

update-notifier 0.118.1ubuntu1, Ubuntu 12.04

In Precise alpha, update-notifier shows up in menu bar as a icon with exclamation mark. When I click the icon, I see "The update information is outdated. This may be caused by network problems or by a repository that is no longer available. Please update manually by clicking on this icon and then selecting 'Check for updates' and check if some of the listed repositories fail."

However, a) there is no "this icon" (bad wording because update-notifier is nowadays an indicator) and b) Check for updates doesn't exist. I only see "Show updates" option in update-notifier's menu. Because of this, I installed shutter via apt-get (without doing apt-get update) and now update-notifier is gone so I can't provide a screenshot.

I believe that update-notifier was shown because I added a non-existent PPA.

<https://wiki.ubuntu.com/SoftwareUpdates#alert>: "Status of software updates should never be presented in the menu bar or a notification bubble."

Related branches

Jiri Grönroos (jiri-gronroos) wrote :
Jiri Grönroos (jiri-gronroos) wrote :
tags: added: string-fix
Changed in update-notifier (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Yop Spanjers (yopspanjers) wrote :

i've got the same bug, with an English screenshot

Changed in update-notifier (Ubuntu):
status: Triaged → Confirmed
Robert Roth (evfool) on 2012-06-08
tags: added: bitesize
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-notifier - 0.121ubuntu1

---------------
update-notifier (0.121ubuntu1) quantal; urgency=low

  [ Michael Vogt ]
  * lp:~nathwill/update-notifier/lp-934517:
    - improve wording (LP: #934517), thanks to Nathan Williams

  [ Julian Taylor ]
  * replace dict.has_key with key in dict (LP: #1040380)
 -- Dmitrijs Ledkovs <email address hidden> Sat, 25 Aug 2012 15:16:34 +0100

Changed in update-notifier (Ubuntu):
status: Confirmed → Fix Released

I believe I am seeing a new manifestation of this bug. The text now instructs the user to "Show Updates". However, the resulting dialog doesn't have any information or way to see possibly failing repositories. I presume that the notification is again out of sync with the new simplified update manager GUI.

Changed in update-notifier (Ubuntu):
status: Fix Released → Confirmed
description: updated
Changed in update-notifier (Ubuntu):
status: Confirmed → Triaged
Changed in update-notifier (Ubuntu):
assignee: nobody → Satwik Bhandiwad (satwik-bhandiwad)
Vipin Aerat (vipina82) on 2016-03-06
Changed in update-notifier (Ubuntu):
status: Triaged → Opinion
Steve Langasek (vorlon) on 2016-03-06
Changed in update-notifier (Ubuntu):
status: Opinion → Triaged
assignee: Satwik Bhandiwad (satwik-bhandiwad) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers