Ubuntu

Escaping of UTF characters in a translatable string needs fixing

Reported by David Planella on 2010-09-08
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Software Updater
Fix Committed
Medium
Unassigned
Ubuntu Translations
Medium
Unassigned
update-manager (Ubuntu)
Medium
Michael Vogt
Natty
Medium
Michael Vogt

Bug Description

Binary package hint: update-manager

Similarly to bug 625859, the following translatable string needs fixing (or just use the normal «'» char), or otherwise translations are not loaded.

"It’s safer to connect the computer to AC power before updating."

David Planella (dpm) on 2010-09-08
Changed in ubuntu-translations:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Medium
milestone: none → maverick-user-interface-freeze
Barry Warsaw (barry) wrote :
Changed in update-manager:
status: New → Confirmed
importance: Undecided → Medium
Changed in update-manager (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
status: New → Confirmed
importance: Undecided → Medium
tags: added: patch
Michael Vogt (mvo) wrote :

Is this something that needs a SRU for maverick too?

Changed in update-manager (Ubuntu):
status: Confirmed → Fix Committed
Changed in update-manager:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:0.145.5

---------------
update-manager (1:0.145.5) natty; urgency=low

  [ Michael Vogt ]
  * DistUpgrade/DistUpgradeViewText.py:
    - start with gnu screen integration
  * DistUpgrade/DistUpgradeController.py:
    - when starting a additional sshd detect if there is a firewall
      running and if so print information that the additional sshd
      may need to be added to the firewall rules
  * UpdateManager/Core/utils.py:
    - add iptables_active() helper
  * merged lp:~brian-murray/update-manager/has-completed, many thanks
    This fixes issues with the English past tense
  * merged lp:~mvo/update-manager/use-screen-in-text-frontend, this
    will use screen in the text version of the release upgrader
  * Janitor/plugins/dpkg_status_plugin.py, DistUpgrade/DistUpgradeViewGtk.py:
    - fix python-apt 0.8 API
  * merged lp:~kelemeng/update-manager/bug633036 (LP: #633036), many
    thanks to Gabor Kelemen
  * debian/rules, debian/control:
    - use dh_python2 instead of python-central and drop it from the
      build-depends

  [ Colin Watson ]
  * DistUpgrade/*ReleaseAnnouncement:
    - Fix "Narwahl" typo (LP: #684050).
 -- Michael Vogt <email address hidden> Fri, 03 Dec 2010 09:46:34 +0100

Changed in update-manager (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in update-manager (Ubuntu Maverick):
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

Needs SRU for Maverick!

Michael Schmid (mschmid-gmx) wrote :

Just to tell: I installed the current dev.-version of Ubuntu 11.04 on virtualbox and there ist the same problem....

Michael Schmid (mschmid-gmx) wrote :

Is there a SRU for Maverick done allready? If yes, how to retrieve and test it? Because I still have this bug.

In Natty Beta I have seen that the bug is fixed. I see the message in german now...

David Planella (dpm) wrote :

Hi Michael,

There isn't an SRU for this yet as far as I know. If you consider this to be an important issue for you, do you think you could file one by following the procedure at https://wiki.ubuntu.com/StableReleaseUpdates?

Thanks!

Michael Schmid (mschmid-gmx) wrote :

No, its not an important issue for me, but maybe I will try to do a SRU for Maverick, just for fun :-)

David Planella (dpm) on 2011-10-19
Changed in ubuntu-translations:
status: Triaged → Fix Released
no longer affects: update-manager (Ubuntu Maverick)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers