Intrepid -> Jaunty Alpha5 : can not mark 'ubuntu-desktop' for upgrade

Bug #335623 reported by DLCBurggraaff on 2009-02-27
92
This bug affects 2 people
Affects Status Importance Assigned to Milestone
launchpad-integration (Ubuntu)
Undecided
Unassigned
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

Cloned my Intrepid as updated on Feb 27
Disabled the Nvidia 177 driver - logged out/in - nv driver is used
Ran vmware-uninstall to remove VMware Workstation 6.5 - rebooted
Ran update-manager -d

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 8.10
Package: update-manager 1:0.93.34
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin:/home/username/bin:.
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
Uname: Linux 2.6.27-11-generic x86_64
UnreportableReason: This is not a genuine Ubuntu package

DLCBurggraaff (burdi) wrote :
DLCBurggraaff (burdi) wrote :
DLCBurggraaff (burdi) wrote :
DLCBurggraaff (burdi) wrote :
rww (rww) wrote :

I am also affected by this error. Confirming bug. I can provide my /var/log/dist-upgrade/ files too if needed, but they appear to be very similar to DLCBurggraaff's.

Changed in update-manager:
status: New → Confirmed
rww (rww) wrote :

Further investigation reveals that this problem seems to be caused by python-launchpad-integration depending on python < 2.6, so I'm adding launchpad-integration to the "Affected" list.

®om (rom1v) wrote :

$ sudo apt-get install python-launchpad-integration
...
  python-launchpad-integration: Dépend: python (< 2.6) mais 2.6.1-0ubuntu1 devra être installé
E: Paquets défectueux

(python-launchpad-integration: Depends: python (< 2.6) but 2.6.1-0ubuntu1 must be installed
E: Defect)

Sebastien Bacher (seb128) wrote :

there is an ongoing transition in jaunty that's expected and has been announced on the lists no need to open bugs

DLCBurggraaff (burdi) wrote :

@Sebastien Bacher: Which lists?
It is not mentioned in http://www.ubuntu.com/testing/jaunty/alpha5

rww (rww) wrote :

@DLCBurggraaff

Looks like it was mentioned on ubuntu-devel-announce at https://lists.ubuntu.com/archives/ubuntu-devel-announce/2009-February/000541.html . I missed that message due to some recent problems with my mail client. I guess this is an object lesson about checking the lists before reporting bugs ;)

Anyway. It looks like python-launchpad-integration for i386 has been transitioned correctly, as it requires python << 2.7 and correctly uses /usr/lib/python2.6/dist-packages/. python-launchpad-integration for amd64 hasn't been transitioned yet, though, hence the problems we're seeing. python-launchpad-integration isn't in the ~pythoneers PPA, so adding the line from the mailing list won't expedite anything.

Matthias Klose (doko) wrote :

launchpad-integration was built on 2009-02-22 on amd64;
https://edge.launchpad.net/ubuntu/+source/launchpad-integration/0.1.22/+build/878956
 it is more likely a mirror which is not up tp date, but then, how did you get the new python-defaults?

Changed in launchpad-integration:
status: New → Fix Released
rww (rww) wrote :

@Matthias Klose,

This is not a mirror issue; I got the packages directly from launchpad librarian. As I've already said, amd64 has not been transitioned correctly.

The amd64 python-launchpad-integration .deb created from the build you linked has the following Depends:
libc6 (>= 2.2.5), libglib2.0-0 (>= 2.12.0), liblaunchpad-integration1 (>= 0.1.17), python (<< 2.6), python (>= 2.5), python-central (>= 0.6.11)
It only includes /usr/lib/python2.5 stuff, not python2.6 stuff.

The i386 p-l-i .deb created by https://edge.launchpad.net/ubuntu/+source/launchpad-integration/0.1.22/+build/878959 has the following Depends:
Depends: libc6 (>= 2.1.3), libglib2.0-0 (>= 2.12.0), liblaunchpad-integration1 (>= 0.1.17), python (<< 2.7), python (>= 2.5), python-central (>= 0.6.11)
It includes both /usr/lib/python2.5 and /usr/lib/python2.6 stuff.

Andrew Gee (andrewgee) wrote :

I'd like to mention that the version that has been pointed out (0.1.22) is infact the version that I'm trying to install, which has the bad dependencies. I've looked at the i386 and amd64 debs and they have different dependencies. i386 asks for python << 2.7 and amd64 asks for python << 2.6.

Thanks

rww (rww) wrote :

Bug reports are still coming in about this, and I just tried upgrading to Jaunty again and it exhibited this problem, so I'm changing the status of this bug back from Fix Released to Confirmed.

Changed in launchpad-integration:
status: Fix Released → Confirmed
Steve Kowalik (stevenk) wrote :

@Robert, please don't do that. The fix has been uploaded to Jaunty, it just hasn't been published yet. There is a delay between uploading the package, waiting for the package to build, and then having the package hit firstly archive.ubuntu.com, and then mirrors.

I'm going to set this back to Fix Released, as I've just verified via the build logs that launchpad-integration 0.1.23 does fix the issue.

Changed in launchpad-integration:
status: Confirmed → Fix Released
DLCBurggraaff (burdi) wrote :

My upgrade now continues - the problem is resolved.
Thanks

DLCBurggraaff (burdi) wrote :

Alas the upgrade now fails at the end with what looks like a python version problem -- see the attached screenshot.

rww (rww) wrote :

@Steve Kowalik, @Matthias Klose: My apologies. I misread Matthias' comment and thought he said that 0.1.22 fixed this bug. Anyway, I just tried an upgrade to Jaunty again, and it worked fine. Thanks for the bug-fix :)

rww (rww) on 2009-03-03
Changed in update-manager:
status: Confirmed → Fix Released
DLCBurggraaff (burdi) wrote :

Retried the upgrade. It failed at the same point as on 2009-03-01. However, after the reboot it turns out I have a workable system. For as far as I can see any update fails at the end with an abort. The update is applied however. The package is not deleted from /var/cache/apt (the pertinent synaptic setting is still there) - "apt-get clean" needs to be run.

DLCBurggraaff (burdi) wrote :

Just reporting, no immediate fixes needed nor expected - after all this is still alpha.

Ursula Junque (ursinha) on 2009-10-16
summary: - Intrepid -> Jaunty Alpha5 : can not mark 'ubuntu-desktp' for upgrade
+ Intrepid -> Jaunty Alpha5 : can not mark 'ubuntu-desktop' for upgrade
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers