Gutsy->Hardy Upgrade: "unresolvable problem occurred"

Bug #221285 reported by Doug on 2008-04-24
4
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: update-manager

I got these messages when running 'update-manager':
-----------
Can't install 'ubuntu-desktop'
An unresolvable problem occurred while calculating the upgrade.
Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.
-----------
my Ubuntu release: 7.10
update-manager version: 1:0.81.3

I have 863 packages listed as updates, and began doing a "partial" dist-upgrade, but I think update-manager cannot work around broken package dependencies related to 'ubuntu-desktop'.

I will include the apt.log, as requested in the above message. It's 180kB so I will upload it compressed. I believe I can find a work-around, but wanted to "follow directions" to report this as a bug.

Thanks,
Doug

Doug (illusion65) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

Could you please attach the "main.log" file as well to this report? What version of python do you have installed (dpkg -l python|grep ^ii)?

Changed in update-manager:
status: New → Incomplete
Doug (illusion65) wrote :

python: 2.5.1-1ubuntu2

I installed ubuntu-desktop, which removed many packages (~20) and installed many more (~40) using synaptic. Then ran update-manager again. This time I did not get the error during the dist-upgrade, but it stopped with "Error authenticating some packages", listing a large collection (maybe all ~800 being upgraded) of common packages (acpi, gcc, many lib*, python2.5, xsane, ...).

"main.log.bz2" attached. I didn't think it would be useful since it, "main-pre-req.log" & "term.log" (also in "/var/log/dist-upgrade") are dated 28 Oct 2007, which is when I upgraded from Feisty to Gutsy.

Thanks,
Doug

Michael Vogt (mvo) wrote :

Thanks for the additional information.

The large number of package to update indicates that your /etc/apt/sources.list got modified to a different version of ubuntu than the one you installed (or upgraded) too. Could you please attach that file too?

Doug (illusion65) wrote :

Hi Michael,

Sorry about the delay, I was on holiday the week that you posted and just now catching up from a flurry of work. I did solve the problem, but I don't think I did anything special. Instead of trying a system update, I ran a distribution upgrade.

I'm including three "sources.list" with their dates as suffix. The 17Jul07 is certainly "before" I tried the Hardy upgrade, the source.list.21Apr08 was probably timestamped when I first tried the upgrade (and was marked ".saved", with a duplicate named ".distUpgrade"), and the .28Apr08 sources.list file is post-upgrade and has the Hardy references. I believe the references are correct in the files, but I'll let you determine that for certain.

Since that time, I've "fresh" installed Hardy on 2 laptops and dist-upgraded another, so now we're a 4 laptop, Ubuntu family! The Hardy "fresh install" is easily the best experience I've encountered for installing an OS on a laptop. Well done and thanks to everyone who's contributed so much.

Doug

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 46245, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Brian Murray (brian-murray) wrote :

This probably has something to with one of the following repositories which I found in the 21Apr08 sources.list file:

deb http://eric.lavar.de/comp/linux/debian/ experimental/
deb-src http://eric.lavar.de/comp/linux/debian/ experimental/
deb http://packages.medibuntu.org/ gutsy free non-free
deb http://lintouch.org/ubuntu breezy/all/
deb http://lintouch.org/ubuntu breezy/$(ARCH)/
deb http://mirrors.kernel.org/debian lenny main

Changed in update-manager:
importance: Undecided → Low
status: Incomplete → Confirmed
Pinejoker (esijeffrey) wrote :
Download full text (13.1 KiB)

i got same problem

family@family-desktop:~$ sudo do-release-upgrade
Checking for a new ubuntu release
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting '/tmp/tmp-1yX90/gutsy.tar.gz'
authenticate '/tmp/tmp-1yX90/gutsy.tar.gz' against '/tmp/tmp-1yX90/gutsy.tar.gz.gpg'

Reading cache

Checking package manager
Reading package lists: Done
Reading state information: Done
Reading state information: Done
Reading state information: Done
Ignored http://us.archive.ubuntu.com feisty-backports Release.gpg
Failed http://us.archive.ubuntu.com feisty-backports Release.gpg
Done http://old-releases.ubuntu.com feisty-updates Release.gpg
Done http://old-releases.ubuntu.com feisty Release.gpg
Done http://old-releases.ubuntu.com feisty-backports Release.gpg
Ignored http://us.archive.ubuntu.com feisty-backports Release
Failed http://us.archive.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-security Release.gpg
Done http://old-releases.ubuntu.com feisty-proposed Release.gpg
Hit http://old-releases.ubuntu.com feisty-updates Release
Done http://old-releases.ubuntu.com feisty-updates Release
Ignored http://us.archive.ubuntu.com feisty-backports/main/debian-installer Packages
Failed http://us.archive.ubuntu.com feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty Release
Hit http://old-releases.ubuntu.com feisty-backports Release
Hit http://old-releases.ubuntu.com feisty-security Release
Done http://old-releases.ubuntu.com feisty Release
Done http://old-releases.ubuntu.com feisty-backports Release
Done http://old-releases.ubuntu.com feisty-security Release
Failed http://us.archive.ubuntu.com feisty-backports/main/debian-installer Packages
Hit http://old-releases.ubuntu.com feisty-proposed Release
Done http://old-releases.ubuntu.com feisty-proposed Release
Hit http://old-releases.ubuntu.com feisty-updates/main Packages
Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
Hit http://old-releases.ubuntu.com feisty-updates/main Sources
Hit http://old-releases.ubuntu.com feisty-updates/restricted Sources
Hit http://old-releases.ubuntu.com feisty-updates/main Packages
Hit http://old-releases.ubuntu.com feisty-updates/restricted Packages
Hit http://old-releases.ubuntu.com feisty-updates/universe Packages
Hit http://old-releases.ubuntu.com feisty-updates/multiverse Packages
Hit http://old-releases.ubuntu.com feisty-updates/main Sources
Hit http://old-releases.ubuntu.com feisty-updates/restricted Sources
Hit http://old-releases.ubuntu.com feisty-updates/universe Sources
Hit http://old-releases.ubuntu.com feisty-updates/multiverse Sources
Hit http://old-releases.ubuntu.com feisty/universe Packages
Hit http://old-releases.ubuntu.com feisty/universe Sources
Hit http://old-releases.ubuntu.com feisty/multiverse Packages
Hit http://old-releases.ubuntu.com feisty/multiverse Sources
Hit http://old-releases.ubuntu.com feisty-backports/main Packages
Hit http://old-releases.ubuntu.com feisty-backports/restricted Packages
Hit http://old-releases.ubuntu.com feisty-backports/universe Packages
Hit http://old-releases.ubuntu.com feisty-backports/multiverse Packages
Hit http://old-rel...

RedSingularity (redsingularity) wrote :

Cleaning up unsupported versions.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in update-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers