Scrolled Windows in update-manager are too small to read

Bug #1623856 reported by Dave Morley on 2016-09-15
442
This bug affects 88 people
Affects Status Importance Assigned to Milestone
aptdaemon (Ubuntu)
Low
Brian Murray
Yakkety
Low
Unassigned
Zesty
Low
Barry Warsaw
update-manager (Ubuntu)
Low
Unassigned
Yakkety
Low
Unassigned
Zesty
Low
Unassigned

Bug Description

[Impact]

  * Expanding the scrolled windows for download progress or technical details in update-manager are just one line high, making them unreadable.

[ Test Case ]

  * Install Ubuntu 16.10 final or 17.04 daily.
  * Open update-manager and wait for it to refresh.
  * Select an update from the "Details of updates" section
  * Then expand the "Technical description", you'll see the scrolled window is just one line high. (This exercises update-manager)
  * Choose to install an update, preferably a large one, and click "Install"
  * While the update(s) are downloading click the "Details" expander
  * You'll see the scrolled window is just one line high. (This exercises aptdaemon)

After installing the patched aptdaemon and update-manager packages following the same steps will result in both scrolled windows defaulting to several lines of readable output.

[ Regression Potential ]

  * None.
  * racb: a mistake in the patch could cause the window appearance to screw up in some other way.

[ Other Info ]

ProblemType: BugDistroRelease: Ubuntu 16.10
Package: update-manager 1:16.10.5
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Uname: Linux 4.4.0-9136-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Sep 15 10:10:08 2016
GsettingsChanges:
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'406'
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'window-width' b'484'
 b'com.ubuntu.update-manager' b'launch-time' b'1473927310'
InstallationDate: Installed on 2016-07-25 (51 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
PackageArchitecture: allSourcePackage: update-manager
UpgradeStatus: Upgraded to yakkety on 2016-09-06 (8 days ago)

Dave Morley (davmor2) wrote :
tags: added: rls-y-incoming
Changed in update-manager (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Changed in update-manager (Ubuntu):
status: Confirmed → Triaged
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in update-manager (Ubuntu):
status: Triaged → In Progress
Changed in aptdaemon (Ubuntu):
status: New → In Progress
importance: Undecided → Low
assignee: nobody → Martin Wimpress (flexiondotorg)
Martin Wimpress (flexiondotorg) wrote :

The following merge proposal has been created for Yakkety which should be partnered with the attached aptdaemon debdiff.

  * https://code.launchpad.net/~flexiondotorg/update-manager/update-manager-lp1623856-yakkety/+merge/309874

summary: - Updated gtk element means you need to specify a size on the details drop
- down or it is only 1 line high
+ Scrolled Windows in update-manager are too small to read
description: updated
Brian Murray (brian-murray) wrote :

@Martin - could you explain how to test this with aptdaemon?

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu Yakkety):
status: New → Confirmed
Changed in update-manager (Ubuntu Yakkety):
status: New → Confirmed
Martin Wimpress (flexiondotorg) wrote :

@brian-murray I've updated the the Test Case to explain which issues are present in what software.

description: updated
Robie Basak (racb) wrote :

I see that 1:17.04.1 is in zesty-proposed and marks this bug as fixed.

description: updated
Changed in update-manager (Ubuntu):
status: In Progress → Fix Committed
Changed in update-manager (Ubuntu Yakkety):
status: Confirmed → Fix Committed
tags: added: verification-needed

Hello Dave, or anyone else affected,

Accepted update-manager into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/update-manager/1:16.10.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in update-manager (Ubuntu Yakkety):
importance: Undecided → Low
Changed in aptdaemon (Ubuntu Yakkety):
importance: Undecided → Low

Tested from yakkety-proposed

scott@scott-ASUS-M2N68-AM-PLUS:~$ update-manager --version
update-manager: version 1:16.10.8

When "details" is clicked when the files are being downloaded, even if maximized,
one gets less than one line displayed (I think it's about 1/2 a line!).

When the install is being done, one line is displayed, then two, then three, etc. until maybe half the screen height is being used when maximized.

I tried to screenshot the install screen before it reached its maximum height, as
it looks quite messy until it reaches it, but I was too slow. The white-on-black terminal lines don't reach all the way across the window until the full height is reached, and it scrolls the shorter lines off the top of the terminal screen. If it blanked the screen with the background color first for the full width/height of the display terminal, it would look much better (although as I say, it does not use all of the window height provided)

One other thing I noted:

A new kernel was being installed, and despite my OS being 64-bit, I noted a reference to
GRUB being built (?) for i386, so I tried to select/cut/paste the relevent part of the output before update-manager finished its work.
I couldn't.

I could make the selection, but right-clicking did not generate the usual copy/select-all options, so I tried to cntrl-C, and paste into leafpad.
No-Go. The terminal apparently cannot do cut-n-paste.
(Nor can one apparently request the window stay open when the install is complete, as I believe both synaptic and gdebi do).

I enclose (hopefully) two screenshots.
1. download detail window with less than one line height
2. install detail window not utilizing full maximized window height

-------------------------------------------
System details same as my (duplicate) bug:
https://bugs.launchpad.net/ubuntu/+source/update-manager/+bug/1637909

tags: added: verification-failed
removed: verification-needed
Brian Murray (brian-murray) wrote :

@Scott - it sounds like you were exercising the aptdaemon part of the bug and that fix hasn't made it into the archive yet. From the description:

" * Install the updates, expand the Details while updates are downloaded. Again you'll see the scrolled window is just one line high. (This exercises aptdaemon.gtk3widgets)"

tags: added: verification-needed
removed: verification-failed

A patched version of aptdaemon for Ubuntu 16.10 has been built in the following PPA:

  * https://launchpad.net/~flexiondotorg/+archive/ubuntu/sru

I've tested the patched aptdaemon alongside the patched update-manager from yakkety-proposed. Together they address the issue raised.

"
A patched version of aptdaemon for Ubuntu 16.10 has been built in the following PPA:

  * https://launchpad.net/~flexiondotorg/+archive/ubuntu/sru

I've tested the patched aptdaemon alongside the patched update-manager from yakkety-proposed. Together they address the issue raised.
"

Yes.

I just ran Software Updater, and I can see both download- and install-detail.

The detail for install was only about ten lines when I maximized it.
(See new attached screenshot.)
It is possible that since I only managed to maximize the window AFTER the install started,
that it took the install-detail height from the height of the download-detail.

I might have expected the height to change after I maximized, though....

Comments:

Unlike with synaptic and gdebi, there is no option to close/not close the download/install window after completion.
There also is no ability to do cut-and-paste from the detail terminal (i.e. one can select, but ctrl-C, and -V have no effect, and there is no context-menu with COPY and SELECT_ALL) that I have seen in at least one of the above package programs).
This makes it impossible to copy failed install info, for use in bug reports.

Is anyone aware of a config file for update-manager? I would like to be able to say:
Use Maximized Install Window: True
Always Show Detail: True
etc.

Is any of this bug material, or should I just enter it as a Wish List bug?

"
A patched version of aptdaemon for Ubuntu 16.10 has been built in the following PPA:

  * https://launchpad.net/~flexiondotorg/+archive/ubuntu/sru

I've tested the patched aptdaemon alongside the patched update-manager from yakkety-proposed. Together they address the issue raised.
"

Yes.

I just ran Software Updater, and I can see both download- and install-detail.

The detail for install was only about ten lines when I maximized it.
(See new attached screenshot.)
It is possible that since I only managed to maximize the window AFTER the install started,
that it took the install-detail height from the height of the download-detail.

I might have expected the height to change after I maximized, though....

Comments:

Unlike with synaptic and gdebi, there is no option to close/not close the download/install window after completion.
There also is no ability to do cut-and-paste from the detail terminal (i.e. one can select, but ctrl-C, and -V have no effect, and there is no context-menu with COPY and SELECT_ALL) that I have seen in at least one of the above package programs).
This makes it impossible to copy failed install info, for use in bug reports.

Is anyone aware of a config file for update-manager? I would like to be able to say:
Use Maximized Install Window: True
Always Show Detail: True
etc.

Is any of this bug material, or should I just enter it as a Wish List bug?

Barry Warsaw (barry) wrote :

@flexiondotorg I've heard back from the original aptdaemon maintainer. aptdaemon is removed from Debian unstable, and lp:aptdaemon is probably in no good shape for release. The maintainer has essentially orphaned the package.

So I think if this is to be applied and uploaded, it should be done against source branches in Ubuntu. You have the bug assigned to yourself, so unless I hear otherwise, I'll assume that you're going to take care of it. But please do let me know if you need any help.

Thanks!

martin (taxi-martin) on 2016-11-25
Changed in aptdaemon (Ubuntu Yakkety):
assignee: nobody → martin (taxi-martin)
Changed in update-manager (Ubuntu):
status: Fix Committed → Fix Released

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of update-manager from yakkety-proposed was performed and bug 1647117 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and add the tag "bot-stop-nagging" to bug 1647117 (not this bug). Thanks!

tags: added: verification-failed

I don't know if it is a regression, or just the fix not totally fixing the problem...

At least some of the time, I get very few lines of download progress, even when maximized, and even if maximized, the install details don't seem to occupy more than 1/2 the possible height.

At least once, I had just the one (partial) line for download detail.

If I recall correctly, one CANNOT maximize until "details" is clicked upon,
I think (I cannot verify any of this until the next time that there are multiple packages to update) that if I wait to long to hit "details" and "maximize" that I get VERY few lines of install detail.

I STILL wish there were a way to config this to ALWAYS SHOW DETAILS and ALWAYS maximise the download/install window.

-----------------------------------
scott@scott-ASUS-M2N68-AM-PLUS:~$ uname -a
Linux scott-ASUS-M2N68-AM-PLUS 4.8.0-29-generic #31-Ubuntu SMP Wed Nov 30 19:13:21 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Lubuntu 16.10 Yakkety
Update-manager 1:16.10.8
aptdaemon 1.1.1+bzr982-0ubuntu16.16.10.1~yakkety1.0

Barry Warsaw (barry) on 2017-01-19
Changed in aptdaemon (Ubuntu):
assignee: Martin Wimpress (flexiondotorg) → Barry Warsaw (barry)
Barry Warsaw (barry) on 2017-01-23
no longer affects: aptdaemon (Ubuntu Yakkety)
Wolfgang Betz (betzwlin) on 2017-01-28
Changed in update-manager (Ubuntu Zesty):
assignee: Martin Wimpress (flexiondotorg) → Wolfgang Betz (betzwlin)
assignee: Wolfgang Betz (betzwlin) → nobody
John Relph (relph) wrote :

I enabled proposed packages, installed the new Update Manager, and I still see the one-line details window problem. I see this exact same behavior in deja-dup as well. Is there a bug on that?

Kev Bowring (flocculant) wrote :

updated zesty aptdaemon to package in -proposed

See whole detail window now, can't ctrl+c/v messages, but can select with mouse and middle-click to paste

Kev Bowring (flocculant) wrote :

today - get whole detail window for changelog - one line once installing updates

Barry Warsaw (barry) wrote :

Unfortunately this won't get fixed in aptdaemon. That package is unmaintained and does not build in Zesty any more because it uses obsolete APIs. This bug isn't worth fixing aptdaemon for and really, aptdaemon should eventually get removed from Ubuntu (it's already dropped in Debian).

Changed in aptdaemon (Ubuntu Zesty):
status: In Progress → Won't Fix
description: updated
Brian Murray (brian-murray) wrote :

I've verified the fix for the update-manager portion of this, where the technical details are only one line high, on yakkety using the version of update-manager from -proposed.

tags: added: verification-done
removed: verification-failed verification-needed

I am not quite sure the division of labor between aptdaemon and update-manager...

In other words, if aptdaemon is not going to be updated, then presumably something
else will be needed to fulfill the complete function of "Software Updater"/update-manager.

What would replace aptdaemon when running "Software Updater"/update-manager,
such that viewing the download and install of packages could be viewed and hopefully
also cut-n-pasted (or auto log file, or ... ?)

I am sure I've seen a very similar update interface in Fedora.
https://commons.wikimedia.org/wiki/File:Fedora_Update_manager.JPG
Most likely it is gnome-packagekit.
https://help.gnome.org/users/gnome-packagekit/stable/update-viewer.html.en
So maybe it can be used instead or merged into Ubuntu's.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:16.10.8

---------------
update-manager (1:16.10.8) yakkety; urgency=medium

  [ Brian Murray ]
  * data/gtkbuilder/UpdateManager.ui: Set a minimum content height of 80px for
    the technical description scrolled window. This was the default height
    gtk3widgets used in GTK versions prior to 3.20. Thanks to Martin Wimpress
    for the fix. (LP: #1623856)
  * tests/test_hwe_support_status.py: Resolve issues with the test.

  [ Iain Lane ]
  * debian/control: Update Vcs-Bzr for yakkety stable branch

 -- Brian Murray <email address hidden> Wed, 26 Oct 2016 10:09:34 -0700

Changed in update-manager (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for update-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in aptdaemon (Ubuntu):
assignee: Barry Warsaw (barry) → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu17

---------------
aptdaemon (1.1.1+bzr982-0ubuntu17) zesty; urgency=medium

  * d/patches/lp1623856-window-height.patch: Set the scrolled
    window minimum height so that the text is more readable. (LP: #1623856)
  * d/tests/control: Update a dependency.

 -- Barry Warsaw <email address hidden> Mon, 23 Jan 2017 18:00:53 -0500

Changed in aptdaemon (Ubuntu Zesty):
status: Won't Fix → Fix Released

The attachment "aptdaemon-lp1623856.diff (For Yakkety)" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

Hello Dave, or anyone else affected,

Accepted aptdaemon into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/aptdaemon/1.1.1+bzr982-0ubuntu16.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in aptdaemon (Ubuntu Yakkety):
status: New → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Changed in aptdaemon (Ubuntu Yakkety):
importance: Undecided → Low
Łukasz Zemczak (sil2100) wrote :

Hello Dave, or anyone else affected,

Accepted aptdaemon into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/aptdaemon/1.1.1+bzr982-0ubuntu16.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dave Morley (davmor2) wrote :

Tested on both zesty and yakkety all 3 drop downs are now a reasonable size

tags: added: verification-done
removed: verification-needed
Sam Bizzell (thechachi) wrote :

Tested in 17.04 (Zesty Zapus) and the content appears to fill the window for downloading and installing details once again. Thank you, thank you!

What about the progress scroll bars that you see when you are downloading packages for installation? Issue is still present in UB 16.10. Please advise?

Issue is still present, with today i noticed while installing a kernel update.
Please refer to the attached pic.

anatoly techtonik (techtonik) wrote :

Can't see the fix on 16.10 either.

Pavak Paul (pavakatubuntu) wrote :

I have yakkety-proposed enabled but still same problem.

Oliver Becker (morbis55) wrote :

I still have the problem too with 17.04 Beta 2

As I am currently working with QT, isn't there just a simple option like
"anchors.fill: parent" so it will scale responsively with the main window?

I don't like the idea of having a fixed size.
Currently if you do an update with the updadate manger the overview window
for downloads inside the update manager window will have a fixed size.
You can't make it bigger or smaller.
However when it goes from download to install as you can see the terminal window
inside the update mangager window, you can make the window smaller but
it will not scale bigger again.

So yeah, isn't there a just a anchor with margin?

PS: Somehow it is pretty hard to get the "enlarge/shorten" mouse icon to show up
if you go to the corner of the update manager window to scale it.
Sure you could use "alt + middle mouse button" to scale the window
but not everyone knows of this hotkey

On Wed, Apr 05, 2017 at 03:57:51AM -0000, Mohd Imran Jamadar wrote:
> Issue is still present, with today i noticed while installing a kernel update.
> Please refer to the attached pic.

On which release of Ubuntu is it still present? What version of
aptdaemon and update-manager do you have installed? Just saying it is
still present isn't very helpful.

--
Brian Murray

Brian Murray (brian-murray) wrote :

On Wed, Apr 05, 2017 at 04:18:11AM -0000, anatoly techtonik wrote:
> Can't see the fix on 16.10 either.

Using which version of aptdaemon and update-manager?

--
Brian Murray

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package aptdaemon - 1.1.1+bzr982-0ubuntu16.2

---------------
aptdaemon (1.1.1+bzr982-0ubuntu16.2) yakkety; urgency=medium

  * d/patches/lp1623856-window-height.patch: Set the scrolled
    window minimum height so that the text is more readable. (LP: #1623856)

 -- Brian Murray <email address hidden> Mon, 27 Mar 2017 16:37:50 -0700

Changed in aptdaemon (Ubuntu Yakkety):
status: Fix Committed → Fix Released

Hmmm... back in November, I added the Proposed repository shown above in Other Software
(https://launchpad.net/~flexiondotorg/+archive/ubuntu/sru),
and from it obtained:
aptdaemon (1.1.1+bzr982-0ubuntu16.16.10.1~yakkety1.0 )

The fix-release version in #41 above is:

aptdaemon (1.1.1+bzr982-0ubuntu16.2) yakkety;

This has not shown up in my repositories yet, and I am wondering about the version
numbering... surely the version I have is technically a higher version than the release
(16 being higher than 2)

In Synaptic, it shows the 16.2 version in Versions, as well as mine (and also the assumed
original 16), but Package->Force Version, selecting 16.2 has no effect on the version, and
"Apply" is ghosted.
Even unchecking the Other Software repository and Reloading the package list did not change anything.
Perhaps it is because there are three other aptdaemon-related packages with the same version
string as aptdaemon (aptdaeman-date, and two python3 pkgs.) that perhaps would not work if aptdaemon changed its version.

Should I be uninstalling all 4 "16.16.10.1..." packages to be able to install 16.2?

Or am I missing something?

Brian Murray (brian-murray) wrote :

On Thu, Apr 06, 2017 at 01:09:21AM -0000, Scott Cowles Jacobs wrote:
> Hmmm... back in November, I added the Proposed repository shown above in Other Software
> (https://launchpad.net/~flexiondotorg/+archive/ubuntu/sru),
> and from it obtained:
> aptdaemon (1.1.1+bzr982-0ubuntu16.16.10.1~yakkety1.0 )

This version of aptdaemon was never in the official Ubuntu archive, and
in fact the url you've provided is a PPA.

> The fix-release version in #41 above is:
>
> aptdaemon (1.1.1+bzr982-0ubuntu16.2) yakkety;
>
> This has not shown up in my repositories yet, and I am wondering about the version
> numbering... surely the version I have is technically a higher version than the release
> (16 being higher than 2)

This version of aptdaemon is still going through the phased-updates
process is only being presented to 20% of users who use update-manager
to update their packages. If you use apt-get install aptdaemon and have
-proposed enabled you'd get the new version of aptdaemon.

> In Synaptic, it shows the 16.2 version in Versions, as well as mine (and also the assumed
> original 16), but Package->Force Version, selecting 16.2 has no effect on the version, and
> "Apply" is ghosted.
> Even unchecking the Other Software repository and Reloading the package list did not change anything.
> Perhaps it is because there are three other aptdaemon-related packages with the same version
> string as aptdaemon (aptdaeman-date, and two python3 pkgs.) that perhaps would not work if aptdaemon changed its version.

The version of aptdaemon you have installed,
1.1.1+bzr982-0ubuntu16.16.10.1~yakkety1.0, from some other repository is
in fact greater than the one in the official Ubuntu archive for yakkety.
You'll actually want to "downgrade" to the version of aptdaemon from the
archive.

--
Brian Murray

anatoly techtonik (techtonik) wrote :

Even as simple interface as update manager is so hard to get right and
debug. It is devastating.

Can I install just aptdaemon from proposed without turning a flood
checkbox for bugs from other packages?

Mauro Rossi (maurossi) wrote :

Hi,

I opened a bug case because 17.04 if affected too
never received a single sign of response.

I highlighted this at least three weeks ago, maybe one month.
Cheers

Mauro Rossi
<email address hidden>

PS: Come on, don't let me write to Mark S. in person about this Details frame two lines of code...

Mauro Rossi (maurossi) wrote :

Will the fix be upstreamed to Ubuntu 17.04 servers?
Thanks
M.

Brian Murray (brian-murray) wrote :

It should be fixed in Ubuntu 17.04. Maybe you could provide some details about which particular bug (technical details vs download [read the description]) you are experiencing and the version of the affected packages (aptdaemon and update-manager) you have installed.

Check this out in Zesty release.

Brian Murray (brian-murray) wrote :

On Sun, Apr 16, 2017 at 12:17:19PM -0000, Mohd Imran Jamadar wrote:
> Check this out in Zesty release.

While that picture definitely shows the problem, you have not included
information about the package versions which you have installed. What
version of aptdaemon do you have installed?

--
Brian Murray

Hrunting (ubuntu-hrunting) wrote :

I am still seeing behavior exactly like the screenshot posted by Mohd Imran Jamader in Ubuntu 17.04. I see it on the download progress view, the install details (terminal-like) view, and would-you-like-to-keep-or-replace config differences view. In each one, the details window does not expand to the full height of the window. If the expansion hasn't been done at all, the view will only be one line high, but in the download progress view, it can sometimes be half-height. Sorry, I didn't grab screenshots, but it's the exact same appearance seen in the screenshots throughout this bug report.

aptdaemon version 1.1.1+bzr982=0ubuntu17
update-manager version 1:17.04.3

I'm seeing exactly the same behaviour as Hrunting above on 17.04. It is an improvement on the previous one-line display but still not using the whole window. Additionally, when I try and vary the size of the window, the window changes size but the "terminal-like" part of the window doesn't change size - it stays at something like half the original size of the window.

Identical versions of aptdaemon & update-manager to Hrunting.

Brian Murray (brian-murray) wrote :

I've opened bug 1689668 regarding the config file differences issue. There may be multiple dialogs raised by aptdaemon in update-manager depending on the dialog being raised. If you still see an issue with the fixed version of aptdaemon please open a new bug report with the package version you are using and a screenshot of the issue. Thanks in advance!

Changed in aptdaemon (Ubuntu):
status: In Progress → Fix Released
Hrunting (ubuntu-hrunting) wrote :

I've opened bug 1690541 for the continued problem with the dialog line sizing with the "fixed" version of aptdaemon

While this is still present in 17.04, surprisingly whatever application is run upon clicking “apt:” links in a browser has no problem with a terminal widget.

Ettore Atalan (atalanttore) wrote :

Same problem on my Ubuntu 17.04 machine.

Cripton (cripton) wrote :

Same problem on my Ubuntu 17.10 machine.

Andreas Franzén (triptec) wrote :

I've got this same problem as well, ubuntu 17.10.

One would think that a nagging window like this that's in my face almost on a daily basis would get more attention than what I see here. Insane.

zxMarce (zxmarce) wrote :

I'm on 16.04 Gnome installed from plain vanilla 16.04, and changed Unity to Gnome. Also affects me since some time ago (measured in months):

The DETAILS pane for DOWNLOAD PROGRESS (the one with the progress bars and percentages) started showing two, three or four progresses (there would be room for 10+). At the same time, the upgrade progress DETAILS (text) pane was only some lines high, but starting today (2018-Mar-01) it is just one line high.

I'm on 16.04 because it's my office machine and it is an LTS release. Will not upgrade until the next LTS.

zxMarce (zxmarce) wrote :

Forgot my versions.

UPDATE-MANAGER (nice one, getting its version spit some issues as well):
------------------------------------------------------------------------
  xxxxxx@yyyyyy:~$ update-manager -V
  /usr/bin/update-manager:28: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
    from gi.repository import Gtk
  /usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Dbusmenu was imported without specifying a version first. Use gi.require_version('Dbusmenu', '0.4') before import to ensure that the right version gets loaded.
    from gi.repository import Dbusmenu, Unity
/usr/lib/python3/dist-packages/UpdateManager/UnitySupport.py:29: PyGIWarning: Unity was imported without specifying a version first. Use gi.require_version('Unity', '7.0') before import to ensure that the right version gets loaded.
    from gi.repository import Dbusmenu, Unity
  update-manager: version 1:16.04.12

Regarding APTDAEMON, I googled, but could not find how to get the version for aptd (suspect that is the daemon executable). The package, on the other hand, yields this:

  xxxxxx@yyyyyy:~$sudo apt-cache show aptdaemon
  Package: aptdaemon
  Priority: extra
  Section: admin
  Installed-Size: 196
  Maintainer: Ubuntu Developers <email address hidden>
  Original-Maintainer: Julian Andres Klode <email address hidden>
  Architecture: all
  Version: 1.1.1+bzr982-0ubuntu14
  Depends: python3, python3:any (>= 3.2~), gir1.2-glib-2.0, python3-aptdaemon (= 1.1.1+bzr982-0ubuntu14), python3-gi, policykit-1
  Recommends: lintian
  Breaks: software-center (<< 1.1.21)
  Filename: pool/main/a/aptdaemon/aptdaemon_1.1.1+bzr982-0ubuntu14_all.deb
  Size: 13490

Brian Murray (brian-murray) wrote :

apt-cache policy is a good way to check which version of a package you have installed e.g.

 $ apt-cache policy aptdaemon
aptdaemon:
  Installed: 1.1.1+bzr982-0ubuntu19
  Candidate: 1.1.1+bzr982-0ubuntu19
  Version table:
 *** 1.1.1+bzr982-0ubuntu19 100
        100 /var/lib/dpkg/status
     1.1.1+bzr982-0ubuntu17 500
        500 http://192.168.10.7/ubuntu bionic/main amd64 Packages
        500 http://192.168.10.7/ubuntu bionic/main i386 Packages

Brian Murray (brian-murray) wrote :

Did you install some updates around March 1st? You could check /var/log/apt/history.log to see if any were installed.

tags: removed: rls-y-incoming
To post a comment you must log in.