Changing download servers and updating crashes update-manager

Bug #1095453 reported by Nicholas Skaggs on 2013-01-02
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
update-manager (Ubuntu)
High
Unassigned

Bug Description

To reproduce the crash, do the following:

Open update-manager
Click settings
 software sources opens
Click ubuntu software tab
Change the server selected in 'download from' (eg, from main server to us server, etc)
 may be prompted to enter password for rights to change
Click close
 update-manager returns
Click update
 Crash occurs

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: update-manager 1:0.175
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Aptdaemon:

Architecture: amd64
Date: Wed Jan 2 16:56:37 2013
DpkgTerminalLog.txt: Error: [Errno 13] Permission denied: '/var/log/apt/term.log'
GsettingsChanges:
 b'com.ubuntu.update-manager' b'first-run' b'false'
 b'com.ubuntu.update-manager' b'launch-time' b'1357163579'
 b'com.ubuntu.update-manager' b'show-details' b'true'
 b'com.ubuntu.update-manager' b'window-height' b'643'
 b'com.ubuntu.update-manager' b'window-width' b'660'
InstallationDate: Installed on 2012-07-13 (173 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: update-manager
UpgradeStatus: Upgraded to raring on 2012-11-16 (47 days ago)

Nicholas Skaggs (nskaggs) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Daniel Kessel (dkessel) wrote :

Confirmed here.

Changed in update-manager (Ubuntu):
importance: Undecided → High
Brian Murray (brian-murray) wrote :

For one reason or another I haven't been able to recreate this crash. Could you include the traceback for this crash? One way to obtain it would be to get it from the corresponding .crash file in /var/crash.

Nicholas Skaggs (nskaggs) wrote :

I will upload the original crash..

Nicholas Skaggs (nskaggs) wrote :

Just reconfirmed the crash, and can push the report with apport if desired.

Daniel Kessel (dkessel) wrote :

Additional info: it does not crash when it only shows the "everything is up to date" message.

Brian Murray (brian-murray) wrote :

The latest version of apport, 2.8-0ubuntu1 facilitates crash reporting in Launchpad, so it'd be great if you could reproduce the crash with that version of apport and send it to Launchpad and then mark this bug as a duplicate of that new one. I'd expected this to be a python crash and not need retracing. Thanks!

Daniel Kessel (dkessel) wrote :

Brian, I just tried that . Apport won't let me report the bug because update manger is "no official ubuntu package".

If another .crash file is needed, I have it....

Daniel Kessel (dkessel) wrote :

I hope I'm not spamming, but I think even if one would get around the "no official ubuntu package" warning, I guess apport still wouldn't allow an upload of the crash because you seem to need out-of-date packages to trigger this bug.

Brian Murray (brian-murray) wrote :

I dug into why this is unreportable and I believe its similar to bug 1067542. We've updated the mirror that we are using and the package cache has not been updated so apport thinks this is a package that is not from an official ubuntu source.

With regards to packages being out of date, I believe that check is only for dependencies (although update-manager) does have a lot of those.

I managed to submit the crash for this bug report as bug 1097889.

I got this traceback for the crash. Seems there's an empty list somewhere that's expected not to be empty.

Traceback (most recent call last):
  File "/.../UpdateManager/UpdatesAvailable.py", line 541, in on_button_settings_clicked
    self.fillstore()
  File "/.../UpdateManager/UpdatesAvailable.py", line 720, in fillstore
    "summary", ""))
  File "/usr/lib/python3/dist-packages/apt/package.py", line 331, in summary
    return self._translated_records.short_desc
  File "/usr/lib/python3/dist-packages/apt/package.py", line 295, in _translated_records
    self.package._pcache._records.lookup(desc_iter.file_list.pop(0))
IndexError: pop from empty list

peterstan (stasnel) on 2015-08-22
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
Brian Murray (brian-murray) wrote :

There is no clear indication that this has been fixed, so I'm changing the status back as at least some of the code in the Traceback is the same.

Changed in update-manager (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers