Regression: Installing apps causes a terrible visual glitch-- have to restart X.org.

Bug #981168 reported by Pablo Almeida on 2012-04-13
130
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Jay Taoko
unity (Ubuntu)
Critical
Jay Taoko
Precise
Critical
Jay Taoko

Bug Description

[Test Case]
Hard to find a solid test case for this bug, as it was machine-specific as well.
1. Install any application from Software Center
   -> Verify that no visual glitches (window hiding, disappearing, graphical artifacts) appear.

[Regression Potential]
Broken Software Center integration related visuals.

Original description:

Installing any GUI app from the software center breaks the session with a visual glitch that hides everything. This is probably related to the new animation when installing apps (the icon flying to the Launcher), because it only happens when the Software Center is set to lock new apps to the Launcher.

I believe this is really bad since this is going to be the default behavior.

I'm on a Intel Graphics machine (lspci output attached)

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu2
Architecture: i386
Date: Fri Apr 13 17:53:46 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120225)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=pt_BR.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Pablo Almeida (pabloalmeidaff9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Pablo Almeida (pabloalmeidaff9) wrote :

Maybe this isn't useful info, but the new apps in the launcher thing never worked on my computer. Before the animation, it simply didn't happen (I had the feature turned on) and now it happens like this, so maybe the problem is not in the animation, but the feature itself?

Gary Lasker (gary-lasker) wrote :

I believe the fix for this is in the Unity domain and so I've changed the target package accordingly. This is a regression as this has worked correctly for many cycles.

Bilal, I've assigned to you to get yoru take on this. Please reassign as needed, etc., of course!

Many thanks!

affects: software-center (Ubuntu) → unity (Ubuntu)
Gary Lasker (gary-lasker) wrote :

Please ignore the "regression" part of my comment #4, that was meant for a different bug!

Changed in unity (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
Didier Roche (didrocks) wrote :

Bilal, can you pease fix it asap for rolling that in a SRU, please?

Changed in unity:
importance: Undecided → High
status: New → Confirmed
milestone: none → 5.12.0
assignee: nobody → Bilal Akhtar (bilalakhtar)
Changed in unity (Ubuntu):
importance: Undecided → High
Omer Akram (om26er) on 2012-04-16
Changed in unity:
importance: High → Critical
Changed in unity (Ubuntu):
importance: High → Critical
Didier Roche (didrocks) on 2012-04-16
summary: - Regression: Installing apps causes a terrible visual glitch-- have to
- restart X.org.
+ Regression: Installing apps causes a terrible visual glitch on
+ netbooks-- have to restart X.org.
jefferson (jeffer40) on 2012-04-16
description: updated
Omer Akram (om26er) on 2012-04-16
Changed in unity:
assignee: Bilal Akhtar (bilalakhtar) → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu Precise):
assignee: Bilal Akhtar (bilalakhtar) → Jay Taoko (jaytaoko)

This issue can be completely isolated to Intel Atom integrated GPUs. All other graphic drivers are unaffected.

I don't have an Atom GPU so I can't reproduce this issue. And, it's most certainly a driver bug.

With regards to Unity, where should we go for this? Should we blacklist the animation (not the whole of Unity 3D) for that driver, should we try working around it in some way (Jay might know more about this), or should we (gulp) remove the animation for 12.04?

Bryce Harrington (bryce) on 2012-04-16
summary: - Regression: Installing apps causes a terrible visual glitch on
+ [i945] Regression: Installing apps causes a terrible visual glitch on
netbooks-- have to restart X.org.

My computer is not a netbook-- it's a desktop. I don't understand the change in the title of the report.

Bilal Akhtar (bilalakhtar) wrote :

@Pablo: Check if lspci -v | grep i945 returns something. If it does, then it means you're on the affected driver.

@Bilal: It doesn't return anything, but my lspci outputs a line like this:

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated
Graphics Controller (rev 02) (prog-if 00 [VGA controller])

I don't know if that's what you mean with "affected driver", but I am sure
I have the issue we're talking about (I am the original reporter of the
bug).

2012/4/16 Bilal Akhtar <email address hidden>

> @Pablo: Check if lspci -v | grep i945 returns something. If it does,
> then it means you're on the affected driver.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/981168
>
> Title:
> [i945] Regression: Installing apps causes a terrible visual glitch on
> netbooks-- have to restart X.org.
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> New
> Status in “unity” source package in Precise:
> Confirmed
> Status in “xserver-xorg-video-intel” source package in Precise:
> New
>
> Bug description:
> Installing any GUI app from the software center breaks the session
> with a visual glitch that hides everything. This is probably related
> to the new animation when installing apps (the icon flying to the
> Launcher), because it only happens when the Software Center is set to
> lock new apps to the Launcher.
>
> I believe this is really bad since this is going to be the default
> behavior.
>
> I'm on a Intel Graphics machine (lspci output attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Fri Apr 13 17:53:46 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20120225)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=pt_BR:pt:en
> TERM=xterm
> PATH=(custom, no user)
> LANG=pt_BR.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-center
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/981168/+subscriptions
>

--
Pablo Almeida
http://www.google.com/profiles/pabloalmeidaff9

I am affected by this bug but the command in comment #9 doesn't return anything.

lspci returns this:

00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 13)

My netbook is a Samsung N310.

Bilal Akhtar (bilalakhtar) wrote :

@Pablo and Stephane: Please run lspci -v , not just lspci. The -v tag is important, since plain lspci doesn't display the driver being used.

Bilal Akhtar (bilalakhtar) wrote :

The lspci -v command should return a large amount of text. Search for your graphic card in it (usually starts as "VGA compatible controller") and see the "Kernel driver in use" line in the graphic card block.

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
 Subsystem: Dell Device 050e
 Flags: bus master, fast devsel, latency 0, IRQ 51
 Memory at f1400000 (64-bit, non-prefetchable) [size=4M]
 Memory at e0000000 (64-bit, prefetchable) [size=256M]
 I/O ports at 4000 [size=64]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: i915
 Kernel modules: i915

As you can see, in my case it's i915, and i945 seems to be the affected driver.

@Bilal

I did lspci -v, as you told me to do and the command didn't output anything, The driver in use is the i915, as in your computer. I'm attaching my lspci -v output:

Thanks for this Bilal. However, lspci -v returns this for me:

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
        Subsystem: Samsung Electronics Co Ltd Device c052
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at f0000000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at 1800 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at f0300000 (32-bit, non-prefetchable) [size=256K]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: intelfb, i915

Looks like it's not only the i945 driver that's affected.

summary: - [i945] Regression: Installing apps causes a terrible visual glitch on
- netbooks-- have to restart X.org.
+ [i945] Regression: Installing apps causes a terrible visual glitch--
+ have to restart X.org.
Bilal Akhtar (bilalakhtar) wrote :

That makes stuff even more surprising.

Also, try running unity --reset, then install an app again. Does the issue happen again?

summary: - [i945] Regression: Installing apps causes a terrible visual glitch--
- have to restart X.org.
+ Regression: Installing apps causes a terrible visual glitch-- have to
+ restart X.org.
Omer Akram (om26er) wrote :

this bug is being looked at by Jay, release teams considers this a release blocker. unity --reset won't help or anything.

I tried "unity --reset" but I confirm that it didn't help.

Why is it a SRU milestone? This really can't be in the final release.

unity --reset didn't help here either. However, after the session is
already broken, it fixes it.

Note: I also tried it from a clean USB live session and the problem is
there too.

2012/4/17 Stéphane Guillou <email address hidden>

> I tried "unity --reset" but I confirm that it didn't help.
>
> Why is it a SRU milestone? This really can't be in the final release.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/981168
>
> Title:
> Regression: Installing apps causes a terrible visual glitch-- have to
> restart X.org.
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> New
> Status in “unity” source package in Precise:
> Confirmed
> Status in “xserver-xorg-video-intel” source package in Precise:
> New
>
> Bug description:
> Installing any GUI app from the software center breaks the session
> with a visual glitch that hides everything. This is probably related
> to the new animation when installing apps (the icon flying to the
> Launcher), because it only happens when the Software Center is set to
> lock new apps to the Launcher.
>
> I believe this is really bad since this is going to be the default
> behavior.
>
> I'm on a Intel Graphics machine (lspci output attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Fri Apr 13 17:53:46 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20120225)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=pt_BR:pt:en
> TERM=xterm
> PATH=(custom, no user)
> LANG=pt_BR.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-center
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/981168/+subscriptions
>

--
Pablo Almeida
http://www.google.com/profiles/pabloalmeidaff9

Jay Taoko (jaytaoko) wrote :

I have attached a branch proposal to this bug. It should resolve the problem. Please, try it.

Sorry if this is a dumb question, but how do I try it?

Bryce Harrington (bryce) wrote :

"i945" is not a "driver", it's a chipset family.

It does appear that all commenters on this bug have i945 chipsets. The correct command to run to check this is:

 $ lspci | grep VGA | grep 945
 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)

It may say "945GSE", or "82945", or etc. The key thing is that "945" is in there somewhere.

I tested a i945 netbook, first with Ubuntu from about a week or so ago, then updated to current. Prior to the update I could not reproduce the bug. After the update I was able to reproduce it.

There are three drivers for i945: One is the kernel driver named i915, one is a mesa driver , and one is the X driver name -intel. The kernel driver handles the hardware, the mesa driver does 3D acceleration, the X driver 2D acceleration.

During this period, none of the three drivers have changed. mesa's last update was 27 Mar. xserver-xorg-video-intel was 15 Feb. The kernel has had some changes more recently but has been frozen in this time period.

Bryce Harrington (bryce) wrote :

@Bilal, note that the i915 you're seeing in your lspci is the kernel driver, not the chipset family. For instance on my system it is:

$ lspci -vvnn
...
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev
03) (prog-if 00 [VGA controller])
 Subsystem: Dell Device [1028:02f4]
        ....
 Kernel driver in use: i915
 Kernel modules: intelfb, i915

For some intel devices they don't give the chipset family, but you can look them up using the new xpci command:

$ xpci 8086:27ae
i945gme (8086:27ae|945GME) i945 xserver-xorg-video-intel

This xpci command gives me:

i945g (8086:2772|945G[ \/]) i945 xserver-xorg-video-intel

2012/4/17 Bryce Harrington <email address hidden>

> @Bilal, note that the i915 you're seeing in your lspci is the kernel
> driver, not the chipset family. For instance on my system it is:
>
> $ lspci -vvnn
> ...
> 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GSE
> Express Integrated Graphics Controller [8086:27ae] (rev
> 03) (prog-if 00 [VGA controller])
> Subsystem: Dell Device [1028:02f4]
> ....
> Kernel driver in use: i915
> Kernel modules: intelfb, i915
>
> For some intel devices they don't give the chipset family, but you can
> look them up using the new xpci command:
>
> $ xpci 8086:27ae
> i945gme (8086:27ae|945GME) i945 xserver-xorg-video-intel
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/981168
>
> Title:
> Regression: Installing apps causes a terrible visual glitch-- have to
> restart X.org.
>
> Status in Unity:
> Confirmed
> Status in “unity” package in Ubuntu:
> Confirmed
> Status in “xserver-xorg-video-intel” package in Ubuntu:
> New
> Status in “unity” source package in Precise:
> Confirmed
> Status in “xserver-xorg-video-intel” source package in Precise:
> New
>
> Bug description:
> Installing any GUI app from the software center breaks the session
> with a visual glitch that hides everything. This is probably related
> to the new animation when installing apps (the icon flying to the
> Launcher), because it only happens when the Software Center is set to
> lock new apps to the Launcher.
>
> I believe this is really bad since this is going to be the default
> behavior.
>
> I'm on a Intel Graphics machine (lspci output attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Fri Apr 13 17:53:46 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20120225)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=pt_BR:pt:en
> TERM=xterm
> PATH=(custom, no user)
> LANG=pt_BR.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-center
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/981168/+subscriptions
>

--
Pablo Almeida
http://www.google.com/profiles/pabloalmeidaff9

Bryce Harrington (bryce) wrote :

@Jay, I can confirm that patching unity with your change seems to resolve the problem.

USC reloads or flashes and seems to lose its position, so perhaps something is still imperfect, but the visual corruption is gone, and programs seem to install successfully.

Jay, I can't tell in reviewing your patch if it's a true fix or a workaround. Is there any actual kernel or X.org changes needed for this issue, or is your unity fix going to be considered the solution? If more is needed on the X or kernel side, please reopen the X task and let us know more specifically whats needed. (A minimal testcase we could pass to upstream would be ideal.)

Changed in xserver-xorg-video-intel (Ubuntu Precise):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.10.0-0ubuntu5

---------------
unity (5.10.0-0ubuntu5) precise-proposed; urgency=low

  * Cherry-pick two fixes from trunk:
    - Fix the software-center install animation making the display useless
      on netbooks (LP: #981168)
    - Shortcut keys in workspace section of the shortcut overlay aren't
      translated. (LP: #980828)
 -- Didier Roche <email address hidden> Tue, 17 Apr 2012 08:09:15 +0200

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Thank you Jay for the quick fix, and Didier for the quick upload.

There are a few minor changes still needed in the branch (Gord pointed that out in the merge proposal), but otherwise the fix should work now. Now that the package is in release, could you upgrade to unity 5.10.0-0ubuntu5 and see if it fixes the issue?

Bilal Akhtar (bilalakhtar) wrote :

Another thing, I haven't tried this out yet (I'm at school) but I can see this change in the branch:

56 - self->launcher_addrequest_special.emit(desktop_file, AbstractLauncherIcon::Ptr(), aptdaemon_task, icon,
57 - icon_x, icon_y, icon_size);

If this line gets removed, it means the icon wouldn't fly anymore, and it won't get pinned either. I can't see it getting re-added.

Can anyone with this package check if this is the case?

Béné (bene-d) wrote :

Hi Bilal! I was affected by this bug and after updating unity I can confirm that it's fixed, that the icon flies and that it gets pinned. Awesome. :)

Hi there. I tested the fix and it works! With flying icon and all that. Thanks! :)

Omer Akram (om26er) on 2012-04-26
no longer affects: xserver-xorg-video-intel (Ubuntu Precise)
Changed in unity:
status: Confirmed → Fix Committed
no longer affects: xserver-xorg-video-intel (Ubuntu)
Didier Roche (didrocks) on 2012-04-27
Changed in unity:
status: Fix Committed → Fix Released
Nekhelesh Ramananthan (nik90) wrote :

Since the original reporter Pablo Almeida and Bene confirm that it has fixed the issue, I am adding the verification-done tag.

tags: added: verification-done

Hello Pablo, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.14.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
description: updated
Download full text (3.7 KiB)

This problem was already gone a long time ago for me but, just in case, I
installed the updates and everything's still working fine.

2012/7/24 Łukasz Zemczak <email address hidden>

> ** Description changed:
>
> + [Test Case]
> + Hard to find a solid test case for this bug, as it was machine-specific
> as well.
> + 1. Install any application from Software Center
> + -> Verify that no visual glitches (window hiding, disappearing,
> graphical artifacts) appear.
> +
> + [Regression Potential]
> + Broken Software Center integration related visuals.
> +
> + Original description:
> +
> Installing any GUI app from the software center breaks the session with
> a visual glitch that hides everything. This is probably related to the
> new animation when installing apps (the icon flying to the Launcher),
> because it only happens when the Software Center is set to lock new apps
> to the Launcher.
>
> I believe this is really bad since this is going to be the default
> behavior.
>
> I'm on a Intel Graphics machine (lspci output attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architecture: i386
> Date: Fri Apr 13 17:53:46 2012
> InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386
> (20120225)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=pt_BR:pt:en
> TERM=xterm
> PATH=(custom, no user)
> LANG=pt_BR.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-center
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/981168
>
> Title:
> Regression: Installing apps causes a terrible visual glitch-- have to
> restart X.org.
>
> Status in Unity:
> Fix Released
> Status in “unity” package in Ubuntu:
> Fix Released
> Status in “unity” source package in Precise:
> Fix Released
>
> Bug description:
> [Test Case]
> Hard to find a solid test case for this bug, as it was machine-specific
> as well.
> 1. Install any application from Software Center
> -> Verify that no visual glitches (window hiding, disappearing,
> graphical artifacts) appear.
>
> [Regression Potential]
> Broken Software Center integration related visuals.
>
> Original description:
>
> Installing any GUI app from the software center breaks the session
> with a visual glitch that hides everything. This is probably related
> to the new animation when installing apps (the icon flying to the
> Launcher), because it only happens when the Software Center is set to
> lock new apps to the Launcher.
>
> I believe this is really bad since this is going to be the default
> behavior.
>
> I'm on a Intel Graphics machine (lspci output attached)
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: software-center 5.2
> ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
> Uname: Linux 3.2.0-23-generic-pae i686
> ApportVersion: 2.0.1-0ubuntu2
> Architec...

Read more...

Ok, I don't know if this is related, but I tested Quantal today with the latest updates and the problem is back. Exactly the same way as before.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers