Dragging windows around is slow/sluggish/laggy when multiple monitors are enabled

Bug #874619 reported by Pior Bastida on 2011-10-14
180
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Ubutter
Undecided
Unassigned
Unity
Fix Released
Undecided
Daniel van Vugt
5.0
Fix Released
Undecided
Tim Penhey
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Test Case]
A performance fix, just make sure that icon movement is fast.

[Regression Potential]
Visual regressions, shell drawing problems. Big change, many regression potentials.

Original description:

Description: Ubuntu 11.10 / 3.0.0-12-generic #20-Ubuntu
Quadro NVS 290 - Dual screen

Display is too slow to be usable. Moving windows or icon is sluggish.
Switching from Nouveau to Nvidia proprietary driver helps a bit but the issue is the same.

I found 2 ways to "fix" this issue:
 * disabling Ubuntu Unity Plugin in CompizConfig Setting Manager
 * disabling one screen

Disabling "Sync to VBlank" doesn't help
Upgrading the nvidia driver with ppa:ubuntu-x-swat doesn't help

Related branches

Dave Gilbert (ubuntu-treblig) wrote :

I guess either the X server or Unity.

Pior: Can you add to the bug report your /var/log/Xorg.0.log

affects: ubuntu → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Incomplete
Falk (andreas-mockel) wrote :

I have the exact same problem with my Quadro NVS 290 - Dual screen at work.
All other computers that is updated worked perfect, but this one is almost unusable..

Is there any way I can help with a bug report on this?

Falk (andreas-mockel) wrote :

Added this bug as a duplicate of #877438 where I have attached some debug logs.

Bo Nygaard Bai (bai-v) wrote :

This bug is NOT specific to Nvidia.

I can confirm it on ATI using both the open source radeon and the closed source fglrx drivers.

The problem seems to be linked to compiz on muti-screen

Bo Nygaard Bai (bai-v) on 2012-01-04
tags: added: fglrx radeon
tags: added: compiz
Bo Nygaard Bai (bai-v) wrote :

I have spend a lot of time trying different setups to test this. The conclusion seems to be:

1) The problem is apparent on both ATI and Nvidia hardware.

2) It only occurs on multiscreen setups

3) It only and always occurs when the Unity plugin to Compiz is active.

Simple reproduction can be done by:

Standard unity desktop session across multiple screens.

Run the attached python program in a fullscreen terminal on one screen.

Try typing in another terminal on another screen.

Python program to spout lines:
----
import time
import sys

try:
    lps=float(sys.argv[1])
except IndexError:
    lps=0

a=0
while True:
    a+=1
    print "Dette er lang linie nummer %d som skal vise om vi kan lave hurtig scroll" % a
    if lps > 0:
        time.sleep(1.0/lps)
----

Bo Nygaard Bai (bai-v) wrote :

This is not a duplicate of bug #877438 since it does not seem to be caused by specific drivers.

This bug deals with Compiz/Unity plug-in on any driver in a multi-screen setup.

The python test program should be run like this:

 python test_prog.py 60

The last argument is number of lines per second of output.

Bo Nygaard Bai (bai-v) on 2012-01-11
tags: removed: fglrx nouveau nvidia radeon
Owen Williams (ywwg) wrote :

I see this problem too, but I only have one screen. Interaction gets worse and worse, and compiz/Xorg CPU usage goes up and up until things get really slow. Disabling unity plugin in ccsm fixes it.

Kalle (k-kalle) wrote :

I have encountered it on many older ati and nvidia graphic cards that normally run desktop with compiz smoothly (on single screen mode). Disabling unity plugin "solves" the slow and choppy desktop problem.

Omer Akram (om26er) wrote :

Is that in Precise? we have a lot of performance improvments + improved multimonitor support in precise. Even the unreleased version of Unity that will be 5.4 have a big performance improvement where the desktop would slow down over the usage of some time.

Bryce Harrington (bryce) wrote :

[Needs retested against precise]

Changed in unity (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Omer Akram (om26er) on 2012-03-28
Changed in unity:
status: New → Incomplete
ecoxmit (ecoxmit) wrote :

I have the same problem. Nvidia proprietary drivers with ubuntu 12.04.

summary: - Unity compiz plugin makes display slow on multi-screen
+ Dragging windows around is slow/sluggish/laggy when multiple monitors
+ are enabled
Changed in compiz-core:
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz (Ubuntu):
status: New → Confirmed
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-core:
milestone: none → 0.9.8.0
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Leo Unglaub (leo-unglaub) wrote :

Hi,
i have the same problem on my 12.04 (unity 5.10.0-0ubuntu6) Laptop. I have a Intel® Core™ i7-2720QM CPU @ 2.20GHz × 8 with 12 GB DDR3 RAM and an ATI GPU. I am using the open source driver and not the properitary one.

the Problem: If i enable my 3 screens, everything starts lagging on the screen. If i only use my Laptop i have no problem with that.

Please let me know if you need more informations.

Greetings
Leo

Daudi Amani (dsaronin) wrote :

I have this same issue, on both upgraded 11.10 and newly installed 12.04 .. but only in twinview mode with two monitors on my workstation. Display response to uner interaction (mouse clicks, movements, etc) is excessively slow: about 20s per action (click, move window, etc)

I do not have this issue on my upgraded 11.10 on my Gateway NV79 notebook with external monitor in twinview.

Hardware specs for both systems are:

HAVE ISSUE
=========================
Ubuntu 12.04
3.2.0-24-generic-pae #37-Ubuntu SMP i686 i386 GNU/Linux
ASUS P5E WS PRO motherboard REV 1.01g WITH iNTEL cORE2 qUAD q6600 @ 2.40GHZx4 6GiB ddr2
VIDEO: nVidea EVGA 320-P2-N811-AR GeForce 8800GTS 320MB 320-bit GDDR3

lspci -nn | grep VGA
  VGA compatible controller [0300]: NVIDIA Corp G80 [GeForce 8800 GTS] [10de:0193] (rev a2)

DOES NOT HAVE ISSUE
==========================
Ubuntu 11.10
3.0.0-19-generic #33-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
Gateway Notebook NV79

lspci -nn | grep VGA
  00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12)

lshw -c video
  *-display
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:42 memory:d0000000-d03fffff memory:c0000000-cfffffff ioport:3050(size=8)

Let me know if any further information would be helpful

Changed in compiz:
assignee: nobody → Daniel van Vugt (vanvugt)
importance: Undecided → Medium
status: New → Confirmed
Changed in compiz:
milestone: none → 0.9.8.0
Changed in compiz-core:
milestone: 0.9.8.0 → none
Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
status: Incomplete → In Progress
milestone: none → 6.0
no longer affects: compiz
no longer affects: compiz-core
no longer affects: compiz (Ubuntu)
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2470

Changed in unity:
status: In Progress → Fix Committed

Awesome!! Thank you Daniel!!

On 07/03/2012 08:53 PM, Daniel van Vugt wrote:
> Fix committed into lp:unity at revision 2470
>
> ** Changed in: unity
> Status: In Progress => Fix Committed
>

Daniel van Vugt (vanvugt) wrote :

Daudi, your problems described in comment #13 sound so severe that you might even have a different bug :(

Daudi Amani (dsaronin) wrote :

It crept in back in February after some random 11.10 update. After that,
it was awful.
I reformated disk, did a fresh (not an update) install of 12.04 .. I'm
using dual monitors twinview now without any problem. But I did the
install with just a single monitor and Unity 2D before trying twinview dual.

On 07/03/2012 10:24 PM, Daniel van Vugt wrote:
> Daudi, your problems described in comment #13 sound so severe that you
> might even have a different bug :(
>

Janusz (yorashtan2) wrote :

This delicious commit can be tested ppa:unity-team/staging

Janusz (yorashtan2) wrote :

Umm not sure if it's been merged yet. Sorry for bug spam.

Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.8 KiB)

This bug was fixed in the package unity - 6.0.0-0ubuntu1

---------------
unity (6.0.0-0ubuntu1) quantal-proposed; urgency=low

  [ Didier Roche ]
  * debian/rules, debian/control, debian/unity-autopilot.install:
    - install new unity-autopilot package, containing autopilot bindings and
      test for Unity
    - add some python build-dep for executing setup.py
    - use dh_python2 and add some python:Depends dep for automatic python
      version detection
  * debian/control:
    - remove gnome-desktop dependency: not needed upstream anymore
    - unity Breaks older lenses due to path change
    - remove libgdu in build-dep
  * debian/libunity-core-6.0-5.install, debian/libunity-core-6.0-dev.install,
    debian/control:
    - version bump in libunity-core, change soname

  [ Matthieu Baerts (matttbe) ]
  * Update apport hook for python3 ; thanks to Edward Donovan (LP: #1013171)

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - compiz crashed with SIGSEGV in get_current_slide() from
      unity::BGHash::OnSlideshowTransition() (LP: #889625)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - App icon on the Unity Launcher lost track of running instance
      (LP: #772063)
    - unity crashed with NameError in reset_unity_compiz_profile(): global
      name 'GError' is not defined (LP: #778470)
    - compiz crashed with SIGSEGV in CompWindow::id() from getPaintMask()
      [compizminimizedwindowhandler.h] from unity::UnityWindow::glPaint()
      (LP: #851982)
    - HUD - Formatting of text in the auto-complete is wrong (LP: #939436)
    - [regression] Launcher is silent to screen reader users (LP: #949448)
    - still some accent issues with unity/nux (LP: #950740)
    - [regression] [precise] 3D apps run much slower under Unity (LP: #987304)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - When number of workspaces is set to 1, the Spread no longer works
      (LP: #996604)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Port to libudisks2 (LP: #1012000)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Searching in the HUD freezes unity (LP: #1016239)
    - Dragged icons rendered under dash (LP: #1021541)
    - Regression in Launcher keyboard navigation (with Alt+F1) (LP: #1021549)
    - Unity dash is is much slower/laggy after revision 2469. (LP: #1021665)
    - Dash and Launcher - As soon as a user starts dragging a file from the
      Dash, there is a 'flicker' before the Launcher icons that are valid drop
      receptacles re-saturate (LP: #863230)
    - Dash - when a file is dragged from the Dash (Dash home, file lens, or
      music lens) and dropped on a Launcher icon, the Dash should
      automatically close (LP: #865168)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - Open dash, press Alt+f1 - dash remains open (LP: #919209)
    - application reopens itself when last instance is closed from
      windows/application switcher (LP: #926406)
    - HUD D...

Read more...

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in ubutter:
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity/5.0 at revision 2394

Paweł Jarosz (paweljaroszit) wrote :

Thx Daniel!
Just wanted to add little hint for ubuntu 12.04 users till unity 5.16 arrives... if you start (or restart) Ubuntu without second display attached and plug it after unity starts but before running any apps, then moving windows works without delay.

Btw ... Anyone knows when unity 5.16 will be released?

description: updated
description: updated

Hello Pior, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/unity/5.16.0-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed

I'm no longer able to reproduce this issue with -proposed enabled on 12.04.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.16.0-0ubuntu1

---------------
unity (5.16.0-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * debian/control:
    - Update libgeis-dev and libgrail-dev dependencies in debian/control
  * New upstream release.
    - launcher is not refreshed after user session switch (LP: #1016430)
    - Dragging windows around is slow/sluggish/laggy when multiple monitors
      are enabled (LP: #874619)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - Tooltips backgrounds are not refreshed (no active blur) (LP: #967112)
    - [regression] Unity panel transparency (active blur) not updating properly
      (LP: #865006)
    - [Regression] Hideous low-res icon when using the HUD with autohide
      enabled. (LP: #1035951)
    - Launcher dragged icon is not redrawn when the mouse pointer is not moved
      (LP: #1032700)
    - Black background around after dash is restored (LP: #992516)
    - Refreshing active blur makes the dash painfully slow (LP: #874230)
    - [SRU regression] alt-grave not switching to next window unless 'grave'
      pressed twice (LP: #1035668)
    - [SRU Regression] Unity 5.14 + Nux 2.14: Launcher tooltips are
      incomplete/missing (LP: #1034164)
    - [nvidia] unity crashed in
      nux::GraphicsEngine::QRP_GLSL_1Tex (glDrawArrays) (LP: #1031554)
    - compiz crashed with SIGSEGV in
      unity::ui::EdgeBarrierController::Impl::OnPointerBarrierEvent()
      (LP: #1020075)
    - Much slower OpenGL frame rates with unityshell loaded, than plain compiz
      (LP: #988079)
    - Compiz won't start if "unredirect fullscreen windows" is enabled
      (LP: #980663)
    - [regression] Unity launcher on-screen corruption on resume from suspend
      with nVidia proprietary driver (LP: #915265)
    - Desktop, Launcher and menu bar still visible when screen locked
      (LP: #886605)
    - Unity is visible on top of fullscreen apps (LP: #734908)
    - [nvidia] compiz crashed with SIGSEGV in
      nux::BasePainter::PaintBackground (LP: #982626)
    - Update dependency on the renamed libgeis

  [ Didier Roche ]
  * debian/control:
    - build-dep on latest nux as libgeis-dev and libutouch-geis-dev are
      conflicting (LP: #1047385)
 -- Lukasz 'sil2100' Zemczak <email address hidden> Tue, 11 Sep 2012 10:53:17 +0200

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Cvetan Simsic (cvetan-simsic) wrote :

I am having issues with Radeon HD 6450, with both proprietary and open source drivers. I don't have issues on Ubuntu 12.04, but everything after that yes. Tried both Ubuntu 13.10 and 14.04. I switched to my integrated Intel HD 2000, and didn't have issues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints