unity window resize / movement extreme slow multimonitor

Bug #982263 reported by walterav on 2012-04-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
New
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Symptom/Occurance:
This slow window resize/movement behaviour will not occur when logged into a "lxde" or "gnome(classis)" session on the same machine. But in a unity or unity-2d session, apps like Nautilus, pcmanfm or firefox or chromium-browser the bigger these application windows get, the harder they seem to move or resize especially on a multimonitor setup it becomes incredibly slow.

Affected manufacturers:
After some googling and looking at youtube movies and other ubuntu releases with "unity" I see it doesn't matter which video manufacture is used al be it Nvidia, Intel or AMD/ATI closed or opensource driver, but in case of using the ATi frglx driver it can be worse than it is already now, but some tweaks in CompizSettingsmanager like "quality, vsync, refreshrate" will improve the performace BUT NOT in this scenario in which I'm writing the bug report for.

Packages:
I cannot say if it is unity or compiz, both of them or something else. But other desktop sessions do not seem to be affected. Unless I run LXDE and start unity or unity-2d-shell on top of it, than it becomes as slow and sluggish as unity(2d) itself.

Regression?
I'm running a test setup from the beginning of 12.04 LTS and this annoying behavior has been there from the beginning, until a month ago it seems to be fixed. Running on a multimonitor setup with opensource driver reacted and responded incredibly snappy, even until compiz 0.9.7.4 update last week but, after the update of compiz 0.9.7.6 this weekend it was back sluggish and slow again. I will try to figure it out more exactly.

Possible Fix?
I do have a daily live iso image of ubuntu 12.04 LTS but don't know from which day, but it doesn't show this SLOW/buggy behavior until you logout and login again back to its default live session and than performance becomes slow again.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.10.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,imgpng,unitymtgrabhandles,place,workarounds,session,grid,expo,gnomecompat,compiztoolbox,resize,scale,vpswitch,mousepoll,ezoom,regex,move,wall,unityshell]
CompositorRunning: compiz
CurrentDmesg:
 [ 38.505673] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
 [ 49.504007] eth0: no IPv6 routers present
 [ 1262.164016] usb 1-5: reset high-speed USB device number 3 using ehci_hcd
Date: Sun Apr 15 13:15:26 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 virtualbox, 4.1.12, 3.2.0-21-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-22-generic, x86_64: installed
 virtualbox, 4.1.12, 3.2.0-23-generic, x86_64: installed
GraphicsCard:
 Advanced Micro Devices [AMD] nee ATI RV630 [Radeon HD 2600XT] [1002:9588] (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:01c4]
MachineType: System manufacturer P5K-E
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=1ba52055-30cd-4f0b-bd47-83ebf7135b66 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/08/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1202
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1202:bd09/08/2008:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

walterav (walterav) wrote :
walterav (walterav) wrote :

Regression?

I can confirm that a multimonitor setup on a netbook with ATI/AMD HD6250 and the opensource display driver with Ubuntu 12.04 LTS AMD64(not fully updated) with the package compiz 0.9.7.4 does NOT show this slow/delayed window movement resize behaviour! Unless logout and login back to the desktop can make it react slower and sluggish again.

A daily live ISO of ubuntu AMD 12.04 LTS also doesn't show this behaviour with "compiz" 0.9.7.2.

The package "unity" in all of them was of version 5.8.0-0ubuntu2.

tags: added: delayed placement
walterav (walterav) wrote :

The problem is probably a regression in compiz 0.9.7.6?

description: updated
IanWilson (wilson-ianj) wrote :

Confirm this on a dual Xeon with nvidia quadro.

If you really want make the problem really bad then then running conky too makes it incredibly slow.

walterav (walterav) wrote :

IanWilson are you using opensource Nouveau or closed binary Nvidia Driver?

Do you also happen to have a older ubuntu precise iso image laying around with an older compiz version which did work?

Can you also confirm on a other desktop environment/session on the same system like "lxde" or something else like "gnome-shell" /"gnome-session-fallback" that doesn't use compiz?

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 920650, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

walterav (walterav) wrote :

Update, in the compiz config settings manager > OpenGL: enable the checkbox "sync to vblank" makes the performance a bit better but still not as snappy as before!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers