compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()

Bug #852582 reported by Jeremy Mullinax-Hill on 2011-09-17
56
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Mirco Müller
Unity Distro Priority
Undecided
Unassigned
unity (Ubuntu)
Critical
Mirco Müller
Oneiric
Undecided
Unassigned

Bug Description

SRU TEST CASE

1. Install unity from oneiric-proposed
2. test it does not crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CrashCounter: 1
Date: Sat Sep 17 10:06:17 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f4bea730642 <_ZN11UnityScreenD2Ev+114>: mov (%rdi),%rax
 PC (0x7f4bea730642) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
 UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
 PluginClassHandler<UnityScreen, CompScreen, 0>::get(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 CompManager::initPlugin(CompPlugin*) ()
Title: compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()
UpgradeStatus: Upgraded to oneiric on 2011-09-17 (0 days ago)
UserGroups: adm cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 UnityScreen::~UnityScreen (this=0x1ed7280, __in_chrg=<optimized out>) at /build/buildd/unity-4.16.0/plugins/unityshell/src/unityshell.cpp:311
 UnityScreen::~UnityScreen (this=0x1ed7280, __in_chrg=<optimized out>) at /build/buildd/unity-4.16.0/plugins/unityshell/src/unityshell.cpp:335
 getInstance (base=<optimized out>) at /usr/include/compiz/core/pluginclasshandler.h:170
 PluginClassHandler<UnityScreen, CompScreen, 0>::get (base=0x1c7a1d0) at /usr/include/compiz/core/pluginclasshandler.h:196
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen (this=<optimized out>, s=<optimized out>) at /usr/include/compiz/core/plugin.h:232

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
importance: Medium → Critical
Mirco Müller (macslow) on 2011-10-25
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
Changed in unity (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) on 2011-10-25
Changed in unity:
milestone: none → 5.0.0
milestone: 5.0.0 → 4.26.0
Mirco Müller (macslow) on 2011-10-25
Changed in unity:
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-10-28
visibility: private → public
Tim Penhey (thumper) on 2011-11-14
tags: added: udp
Didier Roche (didrocks) on 2011-11-16
Changed in unity-distro-priority:
status: New → Fix Committed
David Barth (dbarth) on 2011-12-16
Changed in unity:
milestone: 4.26.0 → 4.28.0
Omer Akram (om26er) on 2012-01-05
Changed in unity:
status: In Progress → Fix Released
importance: Undecided → Critical
Omer Akram (om26er) on 2012-01-05
description: updated
Changed in unity (Ubuntu Oneiric):
status: New → Confirmed
Tim Penhey (thumper) on 2012-02-20
tags: added: distro-priority
Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-11
tags: removed: udp

It worked great for about 2 minutes. When I tried to open the fusion menu compiz crashed, attempted to restart and the system froze. I have the latest kernel. I will try to provide you all of the information about the crash as soon as possible. Quite busy at this time.

Jeffrey

-----Original Message-----
From: John Lea
Sent: Wednesday, April 11, 2012 1:21 AM
To: <email address hidden>
Subject: [Bug 852582] Re: compiz crashed with SIGSEGV inUnityScreen::~UnityScreen()

** Tags removed: udp

--
You received this bug notification because you are subscribed to a
duplicate bug report (913558).
https://bugs.launchpad.net/bugs/852582

Title:
  compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()

Status in Unity:
  Fix Released
Status in Unity Distro Priority:
  Fix Released
Status in “unity” package in Ubuntu:
  Fix Released
Status in “unity” source package in Oneiric:
  Confirmed

Bug description:
  SRU TEST CASE

  1. Install unity from oneiric-proposed
  2. test it does not crash

  ProblemType: Crash
  DistroRelease: Ubuntu 11.10
  Package: unity 4.16.0-0ubuntu1
  ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
  Uname: Linux 3.0.0-11-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 1.23-0ubuntu1
  Architecture: amd64
  CrashCounter: 1
  Date: Sat Sep 17 10:06:17 2011
  ExecutablePath: /usr/bin/compiz
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
  ProcCmdline: compiz
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SegvAnalysis:
   Segfault happened at: 0x7f4bea730642 <_ZN11UnityScreenD2Ev+114>: mov (%rdi),%rax
   PC (0x7f4bea730642) ok
   source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
   destination "%rax" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: unity
  StacktraceTop:
   UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
   UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
   PluginClassHandler<UnityScreen, CompScreen, 0>::get(CompScreen*) () from /usr/lib/compiz/libunityshell.so
   CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
   CompManager::initPlugin(CompPlugin*) ()
  Title: compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()
  UpgradeStatus: Upgraded to oneiric on 2011-09-17 (0 days ago)
  UserGroups: adm cdrom dialout lpadmin plugdev sambashare

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/852582/+subscriptions

Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers