compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()

Bug #913558 reported by Jeffrey Mikesell on 2012-01-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Again another WM crashes in 11.10, does any of them work? You state 11.10 I shoud install the oneiric-proposed release with one fix and the other in process. OK, I'll do it again, I started with the oneiric-proposed and I am unable to get any of the WM working I will flood you with bugs, and you can take that to the bank!

How many installs does it take to get a single function 11.10 system working with the ubuntu team 2*32-1

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2.1
ProcVersionSignature: Ubuntu 3.0.0-14.23-server 3.0.9
Uname: Linux 3.0.0-14-server x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CrashCounter: 1
Date: Sun Jan 8 13:47:11 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu-Server 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
ProcCmdline: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fc65e17acf2 <_ZN11UnityScreenD2Ev+114>: mov (%rdi),%rax
 PC (0x7fc65e17acf2) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
 UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
 PluginClassHandler<UnityScreen, CompScreen, 0>::get(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 CompManager::initPlugin(CompPlugin*) ()
Title: compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin ais ajaxterm audio avahi bind bluetooth cdrom colord dialout fax freerad fuse gdm irc kvm landscape libvirtd list lpadmin messagebus netdev netdisco nopasswdlogin ntp openldap pdns plugdev popa3d pulse pulse-access rtkit sambashare saned sasl scanner smmsp smmta ssh ssl-cert stunnel4 sudo timidity utempter vde2-net video winbindd_priv www-data

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #852582, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
visibility: private → public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers