Comment 7 for bug 852582

It worked great for about 2 minutes. When I tried to open the fusion menu compiz crashed, attempted to restart and the system froze. I have the latest kernel. I will try to provide you all of the information about the crash as soon as possible. Quite busy at this time.

Jeffrey

-----Original Message-----
From: John Lea
Sent: Wednesday, April 11, 2012 1:21 AM
To: <email address hidden>
Subject: [Bug 852582] Re: compiz crashed with SIGSEGV inUnityScreen::~UnityScreen()

** Tags removed: udp

--
You received this bug notification because you are subscribed to a
duplicate bug report (913558).
https://bugs.launchpad.net/bugs/852582

Title:
  compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()

Status in Unity:
  Fix Released
Status in Unity Distro Priority:
  Fix Released
Status in “unity” package in Ubuntu:
  Fix Released
Status in “unity” source package in Oneiric:
  Confirmed

Bug description:
  SRU TEST CASE

  1. Install unity from oneiric-proposed
  2. test it does not crash

  ProblemType: Crash
  DistroRelease: Ubuntu 11.10
  Package: unity 4.16.0-0ubuntu1
  ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
  Uname: Linux 3.0.0-11-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 1.23-0ubuntu1
  Architecture: amd64
  CrashCounter: 1
  Date: Sat Sep 17 10:06:17 2011
  ExecutablePath: /usr/bin/compiz
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
  ProcCmdline: compiz
  ProcEnviron:
   PATH=(custom, no user)
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SegvAnalysis:
   Segfault happened at: 0x7f4bea730642 <_ZN11UnityScreenD2Ev+114>: mov (%rdi),%rax
   PC (0x7f4bea730642) ok
   source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
   destination "%rax" ok
  SegvReason: reading NULL VMA
  Signal: 11
  SourcePackage: unity
  StacktraceTop:
   UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
   UnityScreen::~UnityScreen() () from /usr/lib/compiz/libunityshell.so
   PluginClassHandler<UnityScreen, CompScreen, 0>::get(CompScreen*) () from /usr/lib/compiz/libunityshell.so
   CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
   CompManager::initPlugin(CompPlugin*) ()
  Title: compiz crashed with SIGSEGV in UnityScreen::~UnityScreen()
  UpgradeStatus: Upgraded to oneiric on 2011-09-17 (0 days ago)
  UserGroups: adm cdrom dialout lpadmin plugdev sambashare

To manage notifications about this bug go to:
https://bugs.launchpad.net/unity/+bug/852582/+subscriptions