Ubuntu

Dash picks random weird colors (yellow, green), fonts invisible (with blur en- or disabled)

Reported by Sam_ on 2011-08-17
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity
High
Gord Allott
unity (Ubuntu)
High
Gord Allott
Oneiric
High
Gord Allott

Bug Description

Before update dash looked fine.
e.g. http://www.markshuttleworth.com/wp-content/uploads/2011/08/dash_home_11.10_768.png
After update it looks like attached screenshot.
Tested with blur en- and disabled in unity-plugin (CCSM).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.8.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
BootLog:
 fsck from util-linux 2.19.1
 fsck from util-linux 2.19.1
 /dev/sda1: sauber, 216160/1892352 Dateien, 1152561/7568128 Blöcke
 /dev/sda6: sauber, 14990/16605184 Dateien, 1543543/66405888 Blöcke
 modem-manager[832]: <info> ModemManager (version 0.5) starting...
CompizPlugins: [core,bailer,detection,composite,opengl,decor,obs,grid,gnomecompat,vpswitch,mousepoll,wall,compiztoolbox,move,resize,place,imgpng,snap,regex,animation,expo,session,unitymtgrabhandles,ezoom,fade,winrules,workarounds,scale,unityshell]
CompositorRunning: compiz
Date: Wed Aug 17 22:51:24 2011
DistUpgraded: Log time: 2011-07-30 23:24:18.623159
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 bcmwl, 5.100.82.38+bdcom, 3.0-3-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 3.0.0-8-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712] (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:1475]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110423)
MachineType: Hewlett-Packard HP 625
ProcEnviron:
 PATH=(custom, no user)
 LANG=C
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-8-generic root=UUID=4a760393-cea9-45d3-88c0-841b7a37104d ro
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-08-01 (15 days ago)
dmi.bios.date: 12/07/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68DVA Ver. F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1475
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 72.0E
dmi.chassis.asset.tag: CNU1080QP1
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68DVAVer.F.06:bd12/07/2010:svnHewlett-Packard:pnHP625:pvr:rvnHewlett-Packard:rn1475:rvrKBCVersion72.0E:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP 625
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.5.0-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

try to logout and login again or restart unity and let me know if the
problem goes away

Changed in unity (Ubuntu):
status: New → Confirmed

mine looks like this (yes i restarted)

dmiranda (dmiranda) wrote :

mine looks like this (yes i restarted)

Jean-Baptiste Lallement (jibel) wrote :

Same Yellow here than Sam_'s screenshot with a Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

Changed in unity (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-1
summary: - Dash canary yellow, fonts invisible (with blur en- or disabled)
+ Dash picks random weird colors (yellow, green), fonts invisible (with
+ blur en- or disabled)
Sam_ (and-sam) wrote :

After reboot today (before updating) dash looks normal again.

Sam_ (and-sam) wrote :

After recent updates rebooted and dash was green, but transparent and fonts are visible.
Tested, after logout dash colour adapts to background, after reboot it changes it's colour, e.g. green or smoky. Attached screenshots.
Actually if one likes the behaviour it could be a feature, this way it doesn't get boring, because you'll never know which colour it has the next time.

Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :
Sam_ (and-sam) wrote :

Seems Bug #824886 isn't fixed sufficiently.
unity:
  Installed: 4.8.2-0ubuntu4
  Candidate: 4.8.2-0ubuntu4
  Version table:
 *** 4.8.2-0ubuntu4 0

David Barth (dbarth) on 2011-08-26
Changed in unity (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jay Taoko (jaytaoko)
Changed in unity:
milestone: none → 4.12.0
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
status: New → Confirmed

The issue seems to have fixed with 4.10.0 though could anyone affected
confirm that as well?

Paul Sladen (sladen) wrote :

I managed to get a screenshot of a yellow Alt-tab switcher; I've also seen the Launcher go this colour (but not the whole rest of the screen as in the images above).

Jamie Strandboge (jdstrand) wrote :

Recent updates improved this significantly for me. However, if I use the 'Aubergine Sea' background, while the colors 'match', the resulting Dash is not aesthetically pleasing in the least (way to much purple particularly in the Launcher and Panel).

Sam_ (and-sam) wrote :

After reboot and logout dash adapts to desktop background, no weird colours.
unity:
  Installed: 4.10.2-0ubuntu2
  Candidate: 4.10.2-0ubuntu2
  Version table:
 *** 4.10.2-0ubuntu2 0

Martin Pitt (pitti) on 2011-08-31
Changed in unity (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Neil J. Patel (njpatel) wrote :

The loading of the background colour is now fixed, selecting the best colour for the background is being discussed at this bug: https://bugs.launchpad.net/ayatana-design/+bug/837993

Changed in unity:
assignee: Jay Taoko (jaytaoko) → Gord Allott (gordallott)
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2011-09-01
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
assignee: Jay Taoko (jaytaoko) → Gord Allott (gordallott)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.12.0-0ubuntu1

---------------
unity (4.12.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - P3: [natty] Cannot click on indicators (LP: #819202)
    - Icons not visible in the launcher or alt-tab switcher (LP: #833905)
    - [dash] Search field in Unity can not support iBus (LP: #663776)
    - [dash] preferred applications are not stored in GConf anylonger
      (LP: #805063)
    - SysTray icons have a white square background in Unity. (LP: #823407)
    - new dash does not fit a normal netbook screen (LP: #825370)
    - Dash picks random weird colors (yellow, green), fonts invisible (with
      blur en- or disabled) (LP: #828363)
    - Music Lens doesn't display items until you search (LP: #824892)
    - Dash - Adjustments to stateful behaviour (LP: #838667)
    - Dragging from dash to launcher still doesn't work (LP: #824833)
    - Click on 'More Apps' et al closes the dash (LP: #824842)
    - cannot paste into dash (particularly relevant for alt+f2) (LP: #736222)
    - Ctrl X doesn't cut selected text in Dash search field (LP: #737731)
    - Ctrl+C doesn't copy selected text in Dash search field (LP: #737732)
    - The indicators shows a big white square when systray whitelisted
      (LP: #822672)
    - ARM FTBFS fix (LP: #834576)
  * debian/control:
    - build on latest nux
  * debian/rules:
    - bump shlibs
 -- Didier Roche <email address hidden> Thu, 01 Sep 2011 17:33:06 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking
To post a comment you must log in.