systray appears behind main panel/one pixel for some qt applications

Bug #755234 reported by Jonathan Almeida on 2011-04-09
126
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
unity-2d
Undecided
Unassigned
unity (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: unity

Applications started in systray (eg. Skype) are not seen in the main panel as shown in the picture: http://img641.imageshack.us/i/nontransparent.png/

They are however running and can be seen by reducing the transparency value of the panel closer to 0 as shown in the picture: http://img231.imageshack.us/i/transparentc.png/

Icons cannot be accessed by left-click or right-click.

Note: The value the transparency of the panel in both the pictures.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.8.4-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl fglrx
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,shift,move,wall,resize,place,vpswitch,compiztoolbox,imgpng,mag,grid,commands,water,gnomecompat,unitymtgrabhandles,regex,snap,session,zoom,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sat Apr 9 00:08:49 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.840, 2.6.38-8-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-7-generic, x86_64: installed
 bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series] [1002:68e0] (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0413]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
InstallationMedia___: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110329.1)
JockeyStatus:
 kmod:wl - Broadcom STA wireless driver (Proprietary, Enabled, In use) [auto-install]
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Dell Inc. Studio 1558
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=aa8f4543-9ca0-4741-98c2-a72fc546caf0 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature__: Ubuntu 2.6.38-8.41-generic 2.6.38.2
ProcVersionSignature___: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/12/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A11
dmi.board.name: 0874P6
dmi.board.vendor: Dell Inc.
dmi.board.version: A11
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A11
dmi.modalias: dmi:bvnDellInc.:bvrA11:bd10/12/2010:svnDellInc.:pnStudio1558:pvrA11:rvnDellInc.:rn0874P6:rvrA11:cvnDellInc.:ct8:cvrA11:
dmi.product.name: Studio 1558
dmi.product.version: A11
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.4+bzr20110407-0ubuntu2
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu11
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

Jonathan Almeida (jonalmeida) wrote :
Jonathan Almeida (jonalmeida) wrote :

I should also note that a restart fixes the problem but the bug occurs randomly.

Omer Akram (om26er) wrote :

Does this issue happen with every theme or is specific to this one? Could you tell the name of the theme ?

Changed in unity (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Jonathan Almeida (jonalmeida) wrote :

The theme is Faenza: http://tiheum.deviantart.com/art/Faenza-Icons-173323228

I have noticed this happening with other themes as well, but I haven't tested this with the default Ubuntu icon pack.

I will also try to find out what was my last action before this happens.

Didier Roche (didrocks) on 2011-04-21
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in unity:
milestone: none → 3.8.12
Fabio Rodriguez (realgt) wrote :

in my case, this only happens on dual monitors, and a restart does not fix it. This is with the default unity theme
I posted some screenshots here:
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/768313

David Barth (dbarth) on 2011-04-22
Changed in unity:
milestone: 3.8.12 → 3.8.14
Fabio Rodriguez (realgt) wrote :

i've found a partial workaround by doing:

unity --replace

so i created a desktop launcher which runs that command and it helps. The systray correctly fits now on the far right edge but the ubuntu icon on the top left corner is still missing.

Didier Roche (didrocks) on 2011-05-03
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Olivier Tilloy (osomon) wrote :

I cannot reproduce the issue with unity-2d (tested with skype).

Changed in unity-2d:
status: New → Invalid
Didier Roche (didrocks) on 2011-05-18
summary: - systray appears behind main panel
+ systray appears behind main panel/one pixel for some qt applications

I had this bug with pidgin.
I removed unity-2d from my system few days ago.

Il 17/05/2011 11:12, Olivier Tilloy ha scritto:
> I cannot reproduce the issue with unity-2d (tested with skype).
>
> ** Changed in: unity-2d
> Status: New => Invalid
>

Olivier Tilloy (osomon) wrote :

@igi: you were seeing a different issue (bug #703389).

This is probably because the affected applications (e.g. Skype) start on startup, but are up before unity. See https://bugs.launchpad.net/ubuntu/+source/unity/+bug/765269 comments 3 and 5.

Neil J. Patel (njpatel) on 2011-05-25
Changed in unity:
assignee: Sam "SmSpillaz" Spilsbury (smspillaz) → Neil J. Patel (njpatel)
assignee: Neil J. Patel (njpatel) → Sam "SmSpillaz" Spilsbury (smspillaz)
David Barth (dbarth) on 2011-05-31
Changed in unity:
milestone: 3.8.14 → 3.8.16
David Barth (dbarth) on 2011-06-15
Changed in unity:
milestone: 3.8.16 → alpha2
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
assignee: nobody → Sam Spilsbury (smspillaz)
kevin (kevinsiji) wrote :

I am also having this issue. I am logging into Gnome classic (without effects), not to Unity.

Alexandre Otto Strube (surak) wrote :

Not really fixed. Fully-updated daily precise pangolin.

To post a comment you must log in.