Launcher unhides and stays unhidden when dragging elements in Opera

Bug #741731 reported by Hernando Torque on 2011-03-24
76
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
Medium
Jason Smith
unity (Ubuntu)
Medium
Jason Smith

Bug Description

Binary package hint: unity

I'm using the latest build of Opera (http://snapshot.opera.com/unix/betaplus_11.10-2053/) and am facing a problem where the launcher would unhide and stay unhidden when I drag elements of Opera's UI or in a website (like dragging an image).

Not only does it stay unhidden, it also doesn't respond to clicks until I quit Opera.

This looks similar to bug 724986, but I was asked on IRC to open a separate bug report.

Happening with Unity 3.6.8 as well as with r1023, hiding mode 'Autohide'.

description: updated
Hernando Torque (htorque) wrote :

The problem does survive a Unity restart. Is this something worth reporting upstream?

Didier Roche (didrocks) wrote :

Hey Hernando.

So yeah, it seems we don't detect the "drop" event of Opera and so that the X state still see Opera as dragging and dropping. It would be interesting to know what they do, if you can report a bug to them (not a unity bug for me, but if they can just give some hints so that we workaround that case…).

Alex Launi (alexlauni) wrote :

This doesn't happen in chrome, so opera's DND is doing something wrong- we should have some stopgap measure nonetheless.

tags: added: autohide
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Hernando Torque (htorque) wrote :

I reported this upstream as bug DSK-332091 (also pointing to this report). Unfortunately there doesn't seem to be a public bug tracker, nor am I supposed to get any feedback unless Opera devs need more information. My current "solution" is to disable launcher hiding, because the bug is way too easy to trigger.

Jason Smith (jassmith) wrote :

Fixed. Opera, Qt, dont quite follow the XDND spec exactly. But I have hacked around it

Changed in unity:
assignee: nobody → Jason Smith (jassmith)
milestone: none → 3.8.4
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Hernando Torque (htorque) wrote :

Before building Unity with that commit, I've observed the following:

* You can stop the sticky unhide by triggering a short unhide like the one in bug 724986. Other short unhides: dragging tabs in Chromium, dragging desktop icons, dragging text in gedit, dragging layers in GIMP, dragging a gnome-terminal tab outside of the window.

* The gnome-terminal can also cause a sticky unhide:
1.) Open gnome-terminal
2.) Open a second tab
3.) Drag the tab outside of the window, back again, then release and make sure to move the pointer away from the tab
-> launcher will unhide and hide again
4.) Repeat 3.
-> launcher will do a sticky unhide unless you hover one of the tabs to get a tooltip or open the context menu (see attached screencast).

---

Now I built Unity with that commit and I see different results for two systems:

System 1 (x86, nvidia-current, a fresh beta 1 install):

- Still getting the sticky unhides, but only for Opera.
- Still can undo them with short unhides.
- gnome-terminal now also does a short instead of a sticky unhide.

System 2 (x64, -intel):

- No more sticky unhides (Opera, gnome-terminal)
- Both act like short unhides.
- Most of the time the mouse pointer stays in the dragging state (pointer icon is a hand) until I do a left-click (Opera)

Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Hernando Torque (htorque) wrote :

This is not fixed on my x86/nvidia-current machine.

Changed in unity:
status: Fix Released → New
Changed in unity (Ubuntu):
status: Fix Released → New
Didier Roche (didrocks) wrote :

yeah, there is still an issue, confirmed

Changed in unity:
milestone: 3.8.4 → 3.8.6
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Jason Smith (jassmith) wrote :

I don't know what else to do here really...

Applications are basically saying they are performing an XDND when there are not. I did my best to hack around this but eventually I have to give up.

Jason Smith (jassmith) wrote :

And wait for a proper fix from upstreams.

Jason Smith (jassmith) wrote :

Okay so on further debugging something Opera does causes the X server to think the mouse button is still depressed. At this point I don't know what we can do about this. When you click on opera to end the bad state things return to normal. This is a wont fix at this point.

Changed in unity:
status: Triaged → Won't Fix
Omer Akram (om26er) on 2011-04-09
Changed in unity (Ubuntu):
status: Triaged → Won't Fix
Gonçalo Fernandes (ilogico) wrote :

So it's Opera's problem? And Qt Designer's?

Bilal Akhtar (bilalakhtar) wrote :

Yes, its the fault of Opera and Qt Designer. These applications don't seem to be following the XDND spec (as said by Jason above).

Mark Baas (mark-baas123) wrote :

So is this bug reported upstream?

Hernando Torque (htorque) wrote :

Yes (reference number DSK-332091), but a fix won't be in Opera 11.10 which has been released today.

Also affects dragging items in Mendeley 0.9.9.2 (sticky unhide, resolved either by closing the application or by triggering a short unhide using one of the above methods).

Malin Bruland (malinkb) wrote :

I can confirm this bug too. To me I couldn't reproduce it on a fresh Ubuntu 11.04 install, but after just few minutes it started again and a reboot dosen't solve it.

I know a person working at Opera, but on the mac-team, but maybe I could ask him to check the status of DSK-332091 and wehter it will be fixed or not, and when.

Malin Bruland (malinkb) wrote :

The person I know who works for Opera have moved the bug in the right direction, the bug is not been treated yet.

Hernando Torque (htorque) wrote :

Awesome! Hopefully this gets fixed in Opera 11.50.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers