Launcher "forgets" to hide (especially when using Opera)

Bug #741193 reported by cmyrland on 2011-03-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Incomplete
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

The Launcher often either doesn't hide at all, or suddenly pops back into view when using Opera Web Browser. When the bug appears I fix it by opening TomBoy and dragging the window over the Launcher. Then it suddenly pops back to life and hides again, even for Opera and other apps. Sometimes it also becomes "solid", as in "not transparent" until I drag tomboy over it.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.6-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.DP.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.DP.2:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.HDMI.A.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1366x768
 edid-base64: AP///////wAw5PcBAAAAAAATAQOAHRB4Cu4llVlViykiUFQAAAABAQEBAQEBAQEBAQEBAQEBPhxWoFAAFjAwIDUAJaUQAAAZAAAAAAAAAAAAAAAAAAAAAAAAAAAA/gAAAABMR0Rpc3BsYXkKAAAA/gBMUDEzM1dIMi1UTEEzAMI=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Wed Mar 23 20:10:38 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:0229]
   Subsystem: Acer Incorporated [ALI] Device [1025:0229]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110317)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110317)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110317)
MachineType: Acer Aspire 3810T
ProcEnviron:
 LANGUAGE=nb_NO:en
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic-pae root=UUID=3704c4df-44b8-4361-abda-cca0b2131a03 ro quiet splash vt.handoff=7
ProcVersionSignature_: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
ProcVersionSignature__: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/26/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.27
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire 3810T
dmi.board.vendor: Acer
dmi.board.version: PSMBOU-1234567
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: None
dmi.modalias: dmi:bvnAcer:bvrV1.27:bd03/26/2010:svnAcer:pnAspire3810T:pvrV1.27:rvnAcer:rnAspire3810T:rvrPSMBOU-1234567:cvnAcer:ct10:cvrNone:
dmi.product.name: Aspire 3810T
dmi.product.version: V1.27
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4git20110322-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6

cmyrland (carl-rahien) wrote :
Mirco Müller (macslow) wrote :

Have you tried this with unity 3.6.8? Could reproduce it with the newer version? I grabbed and installed opera and have been using it for a bit over two hours and didn't run into the described problems. Could very well be, that this is already fixed in the newer version of unity.

Changed in unity:
status: New → Incomplete
Changed in unity (Ubuntu):
status: New → Incomplete
cmyrland (carl-rahien) wrote :

I think I've discovered the cause. If you grab and drag content on a page in Firefox, the launcher appears (I guess for adding pictures to Shotwell, copying text to gedit or whatev.) I think the same happens on Opera, but some bug between launcher and opera causes the launcher to crash (at least partly) if no content is dropped onto it. Could somebody try to verify this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers