compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()

Bug #741652 reported by Ondergetekende on 2011-03-24
574
This bug affects 103 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Neil J. Patel
unity (Ubuntu)
Critical
Neil J. Patel
Natty
Critical
Neil J. Patel
Oneiric
Critical
Neil J. Patel

Bug Description

Binary package hint: unity

I changed the theme from "dust" (which I used in 10.10) to "ambiance". This crash resulted.
Compiz rebooted correctly and the settings were correctly propagated.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: unity 3.6.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Thu Mar 24 12:48:27 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f4f85d21204 <_ZN18SimpleLauncherIcon18OnIconThemeChangedEP13_GtkIconThemePv+36>: mov (%rdi),%rax
 PC (0x7f4f85d21204) ok
 source "(%rdi)" (0x12345678) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 SimpleLauncherIcon::OnIconThemeChanged(_GtkIconTheme*, void*) () from /usr/lib/compiz/libunityshell.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
UpgradeStatus: Upgraded to natty on 2011-03-24 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Ondergetekende (kvdveer) wrote :

StacktraceTop:
 SimpleLauncherIcon::OnIconThemeChanged (icon_theme=<value optimized out>, data=0x2dd4360) at /build/buildd/unity-3.6.8/src/SimpleLauncherIcon.cpp:133
 g_closure_invoke (closure=0x2df9150, return_value=0x0, n_param_values=1, param_values=0x2b63d40, invocation_hint=0x7fffd378f270) at /build/buildd/glib2.0-2.28.4/./gobject/gclosure.c:767
 signal_emit_unlocked_R (node=<value optimized out>, detail=0, instance=0x15b8090, emission_return=0x0, instance_and_params=0x2b63d40) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:3252
 g_signal_emit_valist (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>, var_args=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:2983
 g_signal_emit (instance=<value optimized out>, signal_id=<value optimized out>, detail=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./gobject/gsignal.c:3040

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
status: New → Fix Committed
Changed in unity:
importance: Undecided → Medium
status: New → Fix Committed

I had this one whithout any theme change.

Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: none → 3.8.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.8-0ubuntu2

---------------
unity (3.6.8-0ubuntu2) natty; urgency=low

  * Backport from trunk:
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - launcher hide a little bit too early if you bring the current window next
      to it (LP: #741761)
    - "Files & Folders" tooltip says "Files &amp; Folders" (LP: #741654)
    - Time & Date has no application quicklist menuitem title (LP: #741680)
 -- Didier Roche <email address hidden> Thu, 24 Mar 2011 16:07:44 +0100

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released

for me the same thing I just installed ccsm

Gregg Chappell (greggchappell) wrote :

I seem to get this whenever I remove something through Software Center.

DFOXpro (dfoxpro) wrote :

i get this crash on ubuntu natty when i try to open games list on apps icon

@Amaeth: Are you using which version of unity? To know, run 'dpkg -l unity' on terminal. Make sure that you are using the latest version (3.6.8-0ubuntu3 at moment).

Florin (tlenze) wrote :

I am using 3.6.8-0ubuntu3, and I just experienced this bug.

I can't reproduce this bug here anymore.

Anyone besides Florin is experiencing this bug with unity 3.6.8-0ubuntu2 or higher?

hello, I get this error with unity 3.6.8 compiz 0.9.4.0
in particular, this happens to me at the end of the installations that I do with PlayOnLinux

unity 3.6.8-0ubuntu3

Changed in unity:
status: Fix Committed → Confirmed
Antono Vasiljev (antono) wrote :

got this crash with unity 3.6.8-0ubuntu3
and compiz 1:0.9.4git20110322-0ubunt

Didier Roche (didrocks) on 2011-03-28
Changed in unity (Ubuntu):
status: Fix Released → Triaged
tags: added: bugpattern-needed
Lars Renström (lars-renstrom) wrote :

I experienced the crash while updating my system via Terminal using apt-get dist-upgrade.

EmyrB (emyr) wrote :

Still crashing on Unity 3.6.8-0ubuntu3 with Compiz 1:0.9.4git20110322-0ubuntu5. It crashes every time I open an application, it doesn't matter if its a terminal window, firefox or anything. Compiz is very unstable.

EmyrB (emyr) wrote :

Sorry I forgot to add, I haven't touch any part of the theme, its just the default that Ubuntu installs.

Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
tags: added: bugpattern-written
removed: bugpattern-needed
Lojjik Braughler (llbraughler) wrote :

I still receive this error intermittently.

When this crash happens?
The crash will occurs when the icon theme is changed or the icon cache is updated (and here we can include install/upgrade/remove software).

Why this crash happens?
I really don't know... Everything looks fine on code.

Didier Roche (didrocks) on 2011-03-29
Changed in unity:
status: Confirmed → Triaged
Neil J. Patel (njpatel) wrote :

Stacktrace was interesting, while looking up an icon, there might be a theme-changed signal and therefore our callback is called. However before we lookup an icon, we unreference the last icon but don't set it to NULL, and hence the callback accesses and invalid pointer.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
status: Triaged → Fix Committed
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Committed
status: Fix Committed → In Progress
importance: Medium → Critical
Changed in unity:
importance: Medium → Critical
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity (Ubuntu Natty):
status: In Progress → Fix Committed
Simon Charette (charettes) wrote :

Crash after every update.

Antono Vasiljev (antono) wrote :

Same here. Crash after update.

Alex Kras (akrasnoborodkin) wrote :

Crashed after last update serveral minutes ago. Crashed to times, first time when updates installation finished second time when clicked close in update manager.

Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released

alt+tab

Michael Terry (mterry) wrote :

I just got a bug report on an updated oneiric system that led me here. This might have resurfaced?

Also affected me on ubuntu 11.10 alpha3 with last updates, when i tried to tweet image file with gwibber.

Taylor (homeofpoe) wrote :

unity 4.8.0

I think this is occurring for me during an alt+tab. To note, two alt tab displays come up when I use that -- the standard version and the newer one.

Ryan Kitty (gothickitty93) wrote :

I just experienced this on oneiric after installing gnome-tweak-tool using Synaptic Package Manager.

tags: added: oneiric
Doug McMahon (mc3man) wrote :

This happens quite often in 11.10 - latest when using the Software-Center to remove a package. Apport will not create a new report, only points to this bug.

I added a task for Oneiric since it seems to be a regression there.

Changed in unity (Ubuntu Oneiric):
status: Fix Released → Triaged
milestone: ubuntu-11.04-beta-1 → ubuntu-11.10-beta-1
tags: added: regression-release
Neil J. Patel (njpatel) on 2011-08-16
Changed in unity:
status: Fix Released → Fix Committed
Changed in unity (Ubuntu Natty):
status: Fix Released → Triaged
status: Triaged → Fix Released
Changed in unity:
milestone: 3.8.2 → 4.8.0

Seems that a fix was committed yesterday....
I just had the same right now when starting a video and several times last night on various occasions.
Fully up to date oneiric..

Fix committed does not mean fix released :) When there is a new unity
update the status will be changed to reflect the fix.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.8.0-0ubuntu3

---------------
unity (4.8.0-0ubuntu3) oneiric; urgency=low

  * Backport r1373 to fix a segfault happening on theme updates (lp: #825587)
    (lp: #741652)
  * Backport r1380 to fix an alt-tab switcher segfault (lp: #825148)
  * Backport r1381 to fix a session start compiz segfault (lp: #825040)
 -- Sebastien Bacher <email address hidden> Thu, 18 Aug 2011 11:21:50 +0200

Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Released
Jaime Rave (jaimerave) wrote :

I'm still able to reproduce the error using unity - 4.8.0-0ubuntu3 and then trying to open any application with Wine.

A command as simple as winecfg triggers this bug, so I think is not fixed yet.

reopening, just got it launching gvim with unity 4.8.0-0ubuntu3

Changed in unity (Ubuntu Oneiric):
status: Fix Released → Triaged

trace with latest unity (4.8.0-0ubuntu3)

Neil J. Patel (njpatel) wrote :

Alrighty, just pushed another fix for the failure on the last trace.

Changed in unity:
milestone: 4.8.0 → 4.10.0
Omer Akram (om26er) on 2011-08-25
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.