Ubuntu

dynamic quicklists are not working

Reported by Omer Akram on 2011-03-04
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Didier Roche
unity-2d
High
Olivier Tilloy
unity-2d (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: unity

Unity support dynamic quicklists by the libunity API. This bug is about getting them shown by unity.

---
Note than in Maverick right clicking on the tile of an application like tomboy which have their app-indicator in the panel exported their menu items to quicklist. This is not the case anymore in Natty, it has to be explicitly set by the application to export to the launcher.
---

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Fri Mar 4 13:33:16 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110304)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Omer Akram (om26er) wrote :
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Medium
milestone: none → 3.6.4
status: New → Triaged
Didier Roche (didrocks) on 2011-03-07
Changed in unity (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Didier Roche (didrocks) on 2011-03-14
Changed in unity:
milestone: 3.6.6 → 3.6.8
assignee: Didier Roche (didrocks) → Mirco Müller (macslow)

@macslow now that you are on this it might also make sense to assign bug #735920 "Launcher emblem- and progress integration broken" to you? It seems very related

Neil J. Patel (njpatel) on 2011-03-23
Changed in unity:
assignee: Mirco Müller (macslow) → nobody
milestone: 3.6.8 → backlog
Changed in unity-2d:
status: New → Confirmed
importance: Undecided → Medium
Olivier Tilloy (osomon) wrote :

Unity-2d, like unity, uses bamf indicators to build the dynamic quicklists. In natty, it seems those indicators are not exposed by bamf any longer (is this a regression?), at least not on D-Bus at org.ayatana.bamf.

Didier Roche (didrocks) on 2011-03-30
Changed in unity:
milestone: backlog → 3.8.2
assignee: nobody → Didier Roche (didrocks)
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
milestone: none → 3.10

Sorry, still not working for me in unity-3.8.2-0ubuntu1. Testing with my progress.vala script from bug #735920 https://bugs.launchpad.net/ubuntu/+source/libunity/+bug/735920/+attachment/1914623/+files/progress.vala

Changed in unity:
milestone: 3.8.2 → 3.8.4
status: Fix Released → Confirmed
Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Michael Terry (mterry) wrote :

I have a branch merge filed that makes your test case work: https://code.launchpad.net/~mterry/unity/initial-quicklist/+merge/56099

Michael Terry (mterry) on 2011-04-04
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity-2d:
importance: Medium → High
Didier Roche (didrocks) on 2011-04-05
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-07
Changed in unity:
status: Fix Committed → Fix Released

When they will be on the PPA? I want to try it !
El 07/04/2011 17:22, "Didier Roche" <email address hidden> escribió:
> ** Changed in: unity
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (753575).
> https://bugs.launchpad.net/bugs/729074
>
> Title:
> dynamic quicklists are not working
>
> Status in Unity:
> Fix Released
> Status in Unity 2D:
> Confirmed
> Status in “unity” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: unity
>
> In Maverick right clicking on the tile of an application like tomboy
> which have their app-indicator in the panel exported their menu items
> to quicklist. This is not working in Natty.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.0-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> Architecture: i386
> CompizPlugins:
[core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> Date: Fri Mar 4 13:33:16 2011
> LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110304)
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/729074/+subscribe

Omer Akram (om26er) wrote :

ppa? they will be in main archives in a couple of hours. so you just have to
run update-manager. just so we are on the same page I am talking about unity
not unity-2d.

Joaquin (jknvv13) wrote :

I'm talking about Unity2D, on Unity the quicklist are working, but on 2D
version, there's no quicklist
El 07/04/2011 18:21, "Omer Akram" <email address hidden> escribió:
> ppa? they will be in main archives in a couple of hours. so you just have
to
> run update-manager. just so we are on the same page I am talking about
unity
> not unity-2d.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (753575).
> https://bugs.launchpad.net/bugs/729074
>
> Title:
> dynamic quicklists are not working
>
> Status in Unity:
> Fix Released
> Status in Unity 2D:
> Confirmed
> Status in “unity” package in Ubuntu:
> Fix Committed
>
> Bug description:
> Binary package hint: unity
>
> In Maverick right clicking on the tile of an application like tomboy
> which have their app-indicator in the panel exported their menu items
> to quicklist. This is not working in Natty.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.6.0-0ubuntu2
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> Architecture: i386
> CompizPlugins:
[core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
> Date: Fri Mar 4 13:33:16 2011
> LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110304)
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: unity
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/unity/+bug/729074/+subscribe

Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 3.8.4-0ubuntu1

---------------
unity (3.8.4-0ubuntu1) natty; urgency=low

  * New upstream release.
    - [fglrx] compiz crashed with SIGSEGV in nux::IOpenGLSurface::UnlockRect()
      (LP: #685682)
    - SIGSEGV in g_atomic_int_get (LP: #688803)
    - unity-panel-service crashed with SIGSEGV in bamf_factory_view_for_path()
      (LP: #717684)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - Numpad 'Enter' doesn't work on highlighted items in dash, places-files and
      places-apps (LP: #741615)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGABRT in raise() (LP: #743414)
    - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
    - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
    - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
      (LP: #725284)
    - Missing icons in app launcher (LP: #728393)
    - Multiple quick clicks on launcher icon with multiple windows completely
      crashes Unity (LP: #731790)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
      (LP: #742280)
    - panel superposition (LP: #742859)
    - unity-window-decorator doesn't start on secondary X session
      (LP: #730495)
    - Unity Launcher stops autohiding and is not responsive (LP: #744325)
    - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
    - new dialogs open close enough of the launcher to make hide (LP: #747302)
    - dnd from the application place to the launcher works only once
      (LP: #747316)
    - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
      interface of R (LP: #747439)
    - minimize animates window fading to the top left corner (ubuntu symbol)
      (LP: #747765)
    - Spread - Clicking on a app icon to spread the windows must always show
      all the windows, regardless of whether or not some of the windows are
      minimised (LP: #750349)
    - Launcher - Show visual de-coupling of Launcher app icons (LP: #751196)
    - unity-window-decorator crashed with SIGSEGV in event_filter_func()
      (LP: #748317)
    - Pressing Super-W to switch windows also presents Dash (LP: #753453)
    - Don't create windows over the launcher (LP: #688816)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - F10 key does not move focus to indicators when on the desktop.
      (LP: #727548)
    - dynamic ...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Joaquin (jknvv13) wrote :
Download full text (7.4 KiB)

I reported the bug for Unity2D :/

2011/4/7 Launchpad Bug Tracker <email address hidden>

> This bug was fixed in the package unity - 3.8.4-0ubuntu1
>
> ---------------
> unity (3.8.4-0ubuntu1) natty; urgency=low
>
> * New upstream release.
> - [fglrx] compiz crashed with SIGSEGV in
> nux::IOpenGLSurface::UnlockRect()
> (LP: #685682)
> - SIGSEGV in g_atomic_int_get (LP: #688803)
> - unity-panel-service crashed with SIGSEGV in
> bamf_factory_view_for_path()
> (LP: #717684)
> - New window tracking system breaks in the case where windows try to
> restack relative to destroyed windows that were never mapped
> (LP: #723014)
> - Numpad 'Enter' doesn't work on highlighted items in dash, places-files
> and
> places-apps (LP: #741615)
> - compiz crashed with SIGSEGV in free() (LP: #738864)
> - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
> - compiz crashed with SIGSEGV in CompWindow::id() (LP: #742028)
> - Windows that reparent away from the root before they are mapped can
> cause other windows to become invisible (and compiz to crash)
> (LP: #743011)
> - compiz crashed with SIGABRT in raise() (LP: #743414)
> - compiz crashed with SIGSEGV in g_object_get_qdata() (LP: #742905)
> - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #748033)
> - compiz crashed with SIGSEGV in CompScreen::dpy() (LP: #751372)
> - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #744867)
> - unity-window-decorator crashed with SIGSEGV in gdk_window_get_events()
> (LP: #725284)
> - Missing icons in app launcher (LP: #728393)
> - Multiple quick clicks on launcher icon with multiple windows
> completely
> crashes Unity (LP: #731790)
> - Add a test case for invisible windows regressions (LP: #736876)
> - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
> - Wrong window moves (LP: #741656)
> - compiz crashed with SIGSEGV in g_cclosure_marshal_VOID__VOID()
> (LP: #742280)
> - panel superposition (LP: #742859)
> - unity-window-decorator doesn't start on secondary X session
> (LP: #730495)
> - Unity Launcher stops autohiding and is not responsive (LP: #744325)
> - dash categories dropdown menu leaves "ghost" on desktop (LP: #746800)
> - new dialogs open close enough of the launcher to make hide (LP:
> #747302)
> - dnd from the application place to the launcher works only once
> (LP: #747316)
> - compiz crashed with SIGSEGV in CompWindow::id() while opening tcl/tk
> interface of R (LP: #747439)
> - minimize animates window fading to the top left corner (ubuntu symbol)
> (LP: #747765)
> - Spread - Clicking on a app icon to spread the windows must always show
> all the windows, regardless of whether or not some of the windows are
> minimised (LP: #750349)
> - Launcher - Show visual de-coupling of Launcher app icons (LP:
> #751196)
> - unity-window-decorator crashed with SIGSEGV in event_filter_func()
> (LP: #748317)
> - Pressing Super-W to switch windows also presents Dash (LP: #753453)
> - Don't create windows over the launcher (LP: #688816)
...

Read more...

Olivier Tilloy (osomon) wrote :

@Joaquín: a bug report can be used to track an issue in several projects. In that case, the issue was affecting both unity and unity-2d. It was fixed in unity, hence the status change and changelog entry above, but it is not fixed in unity-2d yet. This is unfortunate but don’t worry, it will be fixed soon. Be patient, and keep up with the valuable feedback ;)

Olivier Tilloy (osomon) wrote :

I apparently can’t change the status of the bug for unity, but it’s definitely *not* fixed there. Tested with the latest updates, with banshee and tomboy, when they are running their quicklists should contain extra entries exposed by their indicators, but they don’t.

I believe this may be a regression in BAMF that doesn’t seem to expose indicators anymore.

Didier Roche (didrocks) on 2011-04-08
description: updated
Olivier Tilloy (osomon) wrote :

To clarify what has been a misunderstanding (thanks Didier for the explanations): menus exported by applications over indicators are not shown in the quicklists any more in Natty (they used to be in Maverick), and this is by design.

However, applications can define custom quicklists using the libunity API (Déjà Dup for example does it). This is not implemented in unity-2d yet, and this bug report will track the implementation.

tags: added: delta-with-3d
Bilal Akhtar (bilalakhtar) wrote :

I was working on adding quicklist support to update-manager and suddenly, after working for a while, dynamic quicklists aren't working anymore for me. I am using Unity 3.8.6, and it was working a few minutes ago, stopped working suddenly (static ones are working though). I tried rebooting, unity --reset and unity --reset-icons as well, but to no avail.

Tried using the Vala script attached above as well as using the Python bindings, but it isn't working anymore. What info should I provide to help debug this?

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Didier Roche (didrocks) on 2011-04-13
Changed in unity:
status: Fix Released → Fix Committed
milestone: 3.8.4 → 3.8.8
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.8.8-0ubuntu1

---------------
unity (3.8.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - Empty desktop after login (LP: #687660)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #757709)
    - compiz crashed on initial load of Java Citrix Client/Inkscape in
      PrivateWindow::processMap() (LP: #758307)
    - Sometimes dragging down from the panel just stops working (LP: #750155)
    - Ensure Unity prioritises icon loading from Unity-icon-theme
      (LP: #750471)
    - text truncated in Dash. Empty search from Applications or Files lense
      returns “Your search did not” due to cut off label (LP: #757362)
    - should list PlacesGroup.cpp in POTFILES.in (LP: #757663)
    - Launcher intellhide stuck after edge reveal (LP: #757810)
    - unity-preferences doesn't load translations (LP: #759682)
    - dynamic quicklists are not working (LP: #729074)
    - with second monitor, first monitor does not show nautilus
      application/global menu when displaying desktop (LP: #743149)
    - Launcher - The Workspace, File Lens, App Lens and Trash Launcher icons
      need to be rendered correctly (LP: #745555)
    - the launcher background gets dimmed after icons dnd (LP: #747304)
    - Numpad 'Enter' does not work on unity launcher when navigating through
      keyboard (LP: #760003)
    - Launcher shouldn't hover when being in the dash (LP: #760770)
    - Launcher displays key shortcuts while holding Super while the dash is
      open but the shortcuts are unfunctional (LP: #760728)
    - Running/active indicators point to space between launcher icons for
      folded icons (LP: #703067)
    - user-trash.svg and user-trash-full.svg not lens grayscale versions
      (LP: #741804)
    - code-cleanup: unregistered any established ubus-interests (LP: #757588)
    - dropdown box in places search bar does not resize when font size changes
      (LP: #759763)
    - [FFE] Centered layout for expo plugin (LP: #754689)
    - Unity launcher icons tooltips do not disappear when swiching workspaces
      (LP: #744795)
    - Dash - Update Dash scroll bar (LP: #750374)
    - Letters cut off at the end in the applications window (LP: #753083)
  * debian/control:
    - build-dep on grail/geis with version bumped
  * 01_dont_dep_on_latest_geis_grail.patch:
    - not needed anymore
 -- Didier Roche <email address hidden> Thu, 14 Apr 2011 22:03:42 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity-2d:
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2011-04-28
Changed in unity-2d:
status: Confirmed → In Progress
Colin Law (colin-law) wrote :

Can I just check whether this bug covers the fact that in Unity-2d quicklists generated using X-Ayatana-Desktop-Shortcuts=... in a desktop file that is pinned to the launcher, do not work.

Olivier Tilloy (osomon) wrote :

@Colin: this is a separate issue, tracked by bug #669923.

Colin Law (colin-law) wrote :

@Olivier: Thanks, sorry for the noise. I wonder why a search for
unity-2d quicklist desktop
on bugs.launchpad.net doesn't find it.

Olivier Tilloy (osomon) on 2011-05-18
Changed in unity-2d:
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.6
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers