does not display icons until hovered

Bug #726033 reported by Pavel Rojtberg on 2011-02-27
204
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Mesa
Confirmed
Medium
Nux
Fix Released
High
Unassigned
Unity
Fix Released
Critical
Jay Taoko
mesa (Ubuntu)
Low
Unassigned
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Critical
Jay Taoko

Bug Description

Binary package hint: unity-place-applications

while unity-places-files and the unity launcher display their content on launching, unity-place-applications does not display anything until the respecting elements were activated (hovering, clicking). see screenshot for the look, where only a few icons were hovered.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity-place-applications 0.2.34-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
Date: Sun Feb 27 14:13:47 2011
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-place-applications
---
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1400x1050 1400x1050 1280x1024 1280x1024 1280x960 1280x854 1280x800 1280x720 1152x768 1024x768 1024x768 800x600 800x600 848x480 720x480 640x480 640x480
 edid-base64: AP///////wAwrkNAAAAAAAAPAQOAHhd46q8AmVhTjColUFQhCACBgAEBAQEBAQEBAQEBAQEBMCp4IFEaEEAwcBMAMeQQAAAYKCN4IFEaEEAwcBMAMeQQAAAYAAAADwCQQzKQQygUBgAyDAAAAAAA/gBMUDE1MEUwNS1BMgogAJs=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: On
 modes:
 edid-base64:
DistUpgraded: Fresh install
DistroCodename: natty
DistroRelease: Ubuntu 11.04
DistroVariant: ubuntu
GdmLog1:

GdmLog2:

GraphicsCard:
 ATI Technologies Inc M66GL [ATI Mobility FireGL V5250] [1002:71d4] (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:20a4]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
LiveMediaBuild__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
MachineType: LENOVO 2007FVG
Package: unity 3.4.6-0ubuntu1
PackageArchitecture: i386
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature__: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
Tags: natty running-unity natty running-unity natty running-unity ubuntu compiz-0.9
Uname: Linux 2.6.38-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/12/2008
dmi.bios.vendor: LENOVO
dmi.bios.version: 79ETE3WW (2.23 )
dmi.board.name: 2007FVG
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr79ETE3WW(2.23):bd09/12/2008:svnLENOVO:pn2007FVG:pvrThinkPadT60p:rvnLENOVO:rn2007FVG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2007FVG
dmi.product.version: ThinkPad T60p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.4-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5

Related branches

Pavel Rojtberg (rojtberg) wrote :
Pavel Rojtberg (rojtberg) wrote :
Omer Akram (om26er) wrote :

the rendering is done by unity. Anyways is the problem constant? happens every time? also open a terminal and type apport-collect 726033 so there is enough information about your system

affects: unity-place-applications (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

apport information

tags: added: apport-collected compiz-0.9 ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Pavel Rojtberg (rojtberg) wrote :

jup the problem happens every time. also if it helps: if I scroll down to about the end of the applications list all icons appear and dissappear again about at the time the bottom-most icon is not visible any more. At this breakdown-point the bottom most icon is also drawn over the area below the scroll-bar, which is not drawn on otherwise.
I would guess the error is somewhere in the scrolling-redraw code

Pavel Rojtberg (rojtberg) wrote :

Hallo. I have exactly the same bug since the beginning (before alpha 1). It's happen EVERY time. To scroll with the mouse doesn't work. I try apport-collect 726033 in a terminal.

It doesn't work. I open a duplicate: bug 726888.

Didier Roche (didrocks) wrote :

That shouldn't happen anymore with latest nux and unity, can you confirm?

Changed in unity:
status: New → Incomplete
Pavel Rojtberg (rojtberg) wrote :

no, the problem is still there. one interesting observation is that the problem exists when I select the "office" category as described. But once I click on "display one more results" the whole window content gets displayed.
It dissapears again when I click "fewer results".

See the new screenshot - the only thing displayed as default is the item which should be hidden.

After update to unity 3.6 there is no change.

Screenshot after the mouse moved over the window

Didier Roche (didrocks) wrote :

ok, tracking it though. Thanks for the feedbacks!

Changed in unity:
status: Incomplete → Triaged
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
status: Incomplete → Triaged
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.6.2
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-03-07
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.6.2-0ubuntu1

---------------
unity (3.6.2-0ubuntu1) natty; urgency=low

  * New upstream release:
    - unity-window-decorator crashed with SIGSEGV in
      g_cclosure_marshal_VOID__OBJECT() (LP: #724874)
    - blinking screen at searching "gn" (LP: #674022)
    - Top panel isn't multimonitor aware (LP: #675862)
    - Leaving fullscreen causes the launcher to rapidly appear and then
      disappear (LP: #718054)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-Watch TV
      Shows.desktop/type": ` ' is an invalid character in key/directory names
      (LP: #722403)
    - does not display icons until hovered (LP: #726033)
    - Unintuative Application Matching (LP: #726711)
    - icons missing in the dash recent files and directory search returns
      (LP: #727824)
    - some result cache broke the dash search (LP: #728961)
    - Protect against conflicts with unity super keys (LP: #729166)
    - not installed apps sorting in global search (LP: #636996)
    - No 'safely remove' option is present in the unity menu when a usb disk
      is inserted (LP: #660010)
    - Dash - Implement new Dash design! (LP: #683762)
    - Expose or add missing nux functions for a11y support (LP: #701672)
    - Launcher - A single finger 'hold' on a Launcher app icon should open the
      quicklist (LP: #702486)
    - No "Search" default entry (LP: #710794)
    - Icon in Launcher should be home folder icon (LP: #721121)
    - Launcher bindings require Super to be held down to work (LP: #727580)
    - compiz crashed with SIGSEGV in nux::CairoGraphics::GetBitmap()
      (LP: #727636)
    - Unity "Lens" do not scroll to bottom (LP: #719616)
    - Double-click on panel to unmaximize only works in right half
      (LP: #725529)
    - clicking multiple time on the bfb makes the logo darker and darker
      (LP: #727146)
    - the launcher should go away if it has been open using the keyboard and
      the mouse is not moved while the cursor is on it (LP: #727746)
    - migrate_favorites.py crashed with OSError in makedirs(): [Errno 13]
      Permission denied: '/home/aquarius/.local/share/unity' (LP: #723656)
    - No feedback when unmounting busy device in Unity (LP: #730638)
 -- Didier Roche <email address hidden> Mon, 07 Mar 2011 19:10:27 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Pavel Rojtberg (rojtberg) wrote :

after the update the icons are displayed correctly as long as there is nothing to scroll through. as soon as there are more icons than fits on the screen, the bug is still there. see attached screenshot.

Pavel Rojtberg (rojtberg) wrote :

furthermore there is a redraw issue if I close the category selection menu using the same arrow which is used to open it.(screenshot) if I just click somewhere everything is fine.

Changed in unity (Ubuntu):
status: Fix Released → Incomplete
Changed in unity:
status: Fix Released → Incomplete

I confirm the comment from Pavel Rojtberg. After the update, it's better but not completely resolve.

After update today to unity 3.6.4-0ubuntu1 the bug is almost fixed! When I open a dash (Applications for example)I can see all icons but they disappear after clicking on "see x more results". Same result after used the mouse wheel.

Neil J. Patel (njpatel) wrote :

Pierre, thanks for your comment, I'll look into this for next week, looks like some QueueDraws aren't being evaluated.

Didier Roche (didrocks) on 2011-03-11
Changed in unity:
status: Incomplete → Triaged
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in unity:
milestone: 3.6.2 → 3.6.6
IKT (ikt) wrote :

I had the issue initially after opening applications places from launcher for the first time but after opening a second time it worked fine, not sure if this helps or not.

No change for me. I try today again with the same result. First panel is OK but after to use the mouse wheel or to click on "more results", the icons disappear. And sometimes it's impossible to write something on "search".

Neil J. Patel (njpatel) wrote :

Hi, I've finally got my hands on an Ati mobility system so I can finally work on this bug (as well as right now jay is taking a look). Sorry it didn't make it in this weeks release, but we're very confident of a fix for next week.

Changed in unity:
milestone: 3.6.6 → 3.6.8
importance: High → Critical
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Released → Incomplete
Changed in unity (Ubuntu):
status: Incomplete → Triaged
Changed in nux:
status: New → Triaged
importance: Undecided → Critical
Changed in nux:
importance: Critical → High
Alex Launi (alexlauni) on 2011-04-11
Changed in unity:
status: Fix Released → Triaged
Didier Roche (didrocks) on 2011-04-11
Changed in nux (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2011-04-12
Changed in unity:
milestone: 3.8.2 → 3.8.8
David Barth (dbarth) on 2011-04-13
Changed in unity:
importance: Critical → High
Neil J. Patel (njpatel) on 2011-04-14
Changed in unity:
assignee: Neil J. Patel (njpatel) → Jay Taoko (jaytaoko)
Changed in unity (Ubuntu):
assignee: Neil J. Patel (njpatel) → Jay Taoko (jaytaoko)
importance: High → Critical
Changed in unity:
importance: High → Critical
Didier Roche (didrocks) on 2011-04-14
Changed in unity:
milestone: 3.8.8 → 3.8.10
43 comments hidden view all 123 comments
Giovanni Mellini (merlos) wrote :

@Omer I'm using default radeon GPL driver.
I confirm that on my Mobility X2300 is impossible to install gflrx drivers

giovanni@shrimp:~$ lsmod | grep radeon
radeon 896428 3
ttm 65184 1 radeon
drm_kms_helper 40745 1 radeon
drm 180037 5 radeon,ttm,drm_kms_helper
i2c_algo_bit 13184 1 radeon
giovanni@shrimp:~$ modinfo radeon
filename: /lib/modules/2.6.38-8-generic/kernel/drivers/gpu/drm/radeon/radeon.ko
license: GPL and additional rights
description: ATI Radeon
author: Gareth Hughes, Keith Whitwell, others.
[...]

hoppus2a (hoppus2a) wrote :

@Omer
Ati X1950 pro with open source driver

Jay Taoko (jaytaoko) wrote :

Ok, this confirms that you all have ATI GPUs that are no longer supported by Fglrx. Regarding the original issue, I suspect an issue in the radeon open source driver that affects mainly older GPU.
Again, I have a radeon HD 4670 that does not exhibit the problem when using the open source radeon driver. I am going to ask our X experts if they have more information on the matter.

Bilal Akhtar (bilalakhtar) wrote :

Hi Jay,

Sorry for the late response, well, my response will merely add up to that of the others. I am using the xserver-xorg-video-ati driver (the open source one) as the fglrx one doesn't support my GPU (RV505).

@Niklas:

Your issue is bug #761225.

After the second update today, my system reverted to the old buggy behavior, as already defined is this bug. ( and I'm no longer affected by the problems described in bug #761225 )

And to chip in with the rest, my card is also too old to use the proprietary driver.

Pavel Rojtberg (rojtberg) wrote :

to sum up:
the bug affects mobility as well as desktop cards using the r300g glx driver. (R300-R500)
The HD 4670 uses the r600g driver and does not exhibit the bug.
Both drivers use gallium, so the bug must be in the r300g driver code.

24 comments hidden view all 123 comments

Forwarded from https://bugs.launchpad.net/ubuntu/+source/unity/+bug/726033

When rendering the Unity dash icons are frequently missing from the rendering.
This video is a good demonstration of the problem: https://launchpadlibrarian.net/68813544/unity-bug.ogv

This works on r600g, nouveau, i915 and i965, so it looks like it's a bug somewhere in r300g.

The dash rendering uses FBOs and ARB shaders, with glscissor for clipping.

Created attachment 45747
Xorg.0.log

Created attachment 45748
dmesg.txt

Created attachment 45749
glxinfo.txt

This occurs on both mesa master (as of 2011/04/18, shown in logs) and 7.10.2.

The bug can be reproduced on ATI R300/400/500 GPUs. These GPUs are no longer
supported by fglrx so I couldn't verify if it was strictly a driver issue or if
there was some error in our program code. However, the problem cannot be
reproduced with a Radeon HD 4670 and the open source driver (or fglrx). Nor can
it be reproduced with Intel GPUs such as the GMA 950 and above.

The bug manifest itself in the Unity Dash. When an action is performed to show
more icons in the dash, the rendering does not happen. Elements of the Dash
only appear after the mouse moves over them, but this is the result of Unity
refreshing the rendering. Some elements of the dash also disappear. This make
me think that clipping could be involved. Unity makes extensive use of opengl
scissoring.

28 comments hidden view all 123 comments
aljazek (aljazek) wrote :

I am happy that we're moving forward with this problem. We all have older ATI GPUs (I have Mobility X1600), so it really must be problem in driver coder like Pavel concluded.

Jay Taoko (jaytaoko) wrote :

I just acquired an ATI X1950 Pro just to track down this issue. I can confirm all the issues that have been reported with cards in the R300/400/500 series. The original issue is very obvious with this card, while it doesn't happen at all with my Radeon HD 4670 and the open source driver.
I spent a day trying to find a fix for this problem. My hope is, there may be a hack to work around what I believe is a driver bug. But the hardest part is to identify what the problem is in the driver. So far still no luck. In the mean time, I will report this as a driver bug. There may be a chance that the driver developer could pin point the issue and even propose a quick fix.

Jay Taoko (jaytaoko) wrote :

Upon recommendation I have installed the xorg-edgers drivers in the hope that, maybe, the issue has been addressed in the next releases of Mesa. Unfortunately, it didn't improve the situation.
At this point a bug has been reported to the driver developers: https://bugs.freedesktop.org/show_bug.cgi?id=36332
I am still using the ATI X1950 on my system and I will continue searching for a solution to this problem. Please, keep reporting here if you have more information about the problem.

Pavel Rojtberg (rojtberg) wrote :

do you agree with my findings that the buggy code must be in the scissoring? And if so could you reproduce the error creating a minimal testcase?

Jay Taoko (jaytaoko) wrote :

@Pavel: If you are saying that the problem is in the way the driver handles the clipping, I agree. The same OpenGL code is working fine on GPUs other than the R300/400/500 series. Yet it may not just be the clipping itself. I think it is a combination of different things: frame buffer object, view port, scissoring, texture modes...
I have no way right now to reproduce the problem in a simple test sample outside of Nux, and I think a simple test case that only involves opengl scissoring may not expose the problem. It is really specific to Unity's Dash right now.

Christian Heitjan (heitjan) wrote :

Got the same Problem with ATI X1600 card

My Nvidia FX5200 doesn't show any Unity icons at all. (Fresh 11.04 all updates as at 19/04)

Jay Taoko (jaytaoko) on 2011-04-19
Changed in unity:
milestone: 3.8.10 → 3.8.12
23 comments hidden view all 123 comments

there is now a workaround in this commit:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/natty/nux/natty/revision/26

// jaytaoko: This is a hack for what looks like a bug (#726033) in the radeon opensource driver
// on R300/400/500. Rather than passing a null region to glScissor, we give the clip area a 1 pixel width.

22 comments hidden view all 123 comments
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.46-0ubuntu2

---------------
nux (0.9.46-0ubuntu2) natty; urgency=low

  * Cherry-pick:
    - fix for "does not display icons until hovered" on old ATI hardware
      (LP: #726033)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 10:06:03 +0200

Changed in nux (Ubuntu):
status: Triaged → Fix Released
Pavel Rojtberg (rojtberg) wrote :

that fixed this bug for me. thanks.

Scrolling is quite slow though, but thats another bug I guess..

hoppus2a (hoppus2a) wrote :

Not fix with nux 0.9.46

Scrolling slow but at least the issue is resolved :)

hoppus2a (hoppus2a) wrote :

hum sorry don't see didier roche's patch

hoppus2a (hoppus2a) wrote :

"version 0.9.46-0ubuntu2" fixed the bug for me too !
sorry for flood

hoppus2a, please check for the exact version of nux, the one that
fixes this issue is 0.9.46-0ubuntu2 you might need to update again or
wait a few hours and then update, incase your mirror is slow to
update.

Giovanni Mellini (merlos) wrote :

nux 0.9.46-0ubuntu2 fixed the issue for me with ATI Mobility Radeon X2300
Tks a lot for this quick fix

Jay Taoko (jaytaoko) wrote :

@Pavel: the problem is better understood now. We should be able to make a simple test case for it. I will report the finding in the xorg bug report.

Thank you all for reporting and helping to find a workaround!

Didier Roche (didrocks) on 2011-04-20
Changed in unity:
status: Triaged → Fix Committed
Changed in nux:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in mesa:
importance: Unknown → Medium
status: Unknown → Confirmed
Bryce Harrington (bryce) on 2011-04-20
Changed in mesa (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Didier Roche (didrocks) on 2011-04-21
Changed in unity (Ubuntu):
status: Invalid → Fix Committed
Christian Heitjan (heitjan) wrote :
Download full text (4.8 KiB)

Fix works for me, too... But scrolling is a bit slow...

Am Mittwoch, den 20.04.2011, 10:10 +0000 schrieb Marco Giannini:

> Scrolling slow but at least the issue is resolved :)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/726033
>
> Title:
> does not display icons until hovered
>
> Status in Mesa:
> Unknown
> Status in Nux:
> Triaged
> Status in Unity:
> Triaged
> Status in “mesa” package in Ubuntu:
> New
> Status in “nux” package in Ubuntu:
> Fix Released
> Status in “unity” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: unity-place-applications
>
> while unity-places-files and the unity launcher display their content
> on launching, unity-place-applications does not display anything until
> the respecting elements were activated (hovering, clicking). see
> screenshot for the look, where only a few icons were hovered.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity-place-applications 0.2.34-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
> Uname: Linux 2.6.38-5-generic i686
> Architecture: i386
> Date: Sun Feb 27 14:13:47 2011
> LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
> ProcEnviron:
> LANGUAGE=de_DE:en
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> SourcePackage: unity-place-applications
> ---
> Architecture: i386
> CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,scale,session,unityshell]
> CompositorRunning: compiz
> DRM.card0.LVDS.1:
> status: connected
> enabled: enabled
> dpms: On
> modes: 1400x1050 1400x1050 1280x1024 1280x1024 1280x960 1280x854 1280x800 1280x720 1152x768 1024x768 1024x768 800x600 800x600 848x480 720x480 640x480 640x480
> edid-base64: AP///////wAwrkNAAAAAAAAPAQOAHhd46q8AmVhTjColUFQhCACBgAEBAQEBAQEBAQEBAQEBMCp4IFEaEEAwcBMAMeQQAAAYKCN4IFEaEEAwcBMAMeQQAAAYAAAADwCQQzKQQygUBgAyDAAAAAAA/gBMUDE1MEUwNS1BMgogAJs=
> DRM.card0.VGA.1:
> status: disconnected
> enabled: disabled
> dpms: On
> modes:
> edid-base64:
> DistUpgraded: Fresh install
> DistroCodename: natty
> DistroRelease: Ubuntu 11.04
> DistroVariant: ubuntu
> GdmLog1:
>
> GdmLog2:
>
> GraphicsCard:
> ATI Technologies Inc M66GL [ATI Mobility FireGL V5250] [1002:71d4] (prog-if 00 [VGA controller])
> Subsystem: Lenovo Device [17aa:20a4]
> LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
> LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
> LiveMediaBuild__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110227)
> MachineType: LENOVO 2007FVG
> Package: unity 3.4.6-0ubuntu1
> PackageArchitecture: i386
> PccardctlIdent:
> Socket 0:
> no product info available
> PccardctlStatus:
> Socket 0:
> no card
> ProcEnviron:
> LANGUAGE=de_DE:en
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/ho...

Read more...

Didier Roche (didrocks) on 2011-04-22
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
NikTheGeek (nikthegeek) wrote :

Fix works for me, scolling is fine, nice and smooth. All icons are visible.

Thanks guys!

Nik

Giupino (pegar1982) wrote :

Good for me.
thx guys!

Max Liebkies (mliebkies) wrote :

This is now completely resolved for me. Unity with my x1400 behaves like the reference. :-)
Thank you guys!

11 comments hidden view all 123 comments

Unity doesn't work here after upgrade from 10.10. It hangs after logging in.

Could you possibly make a simple OpenGL test case reproducing this bug? It shouldn't be hard.

Changed in mesa (Ubuntu):
status: Triaged → Invalid
status: Invalid → Incomplete
status: Incomplete → Confirmed
10 comments hidden view all 123 comments
Bryce Harrington (bryce) wrote :

Hey rojtberg,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in mesa (Ubuntu):
status: Confirmed → Incomplete
Pavel Rojtberg (rojtberg) wrote :

this bug was worked around in nux for natty already. As far as I recall the problem was that mesa or better the gallium drivers did not respect a glScissor of 0x0px size(dont paint at all) so it was increased to 1x1px.
So basically it is fixed for unity, but I dont know wheter glScissor is fixed in mesa..

Changed in mesa (Ubuntu):
status: Incomplete → Invalid
status: Invalid → Incomplete
Bryce Harrington (bryce) wrote :

Thanks. Looks like upstream is waiting for a simple test case, as they can't get unity to work.

I'll set this bug report to Triaged.

Changed in mesa (Ubuntu):
status: Incomplete → Triaged
Jay Taoko (jaytaoko) wrote :

We still have the mention of this bug in Nux source code and the fix that goes with it. To make a test in Nux, I would have to remove the hack so that upstream can see the bug happen without the fix. Even so, I am not sure if all the conditions will be there for the bug to be reproducible outside of Unity, but it is worth a try.

8 comments hidden view all 123 comments

Is it still an issue with current kernel and mesa ?

Leo (llenchikk) wrote :

Ubuntu 12.04 and 12.10 are without this issue for me.

Changed in mesa (Ubuntu):
status: Triaged → Invalid
Displaying first 40 and last 40 comments. View all 123 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.