Unable to add Wine applications to Unity launcher

Bug #704187 reported by _remko_ on 2011-01-17
This bug affects 81 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
unity (Ubuntu)

Bug Description

Binary package hint: unity

I am currently using google sketchup through Wine which runs like a charm. I it clear to me that the menu will never be supported in the appmenu. However I do think it would be preferable to at least pin the application to the unity launcher.

The panel shows 'Wine windows program loader' rather than the actual application running under Wine. The same happens to the launcher. It shows the program loader but not the actual program.

When I pin it to the launcher it shows the Wine icon. When i try to start it from the launcher it raises the following error message:

The file 'wine' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.

I am now facing a nice clean desktop with all my apps in the launcher. Except one desktop icon to google sketchup...

When I was using 'Docky' on 10.10 this wasn't an issue and I was able to just add the application to the dock and start it. I think it would be good to add this behavior to the unity launcher so it doesn't feel like a reduction of functionality.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.12-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800 1280x720 1152x768 1024x768 800x600 848x480 720x480 640x480
 status: disconnected
 enabled: disabled
 dpms: On
Date: Mon Jan 17 23:31:32 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-01-16 00:05:19.579608
DistroCodename: natty
DistroVariant: ubuntu
GraphicsCard: Subsystem: Hewlett-Packard Company Device [103c:30ac]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110112)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110112)
MachineType: Hewlett-Packard HP Compaq nc6400 (EH520AV)
 Socket 0:
   no product info available
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=cffb80f8-dc90-4dad-8b03-cc138edb29b4 ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-12.26-generic 2.6.37
SourcePackage: unity

dmi.bios.date: 12/18/2006
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68YCD Ver. F.08
dmi.board.name: 30AC
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 56.34
dmi.chassis.asset.tag: HUB7080BWS
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68YCDVer.F.08:bd12/18/2006:svnHewlett-Packard:pnHPCompaqnc6400(EH520AV):pvrF.08:rvnHewlett-Packard:rn30AC:rvrKBCVersion56.34:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Compaq nc6400 (EH520AV)
dmi.product.version: F.08
dmi.sys.vendor: Hewlett-Packard
version.libdrm2: libdrm2 2.4.22-2ubuntu1
version.libgl1-mesa-glx: libgl1-mesa-glx 7.9+repack-1ubuntu3
version.xserver-xorg: xserver-xorg 1:7.5+6ubuntu7
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.13.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.13.901-2ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20100805+b96170a-0ubuntu1

_remko_ (remko-galama) wrote :
Gord Allott (gordallott) on 2011-02-04
Changed in unity:
importance: Undecided → Medium
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in bamf:
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Jason Smith (jassmith)
Didier Roche (didrocks) on 2011-02-21
Changed in bamf (Ubuntu):
status: New → Triaged
Zorlin (zorlin-gmail) wrote :

Argh. No confirmation box on that, can someone change it back to triaged? Sorry. (Didn't realize I could even change its status.)

Changed in bamf:
status: Triaged → Confirmed
Changed in bamf:
status: Confirmed → Triaged

First off, I apologize if the following post is hard to understand/comprehend; I have a hard time conveying thoughts and ideas using text. I'll attach screenshots that try to explain the written steps.

I have the solution to this bug. The reason why the "wine application launcher" is being shown as the launcher icon is because the wine app is being opened from within the wine prefix. That means that wine is being launched, and then the windows application is being launched inside of it. By default wine attempts to launch the .lnk shortcut file that points to the .exe in the wine folder.

The solution is to create a .desktop file in a location that is looked at by the launcher and to change the command so that wine directly launches the application's executable. Below is a tutorial on how to add Microsoft Word 2007 to the Unity launcher:

1) Open the following: Applications -> System -> Main Menu
2) Highlight "Applications" on the left side list
3) Click the "New Menu" and in the popup box give it a name of "wine-apps" or something of the sort. The launcher will look in this folder and add any items in it to the "All Applications" portion of the launcher later on...
4) On the left side list expand the following: Applications -> Wine -> Programs -> Microsoft Office
5) Highlight the following: Microsoft Office Word 2007
6) Drag and Drop into the menu on the left hand side that you created earlier in step 3
5) Click on the menu on the left side of the window that was created in step 3
6) You should see the Microsoft office word launcher on the right side of the window
9) Highlight it and click on "Properties".
10) Change the command box to match the following (change %USERNAME% to match yours accordingly):
  wine "/home/%USERNAME%/.wine/drive_c/Program Files/Microsoft Office/Office12/WINWORD.EXE"
11) If the icon is the default wine icon, click on it and browse to this directory (all Wine application icons should be located here): /home/%USERNAME%/.local/share/icons
11) Click on the "Close" button twice to close out of the main menu app.
12) Reboot the computer, or log off and back on. This will allow the launcher to repull the proper .desktop files and it should populate the "All Applications" with the launcher icon you just made
13) Open the launcher icon and once the program has loaded in Wine you should be able to right click the icon in the launcher and pin it. Also the icon in the launcher should have the same icon as the application does in windows.

That is a lot of steps, and it's rather time consuming, but it does work. I just started using ubuntu about a month ago and i just installed the netbook remix version yesterday night. So if there was a much shorter/condensed way of doing that, then please let me know.

This above steps should work with any windows applications that are installed in wine. The instrucions will just have to modified to reflect whatever you are trying to add to the launcher. I did the above steps with word and excel and I could pin both to the unity launcher and I could have both word and excel running at the same time and both opened from the Unity launcher.

Brandon B.

 I mis-numbered the above steps, the second step 5 and step 6 should be steps 7 and 8 respectively. I am also attaching a 2nd screenshot to show the results.

Oliver Reardon (ojreardon) wrote :

Hi there,

I tried following your fix but it seems that I'm still getting the "Wine Windows Launcher Loader" in the side bar instead of Microsoft Office Word 2007.

Not too sure what went wrong I've repeated all your steps and it's still not working.

_remko_ (remko-galama) wrote :

The 13 step program doesn't seem like a fix to me. I can find the in my case Sketchup application launcher through the dash and open it. If it comes up there it shouldn't be more than a drag and drop to get it to the launcher.

Dan Kegel (dank) wrote :

Right, that recipe is a workaround, not a fix.

is another example of a workaround.

Wine apps should show up not as 'wine' but as e.g. PlantsVsZombies in the dock, as the first guy said.

Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d:
status: New → Triaged
Changed in unity-2d:
importance: Undecided → High

Give also a look to bug #702452, however it doesn't consider the thing of creating launchers for wine apps, but as soon as will be possible to associate an .exe to a .desktop file in an easy way that will follow.

tags: added: wine
Danon (danonlcb) wrote :


Just need to add step 14 and remove 12, 13

14) go to /home/%USERNAME%/.local/share/application

you will see a file named "Microsoft Office Word 2007". drag it over to the unity launcher

and it works.

Glenn Chugg (glennlchugg) wrote :

Yes, so long as you have a Valid .desktop file, generated by WINE or created manually, you can place WINE apps in Unity launcher, it would be great if Unity could generate the required .desktop file and update it's Launcher depending on the current program WINE has opened, I mean at the moment it doesn't even grab the correct icon if you use the terminal to launch a WINE app, so a bit more work is needed on Unity's WINE integration.

Don't get me started on Unity's lack of ability to show uncategorized items (almost everything created with WINE), the do show up in the Unity Menu, but often they don't have a Title and they do not Launch anything if you click on them. I hope Unity and WINE learn to get along, especially before it's LTS release.

Omer Akram (om26er) on 2012-02-02
Changed in unity-2d:
importance: High → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Changed in bamf (Ubuntu):
importance: Undecided → Medium
Changed in bamf:
assignee: Jason Smith (jassmith) → nobody
Simon Butcher (sbutcher) wrote :

This behaviour persists in 12.04. In fact, if you add notepad (for example) to the launcher, then run it, it doesn't show the > arrow next to the icon, and doesn't appear in alt-tab list of programs.
This means that once the window of a wine app is minimised, there is no way of restoring it, neither from launcher or alt-tab.

Daniel van Vugt (vanvugt) wrote :

Simon, you are describing bug 998591, not this one.

Kai Mast (kai-mast) wrote :

Would be cool if this was implemented.

Andrea Azzarone (azzar1) wrote :

Is this still a problem?

Changed in bamf:
status: Triaged → Incomplete
Changed in unity:
status: Triaged → Incomplete
Changed in unity-2d:
status: Triaged → Incomplete
Changed in bamf (Ubuntu):
status: Triaged → Incomplete
Changed in unity (Ubuntu):
status: Triaged → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for unity-2d because there has been no activity for 60 days.]

Changed in unity-2d:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for Unity because there has been no activity for 60 days.]

Changed in unity:
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for bamf (Ubuntu) because there has been no activity for 60 days.]

Changed in bamf (Ubuntu):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for BAMF because there has been no activity for 60 days.]

Changed in bamf:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers