Ubuntu

menus are not always stacked at the top and so not visible

Reported by Andy Whitcroft on 2010-12-30
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Unity
Critical
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
Natty
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury
Natty
High
Sam Spilsbury

Bug Description

Binary package hint: unity

Both right click on launcher buttons and on the notification area menus correctly trigger the menu but the resultant menu is not stacked at the top, thus the menus is not visible unless you iconify the oscuring windows.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.8-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26~masternext201012291748-generic 2.6.37-rc8
Uname: Linux 2.6.37-12-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Thu Dec 30 10:34:40 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
InstallationMedia_: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
MachineType: Acer AO533
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=10dbafb4-5a21-4665-88d4-2924132ca353 ro vt.handoff=7 quiet splash
ProcVersionSignature_: Ubuntu 2.6.37-12.26~masternext201012291748-generic 2.6.37-rc8
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu6
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 06/07/2010
dmi.bios.vendor: Acer
dmi.bios.version: V1.05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: AO533
dmi.board.vendor: Acer
dmi.board.version: V1.05
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.05
dmi.modalias: dmi:bvnAcer:bvrV1.05:bd06/07/2010:svnAcer:pnAO533:pvrV1.05:rvnAcer:rnAO533:rvrV1.05:cvnAcer:ct10:cvrV1.05:
dmi.product.name: AO533
dmi.product.version: V1.05
dmi.sys.vendor: Acer
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-12-generic

Andy Whitcroft (apw) wrote :
Robert Roth (evfool) wrote :

I have this issue on every login, the indicators and the appmenus do not appear on top, but they go below the nautilus desktop window (the desktop background). A simple workaround for this is to make an empty selection on the desktop, and after that it does work, menus and indicator menus appear on top as they should.

Robert Roth (evfool) on 2010-12-30
Changed in unity (Ubuntu):
status: New → Confirmed

Known issue and I'm working on it, but the fix is bloody difficult and
won't be out for a while.

Thanks for reporting anyways.

On Thu, Dec 30, 2010 at 7:02 PM, Robert Roth <email address hidden> wrote:
> I have this issue on every login, the indicators and the appmenus do not
> appear on top, but they go below the nautilus desktop window (the
> desktop background). A simple workaround for this is to make an empty
> selection on the desktop, and after that it does work, menus and
> indicator menus appear on top as they should.
>
> --
> You received this bug notification because you are a member of Unity
> Team, which is subscribed to unity in ubuntu.
> https://bugs.launchpad.net/bugs/695638
>
> Title:
>  menus are not always stacked at the top and so not visible
>
> Status in “unity” package in Ubuntu:
>  New
>
> Bug description:
>  Binary package hint: unity
>
> Both right click on launcher buttons and on the notification area menus correctly trigger the menu but the resultant menu is not stacked at the top, thus the menus is not visible unless you iconify the oscuring windows.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: unity 3.2.8-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.37-12.26~masternext201012291748-generic 2.6.37-rc8
> Uname: Linux 2.6.37-12-generic i686
> NonfreeKernelModules: wl
> Architecture: i386
> CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
> Date: Thu Dec 30 10:34:40 2010
> EcryptfsInUse: Yes
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> InstallationMedia_: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
> MachineType: Acer AO533
> PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
> ProcEnviron:
>  LANGUAGE=en_GB:en
>  PATH=(custom, user)
>  LANG=en_GB.UTF-8
>  LC_MESSAGES=en_GB.utf8
>  SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=10dbafb4-5a21-4665-88d4-2924132ca353 ro vt.handoff=7 quiet splash
> ProcVersionSignature_: Ubuntu 2.6.37-12.26~masternext201012291748-generic 2.6.37-rc8
> RelatedPackageVersions:
>  xserver-xorg 1:7.5+6ubuntu6
>  libgl1-mesa-glx 7.9+repack-1ubuntu3
>  libdrm2 2.4.22-2ubuntu1
>  xserver-xorg-video-intel 2:2.13.901-2ubuntu2
>  xserver-xorg-video-ati 1:6.13.2-1ubuntu2
> SourcePackage: unity
> XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
> dmi.bios.date: 06/07/2010
> dmi.bios.vendor: Acer
> dmi.bios.version: V1.05
> dmi.board.asset.tag: Base Board Asset Tag
> dmi.board.name: AO533
> dmi.board.vendor: Acer
> dmi.board.version: V1.05
> dmi.chassis.type: 10
> dmi.chassis.vendor: Acer
> dmi.chassis.version: V1.05
> dmi.modalias: dmi:bvnAcer:bvrV1.05:bd06/07/2010:svnAcer:pnAO533:pvrV1.05:rvnAcer:rnAO533:rvrV1.05:cvnAcer:ct10:cvrV1.05:
> dmi.product.name: AO533
> dmi.product.version: V1.05
> dmi.sys.vendor: Acer
> glxinfo: Error: [Errno 2] No such file or directory
> system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-12-generic
>
>
>

--
Sam Spilsbury

Robert Roth (evfool) on 2011-01-02
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Omer Akram (om26er) wrote :

confirmed is ok for now.

Changed in unity (Ubuntu):
importance: Undecided → Medium
status: In Progress → Triaged
Changed in unity:
status: New → Confirmed
Robert Roth (evfool) wrote :

I've set it in progress based on smspillaz's comment, "Known issue and I'm working on it, but the fix is bloody difficult and
won't be out for a while.". In progress should mean, that somebody is working on it, and according to the bugs/statuses wiki, "In Progress bugs should be assigned to the person working on them", but I can not assign this bug to smspillaz. Please smspillaz assign it to yourself and set it in progress if you are really working on it, to warn others who would like to start working on it, that somebody's working already.

Didier Roche (didrocks) on 2011-01-04
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 3.2.10
milestone: 3.2.10 → 3.2.12
David Barth (dbarth) wrote :
tags: added: unity
Changed in compiz (Ubuntu Natty):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → natty-alpha-2
Changed in unity (Ubuntu Natty):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → natty-alpha-2
Neil J. Patel (njpatel) on 2011-01-18
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: High → Critical
milestone: 3.2.12 → 3.2.14
status: Confirmed → Triaged
Changed in unity:
status: Triaged → In Progress
Changed in compiz (Ubuntu Natty):
status: Confirmed → Incomplete
status: Incomplete → Fix Released
Changed in unity (Ubuntu Natty):
status: Triaged → Fix Released
Neil J. Patel (njpatel) on 2011-01-20
Changed in compiz (Ubuntu Natty):
status: Fix Released → In Progress
Changed in unity (Ubuntu Natty):
status: Fix Released → In Progress
Didier Roche (didrocks) on 2011-01-25
Changed in unity:
milestone: 3.2.14 → 3.2.16
Changed in compiz (Ubuntu Natty):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers