separated menus: no keyboard shortcuts for menus

Bug #684060 reported by Andy Whitcroft on 2010-12-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Neil J. Patel
unity (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: unity

Where separated menus are in play for an application none of the keyboard shortcuts (alt-F to open the file menu) do not work.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic x86_64
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz/general/allscreens/options/active_plugins'
Date: Thu Dec 2 09:45:19 2010
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
MachineType: Hewlett-Packard HP Mini 5102
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a011] (prog-if 00 [VGA controller])
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash --
ProcVersionSignature_: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu2
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu1
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SourcePackage: unity
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 03/11/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68PGU Ver. F.05
dmi.board.name: 3653
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 43.1D
dmi.chassis.asset.tag: CNU0150M0R
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68PGUVer.F.05:bd03/11/2010:svnHewlett-Packard:pnHPMini5102:pvr:rvnHewlett-Packard:rn3653:rvrKBCVersion43.1D:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP Mini 5102
dmi.sys.vendor: Hewlett-Packard
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = x86_64, kernel = 2.6.37-7-generic

Related branches

Andy Whitcroft (apw) wrote :
tags: added: iso-testing
Didier Roche (didrocks) on 2010-12-02
Changed in unity:
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Neil J. Patel (njpatel) on 2010-12-07
Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 3.2.6
Neil J. Patel (njpatel) wrote :

Fixed in my branch. You'll also need latest indicator-appmenu

Changed in unity:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 3.2.6-0ubuntu1

---------------
unity (3.2.6-0ubuntu1) natty; urgency=low

  [ Didier Roche ]
  * New upstream release:
   - Autohide option should be more like Intellihide (LP: #685861)
   - Add an unity binary (LP: #599716)
   - Dock icons disappearing on reopen (all programs) (LP: #687466)
   - Application with .desktop file containing "icon=/absolute/path" doesn't
     have an icon in unity panel (LP: #683444)
   - Indicators are mis-aligned (LP: #646740)
   - Navigating between indicator gives focus back to other dialogs during
     transition (LP: #637143)
   - Migration script should dump a lot of migrated items for debugging
     (LP: #687721)
   - Add desktop action support to launcher quicklists (LP: #687403)
   - Rendering of Quicklist radio-button-item still way off (LP: #684048)
   - Clicking on a launcher icon does not raise most recent window (LP: #677577)
   - Quicklist menu item testing - Part 2 (LP: #676040)
   - Panel does not behave like a menu bar (keyboard scrubbing) (LP: #686655)
   - Separated menus: no keyboard shortcuts for menus (LP: #684060)
   - No installation instructions in source (LP: #683792)
   - Unity plugin should depend on "Desktop Wall" plugin (LP: #683211)
   - Network indicator shows up on the left-hand side of the panel (LP: #680545)
   - Scrubbing menu items or indicators in panel prematurely ends (LP: #677601)
   - fix trash icon not being updated (LP: #683241)
  * Revert source 3, it's breaking daily build and hudson
  * remove the patch as well, fixed upstream
  * debian/control, debian/unity.install, debian/unity-common.install:
    - add unity-common package and move some files there
    - install the new perf bootchart there as well
  * debian/unity.install:
    - install new unity binary
  * debian/control:
    - dep on latest nux
    - recommends nux-tools
  * debian/libunity3.symbols:
    - updated to include the new symbols

  [ Sebastien Bacher ]
  * debian/source_unity.py:
    - reassign crashes due to the indicators to the right source directly
 -- Didier Roche <email address hidden> Thu, 09 Dec 2010 19:57:14 +0100

Changed in unity (Ubuntu):
status: Triaged → Fix Released
Didier Roche (didrocks) on 2010-12-10
Changed in unity:
status: Fix Committed → Fix Released

I'm not sure we can consider this bug fully fixed: shortcuts do work, but there's no visual indication when you press Alt (i.e. the letter that would open the menu does not become underlined).

Alex Launi (alexlauni) wrote :

A regression has occurred, and this bug is back.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Changed in unity:
status: Fix Released → Confirmed
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
importance: High → Critical
Neil J. Patel (njpatel) on 2011-03-17
Changed in unity:
milestone: 3.2.6 → none
status: Confirmed → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

Fix in current Natty, setting ubuntu task to 'fix released' too.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Chow Loong Jin (hyperair) wrote :

Reopening, the bug is back in 3.8.10-0ubuntu2.

Changed in unity (Ubuntu):
status: Fix Released → Confirmed
Chow Loong Jin (hyperair) wrote :

Okay, so for some reason, although nothing Unity related got upgraded, I can't reproduce this bug. I'm closing it again then. Sorry for the noise.

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers