Ubuntu 16.04 Unity desktop uses much more ram than Ubuntu 15.10

Bug #1572801 reported by warren
982
This bug affects 190 people
Affects Status Importance Assigned to Milestone
unity (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

Ubuntu 16.04 64bit ISO number 20160420.1
unity version 7.4.0+16.04.20160415-0ubuntu1
Ubuntu 16.04 64bit ram usage has increase dramatically over Ubuntu 15.10
Ubuntu 16.04 ram roughly 1 GB Ubuntu15.10 can be tuned to 420, 450 MB
Ubuntu 16.04 with unity uses 1GB whereas Kubuntu 16.04 is using 420MB live usb

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity 7.4.0+16.04.20160415-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
.tmp.unity_support_test.0:

ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.376
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Apr 21 01:44:22 2016
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1043:8534]
GsettingsChanges:
 b'org.compiz.core' b'outputs' b"['1920x1080+0+0']"
 b'org.compiz.core' b'active-plugins' b"['core', 'composite', 'opengl', 'place', 'regex', 'resize', 'session', 'snap', 'vpswitch', 'wall', 'animation', 'commands', 'compiztoolbox', 'copytex', 'fade', 'grid', 'imgpng', 'mousepoll', 'move', 'scale', 'unitymtgrabhandles', 'workarounds', 'expo', 'ezoom', 'unityshell']"
 b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
 b'org.gnome.desktop.interface' b'scaling-factor' b'uint32 1'
LiveMediaBuild: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
MachineType: ASUS All Series
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash --- cdrom-detect/try-usb=true noprompt
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/03/2014
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 2004
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: Z87-PLUS
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr2004:bd06/03/2014:svnASUS:pnAllSeries:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnZ87-PLUS:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: All Series
dmi.product.version: System Version
dmi.sys.vendor: ASUS
version.compiz: compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.67-1
version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.18.3-1ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.917+git20160325-1ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Thu Apr 21 01:37:17 2016
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.3-1ubuntu2

Revision history for this message
warren (wkclemmons) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1572801

tags: added: iso-testing
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Where and how do you measure those numbers? Unity/compiz uses 223M here

Changed in unity (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Revision history for this message
warren (wkclemmons) wrote : Re: [Bug 1572801] Re: Ubuntu 16.04 Unity desktop uses much more ram than Ubuntu 15.10

The number were measure using system monitor and htop.

On 04/21/2016 05:47 AM, Sebastien Bacher wrote:
> Thank you for your bug report. Where and how do you measure those
> numbers? Unity/compiz uses 223M here
>
> ** Changed in: unity (Ubuntu)
> Importance: Undecided => High
>
> ** Changed in: unity (Ubuntu)
> Status: New => Incomplete
>

Revision history for this message
warren (wkclemmons) wrote :
Revision history for this message
warren (wkclemmons) wrote :

16.04 system monitor

Revision history for this message
Scott Mackay (sgian333) wrote :

This affects me also. Ubuntu Gnome 16.04 is using 2.3 GB of RAM, or 30% of my total RAM. Biggest memory hogs in the processes list according to system monitor are gnome-shell, dropbox, and gnome-software, all over 240 MiB of RAM each. Evolution and chrome are also using a bit (20-90 MiB for each open process). Specs of the computer are Intel MSI B85-G41 motherboard, Pentium G3258 dual core processor, GT 730 graphics card, and 8 GB RAM.

Revision history for this message
warren (wkclemmons) wrote :
Revision history for this message
Mohamed Bassem (medoox240) wrote :

I've also noticed the same thing, searched for the problem and found this bug report. Usually ubuntu 15.10 used to start with ~400MB memory usage, currently it starts with around 1.4GB on my machine.

Revision history for this message
Tom (4homas) wrote :

Same here.
After update from 15.10 to 16.04 Ubuntu is using around 1.2GB on my 32bit machine.

Revision history for this message
Marcos de Itapema (emmfamlame-001) wrote :

I installed new fresh-install ubuntu 16.04 64bits
and noticed high ram usage,
in my case, rapidly going to swap, so making ubuntu slow, with little work load.
Previous versions (I always used 32bits on this machine) didn't swap on normal daily usage.

I'm on an relatively old Dell Latitude D530
with 2gb ram
processor Intel Core 2 Duo @2.0ghz x2
graphics intel 965gm (system configurations -> update -> additional drivers says it's using the proprietary intel-microcode firmware for intel cpu but it wasn't activated on the previos ubuntus 32bit versions I used in past).
I installed (from ubuntu software): dropbox (which is running, automaticly from start-up) ,
and also synaptic, gimp, inkscape, virtualbox (includes dkms), kazam, pulse audio volume control, viewnior, linssid (wich are NOT running).

So now, I rebooted, opened firefox with only this tab, and system monitor, which is indicating 1.1gb ram usage.

So I tried deactivating the proprietary intel-microcode firmware for intel cpu,
but it seems to make no difference,
Anyway, I will reboot now, and if I see difference, I'll write.
If I can help, maybe some log or test, please let me know.

1 comments hidden view all 175 comments
Revision history for this message
kikito (cma54) wrote :

Hello.

same problem: look at HTOP 2016-04-25 23-02-04.png ! ! !

Revision history for this message
Singtoh (singtoh) wrote :

Thought I would add a "Same here". After fresh install of Ubuntu-Gnome(64bit) sitting at idle. 1 to 1.5gig of ram usage after about 15 min. After looking at the internet for a bit, 2 to 2.5gig out of 8gig ram.(%26 to %30).

I was running Ubuntu-Gnome 14.04(64bit) and at idle 400 to 500mb of ram usage after 15min on this same machine. Doing everyday stuff with programs open I never saw ram usage go above %25.

Cheers,

Singtoh

Revision history for this message
Romain Cambier (r-me-v) wrote :

Same here

Revision history for this message
Andrei B. (andrei-balint) wrote :

ubuntu gnome 16.04 with 4 GB of RAM. I almost died in shock when I saw that after a few hours of light usage my system was using swap memory :) . This did not happen with Ubuntu Gnome 15.10.
BIG "Same here" from me as well.

Revision history for this message
huizache (huizache) wrote :

Same here with ubuntu unity 16.04 with 4 GB on a macbook 4,1 = 1.9GB ram and 1GB cache after 10 minutes running Chromium with only one tab.

Revision history for this message
Sébastien Cany (s-cany) wrote :

I have the same problem with ubuntu unity 16.04, with 4 GB on DELL Latitude 3340.

tags: added: u7-trello-import
Revision history for this message
ViBE (vibe) wrote :

definitely. on 14.04 (64 bit) with a bunch of favourite indicator, mail client, Skype my system used about ~800-900 MB memory. now it use much more sometimes and applications like a browser use much more on 16.04 and i have no clue why cause i'm using the same applications.

Revision history for this message
Rakshith (rakshith-ravi-deactivatedaccount) wrote :

Well? Everyone seems to be adding a "Same here" but perhaps someone could point out a fix or at least the reason as to why it is happening?

Revision history for this message
Sebastien Bacher (seb128) wrote :

Could somebody having the issue add a screenshot of gnome-system-monitor processus lists sorted by memory usage when getting the issues? The screenshots on there don't show excessive usage for e.g compiz, would be interesting to know what processus is using the memory on those installations

Revision history for this message
kikito (cma54) wrote :

Hello.

look at #13 : HTOP 2016-04-25 23-02-04.png

it is not enough?

Revision history for this message
Sebastien Bacher (seb128) wrote :

@kikito, not really no, the memory usage we are looking at is the "SHR" column, it has

67.8M compiz
27M gnome-software
43M nautilus

etc

there is no entry that seems buggy in there nor higher than previous versions

Revision history for this message
Scott Mackay (sgian333) wrote :

Here are some screenshots with Ubuntu 16.04 gnome on two different computers. Gnome seems to have improved a little on memory usage in 16.04 since the last time I reported, but I don't know how.

This screenshot is from my intel computer.

Revision history for this message
Scott Mackay (sgian333) wrote :

This screenshot is from my amd computer...

Revision history for this message
Andrei B. (andrei-balint) wrote :

I have the impression this issue is related:
http://askubuntu.com/questions/762717/high-shmem-memory-usage

Revision history for this message
Sebastien Bacher (seb128) wrote :

There are no process that looks especially resource hungry in those screenshots, what's the issue exactly?

Revision history for this message
kikito (cma54) wrote :

mmmmhhh ?

something has changed since 2016-04-25:

HTOP 2016-04-25 23-02-04.png --> Mem=1.13G

HTOP 2016-05-10 14-42-11.png --> Mem=619M ? ? ?

same machine, same config, just open session ! ! !

maybe kernel: Linux PC-xxxxxx 4.4.0-22-generic #39-Ubuntu SMP Thu May 5 16:53:32 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Revision history for this message
Scott Mackay (sgian333) wrote :

@ Sebastien Bacher

I'm still having the excessive use of RAM, even though there is no single process that is responsible. I don't know if the excessive RAM is from the number of running processes or if there is something else using up the RAM. In this screenshot, I don't have any other application open and the computer had been rebooted recently, yet it is still using 1.1 GB of RAM in the screenshot.

Revision history for this message
Romain Cambier (r-me-v) wrote :

I do confirm: compiz is taking about 300 MB which is fine, but my used ram is about 1.5 GB.
Another thing: when launching most of my applications (especially games), I'm out of memory (even with 8 G + 8 G of swap)... I had the same games/configs/hardware/versions/... on ubuntu 15.04 & 15.10 and I never had those OOM.

There is definitively something wrong with memory management: While htop shows a ram usage of 4Gigs par exemple, my ram is used at 9 gigs... with nothing else running !

Revision history for this message
Marcos de Itapema (emmfamlame-001) wrote :

@ Sebastian

In 2 computers:
I apt-get updated & upgraded,
then re-booted twice,
and just after last start-up I started making snapshots with the "Print-Screen" button + save file.
Description of moments on file names (Captura de Tela = Screen Shot in Portuguese).

Revision history for this message
Ilja Polivanovas (ilja-polivanovas) wrote :

I use Ubuntu GNOME without Unity and face same problem (fresh boot, opening several browser tabs - chrome, opera, atom and system starts using swap and freeze UI in 30 minutes of browsing, 4Gb RAM + 4Gb Swap ). It was not so irritating before upgrade from 15.10.

Swappiness set to 5 (but didn't help much)

So I believe it may not be connected with Unity, but would support idea in post #30 about problems with memory management

Revision history for this message
Vishal Agravat (vishal-agravat-jnd) wrote :

same bug with my old computer.
Around 880 to 1 gb by-default memory usage at start up.

Revision history for this message
Rakshith (rakshith-ravi-deactivatedaccount) wrote :

About 2 GB with just VLC runnning. Added screenshot of system monitor showing processes sorted out by RAM Usage

Revision history for this message
Rakshith (rakshith-ravi-deactivatedaccount) wrote :

Hope it helps. Could it be that system monitor is not able to detect a process that is consuming RAM? Perhaps the process is not showing up in system monitor but is actually consuming a lot of RAM? Like the kernel, or systemd or something low level like that?

Revision history for this message
pablo (pablo-dm13x) wrote :

Same here. Using almost 4 gb ram and 1 gb from the swap when i have open firefox, chromium, skype and smplayer (my pc: intel i3 with 4 gb of ram).

Revision history for this message
Panchal Sagar (panchalsag) wrote :

Same bug. Laptop with 4GB ram uses 1.2 GB on startup. And when firefox and clementine is opened it takes 2GB of ram.

Revision history for this message
Sebastien Bacher (seb128) wrote :

doesn't seem to be an issue with the unity shell process but rather with memory management, reassigning to the kernel

affects: unity (Ubuntu) → linux (Ubuntu)
Changed in linux (Ubuntu):
status: Incomplete → New
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Revision history for this message
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.6 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.6-yakkety

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in linux (Ubuntu Xenial):
status: New → Incomplete
importance: Undecided → High
tags: added: kernel-da-key
tags: added: kernel-bug-exists-upstream
Changed in linux (Ubuntu Xenial):
status: Incomplete → Confirmed
James Baughn (geek-v)
Changed in linux (Ubuntu Xenial):
status: Confirmed → Fix Released
WindTux (windtux)
affects: linux (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Incomplete → Confirmed
95 comments hidden view all 175 comments
Revision history for this message
Sergei (markovs-i-mail) wrote :

Since Canonical no longer supports unity, switching to debian is a best way to resolve this issue.

Revision history for this message
tomsk (tomsk-slovak) wrote :

I switched to KDE Neon and I am happy, memory usage is around 400MB and KDE Plasma is better than Unity (better customization, modern look)

Revision history for this message
i2000s (i2000s) wrote :

My gnome-shell is using 20.8GiB right now on my Ubuntu 16.04.2 Gnome. Still slowly increasing! Any fix?

Revision history for this message
tasos (adamopanast) wrote :

Same here.Running Ubuntu Gnome 17.04 , kernel : 4.10.0-19-generic , 4GB RAM , 2,8GB Swap on Dell Inspiron 3542 laptop . I boot on 1.2GB of RAM (!!) and system swaps (and stucks...)with some chrome tabs (5 or 6) , eclipse , skype and slack running . This just means that I cant work :) . Its the first time I face this problem on Linux . Even Windows 10 consume much less memory than this one . I am about to try another kernel or turn off Intel microcode .

Check screenshot .

Revision history for this message
Sergei (markovs-i-mail) wrote :

Confirmed - moving to debian 8 reduces ram usage by 1-2 Gb.

Revision history for this message
gkessel (gkessel) wrote :

I don't think this is strictly a Unity problem. I recently noticed that gnome-shell was eating memory in Ubuntu 16.04.2 (64-bit), consuming all available RAM and SWAP space before ultimately resulting in errors resembling, "Unable to fork: Cannot allocate memory," which occurred when launching any application within Gnome. Rebooting the server freed up memory temporarily, but didn't fix the problem. It appears to be a bug involving the proprietary NVIDIA display drivers. Maybe identical to this bug report, which was supposedly patched last year:
https://devtalk.nvidia.com/default/topic/879616/linux/memory-leak-for-gnome-shell-for-gdm-user-all-driver-versions-/post/4685195/

In the meanwhile, switching back to the open-source Nouveau display drivers seems to have stopped the memory leak. Unfortunately I have a few games on Steam that perform better with the proprietary drivers, so I hope this is something that gets fixed.

Revision history for this message
Bushi (bushi1600) wrote :

I'm using Gnome Ubuntu 17.04 (kernel 4.10.0-20-generic, 6GB of total RAM) and have the same problem. System boots with 1.2GB and soon reaches 50% of used RAM, with 2 or 3 firefox tabs open. I've tested Ubuntu Mate 16.10 and although the initial RAM was lower than Gnome, it was still a little high for Mate (around 800MB). Kubuntu was worst for me, with a very sluggish system just with a open browser.

I also use Linux Mint with Cinnamon desktop, and after booting with lots of programs (dropbox, redshift, conky and some custom scripts), the system barely touches 800MB. I have to open firefox, atom, and a windows 7 virtual machine to pass 50% of RAM use.

Revision history for this message
insp (geiser007) wrote :

Bug still exists in latest release of Ubuntu 16.04?

Revision history for this message
AWB70 (awb70uk) wrote :

2 Systems running both 64bit systems one has 1gig ram installed (old computer) with 14.04.5 LTS 32bit ram after boot up is 328mb Tried Mint 18.1 Mate on same system Ram after bootup 600 ish.
2nd system with 2gig Ram ubuntu 16.04 LTS boots up with 867mb Ram.

Would expect newer versions of OS to consume a bit more RAM but well over double seems very excessive. Installing 16.04 on the 1gig system in fallback metacity mode was totally unworkable so went back to 14.04 lts pending getting more ram for that machine but still, double the RAM was unexpected.

Revision history for this message
warren (wkclemmons) wrote :

Here is few of the Gnome-shell memory leaks listed on Bugzilla
Bug 642652 - Major memory leak on mutter when using gnome-shell
Bug 701230 - Memory usage grows rapidly, never decreases
Bug 735705 - Memory usage of gnome-shell increasing to X GiB (heap)
Bug 777654 - gnome-shell memory leaks on llvmpipe
Bug 709451 - gnome-shell memory leaks
Bug 689378 - Memory Leak

Revision history for this message
Davias (davias) wrote :

..just upgraded from 14.04...my system has 8GB ram, never had problem with memory, now using my main app in Java ?im getting memory low warning! I have an AMD Athlon 2 X4, Radeon 7770 with 1GB ram, using the Noveau driver...

Revision history for this message
Davias (davias) wrote :

...tried the AMDGPU-PRO driver (AMDGPU is not available for HD7770), graphic performance on Java are a joke: 5 times worst than Gallium (not Noveau)...you move the mouse and the cursor follow after 1 second...a joke. Back to Gallium, yesterday started with 29% mem free, ended up in the evening with 1% and 30% swap used! Also, another known problem, monitors position is not remembered...this is the worst upgrade I ever made...planning on going back to 14.04...what a mess..

Revision history for this message
Davias (davias) wrote :

...here again, have been monitoring..I'm on Gnome Fallback as GUI and Oracle Java 8, last update: my java app, Prorealtime 10.3 (owrking ok since 2 years on 14.04) keeps growing in memory space: from the start it occupies 1.1 GB as Firefox, then, with no other activities, java in monitor keeps growing to 3 GB at midday...by evening I'll be on swap...really? Not even windows...Developers? Anyone?

Revision history for this message
insp (geiser007) wrote :

On 16.04 now have the same issues with RAM growing. Thinking about to go back to 14.04 or switch to Linux Mint.

Revision history for this message
Michel-Ekimia (michel.ekimia) wrote :

Can we sum up in the Bug description the root cause of this problem ? thx

Revision history for this message
insp (geiser007) wrote :

I've installed the Gnome flashback desktop environment into my Ubuntu 16.04 and it seems working fine.

Revision history for this message
Davias (davias) wrote :

#151: NO, I am (and always been) on Gnome Flashback...fallback...the old ubuntu desktop, the one like it is meant to be...AND it eats memory...

Revision history for this message
insp (geiser007) wrote :

Yep, with Gnome Flashback the issue also exists, maybe with slightly less load on RAM. I'm so tired about this bug.... what's wrong with Ubuntu 16.04... :(

Revision history for this message
Davias (davias) wrote :

Yeah, .. what's wrong with Ubuntu 16.04...? This LTS update I delayed a lot, waiting for support of the official AMDGPU-PRO driver, was really a nightmare. My system was upgraded since 7.04 and everything just worked PERFECTLY...Now I find myself with low ram warnings, Oracle java 8 system unstable with unusable graphic performance on AMDGPU-PRO. So I have to use Radeon FOS driver, much better, but still much slower than the old fglrx from ADM...and I cannot go back..cannot risk a mess on my work machine...

Revision history for this message
insp (geiser007) wrote :

I think we should create a new report about this issue.

Revision history for this message
Davias (davias) wrote :

..well, instead of a new report, I will like to have new solutions...

Revision history for this message
tomsk (tomsk-slovak) wrote :

Yea I switched to KDE Neon and I don't have any problem, RAM usage is about 450MB :)

Revision history for this message
Reichyga (reichyga) wrote :

A new report is not a bad idea since here there are people complaining of different problems. Some complain about a memory leak while others complain that the use of ram is about 500-1000 MB higher than 14.04. (which is my case)

My best bet is that there is some problem with unity or with a component of gnome since newer versions of the kernel haven't done the trick so far.

That said I've been using 16.04 in my work machines for the last year and the system has been perfectly stable and usable. I'm just bogged down with 16.04 using that much ram it's almost like windows.

Revision history for this message
andresimi (andresimi) wrote :

Good to know @tomsk, Ubuntu days of glory are gone. It's been more than a year in this topic and we couldn't get a word. Maybe it is time for a goodbye indeed.

Revision history for this message
insp (geiser007) wrote :

I've tried KDE Neon on Ubuntu 16.04.2 and the issue still persists.

Revision history for this message
Alecz20 (alexguzu) wrote :

For me compiz consumes 955 MB RAM with Chrome and Firefox open:
Top memory consumers:
Firefox : 900MB - 1,2 GB (about 8 tabs open)
Compiz : 955 MB
Gnome-software : 310 MB
Chrome : ~150 MB per tab.

Total usage: 6.0 GB / 15.3

See attached picture

Revision history for this message
Davias (davias) wrote :

..this is my system monitor...java 8 starts at around 1GB and then grows to grab all memory...

Revision history for this message
Alecz20 (alexguzu) wrote :

@davias: What does java have to do with Ubuntu Unity? Just remove java or stop whatever 3rd party application uses it.

Revision history for this message
Davias (davias) wrote :

..this is about 16.04 memory leaks, not just unity, that BTW, I'm not using..I'm on Gnome Classic...fallback..and my principal application works on java 8, and it was perfect until 14.04..then the upgrade and this nightmare...

Revision history for this message
insp (geiser007) wrote :

What is the best way to migrate from Ubuntu 16.04 to 14.04 or Linux Mint with keeping all my files?

Revision history for this message
Scott Mackay (sgian333) wrote :

I've had the java 8 memory leak with lubuntu 16.04.

As for using excessive memory from the start, like over a gigabyte with nothing else running, I've seen it in Ubuntu (Unity, Gnome, KDE) and Linux Mint 18 (Cinnamon and KDE), which is based on Ubuntu 16.04. I have not observed this excessive memory use with debian 8 or 9 KDE. However Debian 9 does use more than Debian 8. Usually I have .75 GB memory use with Debian 9 KDE with dropbox and nvidia proprietary drivers installed and nothing else running, but the same setup on the same computers with Ubuntu 16.04 and Linux Mint 18 of most desktop environments available through normal channels are always around a GB or more in the same situation. So I believe this is an Ubuntu problem since it does not exist upstream but does exist downstream. Furthermore, I no longer believe it is Gnome, because it exists in KDE for me too.

insp, for migrating you can get an external drive to save your important files. Or you can use cloud backups. Or what I do sometimes is to make a new partition on the same drive if there is space, install the other linux OS, and then copy all the files between partitions in the new OS. Make sure you edit the permissions of the files in the old OS first or you might have trouble copying. Sadly, I doubt Linux Mint 18 will help since it is a rebadged Ubuntu 16.04, but Ubuntu 14.04 or the Linux Mint 17 series based on Ubuntu 14.04 should help. Or, if you are comfortable enough with linux, you can try debian which is what Ubuntu is based on. Debian just doesn't have all the proprietary drivers included by default for wireless and graphics, so it is a little more advanced to set up.

Revision history for this message
Davias (davias) wrote :

Thanks Scott for #166...indeed the memory is excessive from the start, but I can live with that: 1 GB, ok, another 1 GB for firefox, ok...the problem is that java keeps growing...until it eats all the memory (I have 8 GB), the system starts to go paging on disks and become unusable. I'm using Ubuntu since 7.04 and upgraded ever since, this is the first time I have such serious problem.

Revision history for this message
Scott Mackay (sgian333) wrote :

Davias, even though this bug report was originally about the other memory problem of using excessive memory as soon as it turns on, don't see the harm in helping with this java memory problem too since it doesn't look like Canonical is going to fix either one for 16.04 since it has existed so long and we are getting close to another LTS release in April. I had that java memory leak in lubuntu 16.04 for a minecraft server I left on all the time and the memory regularly maxed out regardless of java settings, there was even a thread about it last year somewhere on the Ubuntu forums where it was recommended I switch to a window manager instead of a desktop environment. Memory management was better with openbox on ubuntu without a desktop environment. The minecraft server we have is now on debian 9 without a desktop environment, and I let that run java all week long without the memory leak.

One of my kids now uses kubuntu 16.04 to play minecraft with Oracle Java and it is ok with kde. However java is not constantly running on kubuntu so I can't guarantee it won't have the memory leak after several days of constant java use all day long. So you can try kubuntu 16.04, or probably any ubuntu 14.04. I've switched my personal computer to debian 9 and haven't noticed that memory leak for java with debian either in kde, but once again this computer doesn't run java all the time.

Revision history for this message
Davias (davias) wrote :

..thanks again Scott for the explanation. I'm coming from Ubuntu 14.04, no problems there. But going back is kind of let down, and also not safe to go back: I would have to reinstall the system...very long...waiting 'till April..is almost 1 year away..

Revision history for this message
andresimi (andresimi) wrote :

Following @tomsk that Swtiched to KDE Neon, I tried Mint KDE 1604 and I am very impressed! The only thing I had to setup was to disable baloo file indexer that made the system unusable, but after that the system is really fast and no bugs. Great Work!

- My memory consumption was around 1.5 GB at startup in Ubuntu (always been an Ubuntu user, since 2009). Now, with all my stuff installed, Dropbox, etc it is:

STARTUP
              total used free shared buff/cache available
Mem: 7849 840 5758 98 1250 6618
Swap: 8999 0 8999

WITH 2 TABS OF CHROME OPEN
              total used free shared buff/cache available
Mem: 7849 1930 2908 208 3010 5355
Swap: 8999 0 8999

- How to disable baloo in KDE:
> sudo balooctl disable

Revision history for this message
Blue Boelter (blueaz) wrote :

Hello, a 16.04 64-bit user here. I found this thread in 12-2016 after having this problem. Then an update seemed to fix it and things have been going fine since then. Now, with no changes to my system other than regular updates, the memory suck problem is back. I see that 'Fix Released' label. Is that for the late 2016 problem only? Is there a fix for the 7-2017 problem? How do I get it and when is somebody going to fix it for good?!

Revision history for this message
Sergei (markovs-i-mail) wrote :

Seems like a kernel or systemd bug since debian is affected too after upgrading to 4.9.

Revision history for this message
Begona Alvarez (begonaalvarezd) wrote :

Any update here?

I have been experiencing this issue with Ubuntu 16.04 really looong time. The memory consumption starts normal (high but quite normal for java) but it is just a matter of time that java eats all possible memory leading to a crash. I have been forced to downgrade some computers to Ubuntu 14.04 and this solved all issues. Unfortunately I cannot downgrade all machines to Ubuntu 14.04 so a fix would be highly appreciate :)

Not even windows have this problem...really?

Looking forward for any reply.

Revision history for this message
tomsk (tomsk-slovak) wrote :

@begonaalvarezd

No solution after 2 years.. Cannonical is ignoring us.

I already switched to KDE Neon (uses about 450MB of RAM at start)

Revision history for this message
Begona Alvarez (begonaalvarezd) wrote :

This is quite disappointing...

Just saying...

Displaying first 40 and last 40 comments. View all 175 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.