Newly installed applications do not show in the dash

Bug #1506744 reported by SB on 2015-10-16
342
This bug affects 96 people
Affects Status Importance Assigned to Milestone
GLib
Expired
Medium
bamf (Ubuntu)
Medium
Marco Trevisan (Treviño)
gnome-menus (Ubuntu)
High
Andrea Azzarone
Xenial
Undecided
Unassigned
libunity (Ubuntu)
High
Andrea Azzarone
Xenial
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

[Impact]
I am running 15.10 development version fully up to date, I installed it a few days ago and I have an issue with newly installed applications not appearing in the dash when I search for them, they can be started via console but the icons/launchers of newly installed applications will only appear in the dash after session is restarted.

[Test case]
1. Install a new applicaiton (using apt-get or the software center)
2. Make sure the application is listed in the Unity Dash

[Possible Regressions]
Unity fails to list all the applications, not just the newly installed ones.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: unity 7.3.2+15.10.20151002.2-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu2
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CurrentDesktop: Unity
Date: Fri Oct 16 08:41:39 2015
InstallationDate: Installed on 2015-10-11 (4 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20151011)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)Z

Related branches

SB (emehntehtt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What software did you install? Does it do it all the time? I just tried to install "ghex" as an example and it showed in first position in the dash directly...

Changed in unity (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
SB (emehntehtt) wrote :

Hexchat, Chrome, just installed Avidemux for test and again it did not appear in the dash.

SB (emehntehtt) wrote :

Today I installed Audacious and Audacity and they appeared in the dash without problems, seems one of the updates fixed this. There is a bug that still persists concerning Google Chrome, it asks constantly to be set as default browser even though it is set in Default Applications and it works but clicking set as default in Chrome does nothing, once the browser is restarted it says again that it is not default browser.

SB (emehntehtt) wrote :

This problem returned, today I installed new applications and they did not appear in the dash.

Changed in unity:
importance: Undecided → Low
status: New → Incomplete
SB (emehntehtt) wrote :

I tried to reinstall applications lens and it helped, but not completely, today I installed dconf-editor and VLC, dconf-editor did not appear in the dash, but VLC did appear. Very strange behavior. Let me know if you need any logs not provided in this bug.

Hi guys,

I'm having the same problem reported. Every time I install a program, be it through the "apt-get install" or through a package "DEB" when I look the same in the "Dash" it is not found.

When I run the program via "Terminal" it works correctly. So that the program icon back to "appear" in the "dash" to restart my Ubuntu system.

Luciano Gardim (lucianogardim) wrote :

Package: retroarch - no icon in Dash (after reset, Dash show the icon).

Package: java8-installer - no icon in Dash (after reset, Dash show the icon).

JaSauders (jasauders) wrote :

Same deal here. Installed gimp via apt-get in terminal, nothing in dash. Uninstalled + purged it, reinstalled through software center, same thing -- no results found.

Dan Jared (danjaredg) wrote :

Ubuntu software center with "new applications in launcher" uncheck. The newly installed applications do not show in the dash

Dan Jared (danjaredg) wrote :

Workarround: kill the process /usr/bin/unity-scope-loader

I see that this big has low importance. The way I use Ubuntu it drives me nuts so I hope it will get some TLC soon.

JaSauders (jasauders) wrote :

Christian - Agreed. This should be a higher priority bug given it directly abstructs workflow. I don't know how many times I've been moving along with a ton of things open only to realize I need to pull in an application, but oh wait, I need to log out and back in in order to access it. Sometimes that's just not feasible.

I've also noticed it's not always consistent. I have installed applications that do show up, but more times than not, the newly installed applications simply don't show until I log out/back in. I don't recall seeing this on prior versions of Ubuntu. In my experience it only surfaced with the introduction of 15.10.

SB (emehntehtt) wrote :

I think I will take this bug to Ubuntu IRC on Monday and ping the developers there, obviously multiple users are affected and it would be nice to see this fixed. For me the effect is also very random, sometimes applications show up in the dash immediately, and sometimes they only appear after I log out or reboot.

mendes (mendes3000) wrote :

This bug is annoying and only happens with some apps. When it doesn't work, I need to log out and log in.

Dan Jared (danjaredg) wrote on 2015-11-19: #12
Workarround: kill the process /usr/bin/unity-scope-loader

this workaround worked for me. hope this will get fixed though.

minple (fminple) wrote :

this error is still Ubuntu 15.10 final and Ubuntu 16.04 LTS (development branch, 01/20/2016). Hoping you will fix.

Andrea Gamba (andrea-gamba) wrote :

I have the same problem on freshly installed 15.10 with recent upgrades. To me it happened for instance after installation of gimp, texmacs, streamtuner2... Unity seems sort of slow: for some time I have to call the program from terminal, then suddenly the program starts being recognized by Unity. The problem should have a high priority because it interrupts workflow and gives a feeling that the graphical interface is buggy. New users can decide that Ubuntu is downright buggy and not work using, especially if told that to launch a newly installed application they have to open a terminal and type a command in it.

Andrea Gamba (andrea-gamba) wrote :

There is clearly a problem with /usr/bin/unity-scope-loader:

$ ps ax | grep scope-loader
 5616 ? Sl 0:00 /usr/bin/unity-scope-loader applications/applications.scope applications/scopes.scope commands.scope

Andrea Gamba (andrea-gamba) wrote :

Just

$ kill -9 5616

solves the problem, as mentioned by Dan Jared. Thanks.

Andrea Gamba (andrea-gamba) wrote :

Sorry for multiple posts: just to mention that I, too, was installing with apt-get install from the terminal.

Michael Weimann (m982) wrote :

This error still occurs on the latest 15.10 version

SB (emehntehtt) wrote :

This is happening with 16.04 LTS too.

tags: added: xenial
Paul Russo (paulrusso) wrote :

I can confirm this is happening in 15.10 as well. Some programs will show up in the dash after an install, others will not. Programs show up after a reboot or if the /usr/bin/unity-scope-loader is kill -9'd.

I also vote that this be given a higher priority as having to reboot or kill processes just to fix your workflow is a reason to abandon a distro all together in my opinion.

SB (emehntehtt) wrote :

I agree, this needs to be bumped in priority as 8 people already marked this bug as affecting them.

This affects 16.04 too.(currently up to date.)

Milad (agentmilo) wrote :

+1 user being affected by this bug. It is a serious issue, annoying enough to abandon the package.

Ravi Raj (bastarmedia) wrote :

Yes, I also got this error today when I installed gThumb from the repositories the software didn't appeared in Dashboard. But, as a temporary solution I re-installed gThumb and second time it appeared in dash.

Carlo (woddy68) wrote :

This bug is also on 16.04 , to avoid the log out, open the file manager usr-share applications Double-click on the application icon.
Sorry for my English.

Gustavo L (gustavo-lapido) wrote :

Also affected. Although I agree that this is not a critical error, it shouldn't also be classified as "low importance": either we have a graphical interface and then we're able to do basic stuff like install &open app, without leaving the gui, or not, and then we go back to old terminal only days, although it doesn't fit well with Ubuntu.

Coeur Noir (gerald-maruccia-e) wrote :

I have noticed the same "wrong" behavior yesterday on fresh new install of 16.04

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1574759

Coeur Noir (gerald-maruccia-e) wrote :

I have never suffered of this bug with 12.04 and 14.04 so far.

chuckz (mzakuta) wrote :

Upgraded to 16.04 from 15.10
this bug appeared along with loss of networking
which is also a common bug (Windows PC keeps asking for a password even though no passwords set)

Vipin (vipinmsx-z) wrote :

This bug is affecting in 16.04 LTS. It only happens when installing a deb package via command line[dpkg -i .deb]. Killing unity-scope-loader fixes the issue. Please make a permanent fix as killing the process every-time is not a good solution.

Jason Fenty (joofall) wrote :

I had a similar issue for quite a while, and I tried every fix possible to get applications to appear, even so far as to remove Unity and install it once again. However, I discovered that Chrome had installed an app with unicode characters in the name. On Windows, it wasn't an issue at all, however, on Ubuntu, whenever this app was synced and installed, the dash stopped working like it should. Upon removing the app from chrome://apps, my dash returned to a working state. So could it be possible that apps/profiles which use special characters might be messing with the functionality of the dash?

wtgee (wtgee) wrote :

I am experiencing this on 16.04 with almost every app installed via apt. If I run from the console the icon appears in Dash fine, but it is not accessible from the Dash at all.

@joofall: What Chrome app was it?

Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
importance: Low → High
status: Incomplete → Triaged
Changed in gnome-menus (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in glib:
importance: Unknown → Medium
status: Unknown → Confirmed
Joey Clark (prismbox1) wrote :

Yep, it happened to me today - 16.04 LTS when I installed Docky via synaptic. The workaround worked...

tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Gordon (last-ship) wrote :

i've had the same issue with most every app that I've tried to install. I find that installing instead via Synaptic does seem to be a reliable workaround.

tags: added: desktop-trello-import
Andrea Azzarone (azzar1) on 2016-05-16
Changed in libunity (Ubuntu):
status: New → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
importance: Undecided → High
Andrea Azzarone (azzar1) on 2016-05-16
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in gnome-menus (Ubuntu):
status: Triaged → In Progress
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → nobody
no longer affects: unity
Changed in gnome-menus (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) wrote :

@Seb128 Please find attached a quilt patch for gnome-menus that should workaround the problem. Please note that https://code.launchpad.net/~azzar1/libunity/fix-1506744/+merge/294855 is also required.

The attachment "80_file_monitor_delayed.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.4+16.10.20160516-0ubuntu1

---------------
libunity (7.1.4+16.10.20160516-0ubuntu1) yakkety; urgency=medium

  [ Andrea Azzarone ]
  * Process GFileMonitors signals with a small timeout. (LP: #1506744)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Mon, 16 May 2016 23:32:22 +0000

Changed in libunity (Ubuntu):
status: In Progress → Fix Released
desrt (desrt) wrote :

The patch in comment 42 is not acceptable, for two big reasons.

First: you need to hold a ref on the GFile object when you put it into the info struct. This means that you cannot simply use g_free for the struct: you need to write a custom free func that handles the unref as well. Also: you can't cast g_source_remove() to a GDestroyNotify and expect that to work... one takes a pointer, and the other an int. This may randomly work on some architectures, sometimes, but you cannot rely on this.

The entire act of keeping the list is slightly suspect. At the sprint I think I mentioned that it would be better to have one global timeout that is set (and reset) when any activity happens. The timeout would run after the activity died down, and it would handle all things together in one go. In that case, you'd still need a list, except for the info objects themselves. It's also fine to keep the list of the timeout IDs, but you can't free it in the way that you're doing in the current patch.

Another nice approach, if you want to avoid running the callbacks after teardown: store a weak pointer to the main object in each of the info structs (g_object_add_weak_pointer). The info structs are then used as the user_data to the timeout (this assumes you keep the multiple timeouts). If you find the weak pointer to be empty, then just return without doing anything. That also means that you don't need to handle the "cleanup" -- it will happen automatically. It also means that you can avoid the custom free function if you are clever: the timeout will always run once, and you can do the cleanup from the normal handler (taking care regarding the early exit discussed above).

Ryan Hammang (ryan-hammang) wrote :

Switching away from Unity (and Ubuntu). This should be of high priority...especially because there is no launcher menu or other alternative to find your app.
I'll try Ubuntu again in a year or so.

Andrea Azzarone (azzar1) wrote :
Rained23 (rained23) wrote :

hi,

I think Ubuntu team should focus this, currently everything is on the same par level from application support from 3rd party to linux desktop, and Unity is the next to near OS X user experience, I am not saying OS X is better, but I just want to say OS X user experience on operating system is indeed working.

But this bug really turn me off when I need to relog just to open an apps, yes I know you can do alternative method to open that apps, but why should I, this is simple and basic features that what makes me use unity. Please focus on fixing this, I think this will turn down someone who trying to convert to Ubuntu when they encounter this bug. I dont think this should be allowed for more than 6 month.

One more thing I encounter from the dash it self, when trying to open google chrome, or any apps, sometimes the letter I type didnt show up the apps I need to retype to match the exact name of the apps. Dash should be improved on fuzzy finder function.

Leeo97one (leeo97one) wrote :

Can you tell me why this obvious problem hasn't been fixed yet?

Andrea Azzarone (azzar1) wrote :

A patch has already been proposed. The fix needs to be reviewed.

desrt (desrt) wrote :

The latest patch looks good to me, but with a couple of notes (no need to fix these):

 - using the _full() version of the timeout call is not necessary here

 - now that this patch is simplified it becomes easy to see how all of this is just putting values into one structure and then later moving them into another structure. It seems like we could have just used the first structure type, or even just fixed the other queue mechanism to add the delay. Oh well. No real gain from making that change at this point.

desrt (desrt) wrote :

To elaborate on the previous remark: why didn't we just replace:

  menu_monitor_queue_event (event_info);

with:

  g_timeout_add_seconds (2, menu_monitor_queue_event, event_info);

(and make sure menu_monitor_queue_event() returns FALSE)?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.13.3-6ubuntu4

---------------
gnome-menus (3.13.3-6ubuntu4) yakkety; urgency=medium

  [ Andrea Azzarone ]
  * debian/patches/80_file_monitor_delayed.patch:
    - delay the .desktop handling so the files are available by the time
      the callback is called (LP: #1506744)

 -- Sebastien Bacher <email address hidden> Thu, 23 Jun 2016 10:53:27 -0400

Changed in gnome-menus (Ubuntu):
status: In Progress → Fix Released
Leeo97one (leeo97one) wrote :

Great, but there will be no fix for xenial?

Sebastien Bacher (seb128) wrote :

yes there will be a fix for xenial, the change needed to land to the current serie first and there SRU is a bit more work but it's going to come

Hello Cerberus, or anyone else affected,

Accepted gnome-menus into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-menus/3.13.3-6ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

no longer affects: unity (Ubuntu Xenial)
Changed in gnome-menus (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
SB (emehntehtt) wrote :

OK will download the package once available and give it a try.

Changed in bamf (Ubuntu):
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

I updated today, and I don't have this bug, double checking is appreciated :)

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libunity (Ubuntu Xenial):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2016-07-08
description: updated

The verification of the Stable Release Update for gnome-menus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.13.3-6ubuntu3.1

---------------
gnome-menus (3.13.3-6ubuntu3.1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * debian/patches/80_file_monitor_delayed.patch:
    - delay the .desktop handling so the files are available by the time
      the callback is called (LP: #1506744)

 -- Sebastien Bacher <email address hidden> Wed, 29 Jun 2016 17:34:43 +0200

Changed in gnome-menus (Ubuntu Xenial):
status: Fix Committed → Fix Released

Hello Cerberus, or anyone else affected,

Accepted libunity into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/libunity/7.1.4+16.04.20160701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libunity (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
SB (emehntehtt) wrote :

I enabled Xenial Proposed and installed updates, then I rebooted and installed about a dozen applications and they appeared fine in the dash, so far everything looks fine. Tag changed accordingly.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libunity - 7.1.4+16.04.20160701-0ubuntu1

---------------
libunity (7.1.4+16.04.20160701-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone ]
  * Process GFileMonitors signals with a small timeout. (LP: #1506744)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 01 Jul 2016 10:44:10 +0000

Changed in libunity (Ubuntu Xenial):
status: Fix Committed → Fix Released

This also happens with newly downloaded files in Ubuntu 16.04

Heinzi (heinzhartfiel) wrote :

Same problem after upgrading from Ubuntu 14.04 to 16.04 today. Even gedit is not found inside the dash. Via cli gedit opens as expected.

Heinzi (heinzhartfiel) wrote :

It seems that the behaviour was caused by the upgrade process. All users were affected.
After re-installing the unity-lens-applications the dash is working as expected.

Coeur Noir (gerald-maruccia-e) wrote :

« After re-installing the unity-lens-applications the dash is working as expected. » Not entirely as expected since it does not show available applications to install see #1621106

Varun (varunchandak) wrote :

I finally found out why the installed Applications were not showing up. Check for Filters options while searching and select the Applications button.

Mine was not selected so it was listing due to filters applied.

Varun (varunchandak) wrote :

Applications in filters

Dmitry Diskin (diskin) wrote :

Just got the same problem in Ubuntu 16.04.3 LTS, after updating the system. Killing /usr/bin/unity-scope-loader helped me, thanks to the comment #12!

hansmex (hansdirkse) wrote :

Yesterday, I did a fresh install of Ubuntu 16.04. I then installed the Cinnamon desktop package.

After installing from software center or using DEB, packages don't show up when searching for them. This thread is close to TWO years old and still there is no solution.

The solutions provided above don't work, because those processes aren't active according to the System Monitor.

Shame on an otherwise perfect OS!
Thank you for solving this issue.

Changed in glib:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.