Empty trash from Launcher results in Nautilus window opening

Bug #1445595 reported by Charles Profitt on 2015-04-17
706
This bug affects 182 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Medium
Unassigned
Unity
Fix Released
High
Marco Trevisan (Treviño)
nautilus (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Medium
Marco Trevisan (Treviño)
unity (Ubuntu)
High
Marco Trevisan (Treviño)
Xenial
High
Marco Trevisan (Treviño)

Bug Description

Test case:
- Add a file to trash if none already
- Right click on Unity launcher trash icon > click on Empty Trash option
- Nautilus open a window @ home folder

When selecting 'Empty trash' from the launcher, I get a dialog to confirm the deletion and a Nautilus window. When emptying trash from Nautilus window, I get only a confirmation dialog as expected.

Expected behavior:
- Only confirmation dialog pops up

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
tags: added: vivid
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Charles Profitt (cprofitt) wrote :

Using Unity-Tweak and putting the trash icon on the desktop results in expected behavior with only the confirmation dialog.

Thomas Ward (teward) on 2015-04-20
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :

Seems like an Unity issue, calling the dbus method ("dbus-send --print-reply --dest="org.gnome.Nautilus" /org/gnome/Nautilus org.gnome.Nautilus.FileOperations.EmptyTrash") doesn't trigger the window

affects: nautilus (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: Triaged → Confirmed
Charles Profitt (cprofitt) wrote :

I agree with Sebastien based on his observation and my previous observations about using Nautilus in the file manager window and using the trash icon from the desktop.

Changed in unity (Ubuntu):
status: Confirmed → Triaged
Charles Profitt (cprofitt) wrote :

I am looking through this change in Unity.

http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/3263

I am curious if this change could have exposed an issue in another part of Unit and now the file window opens. Not familiar enough with the code to know if that is the case, but wanted to add this to the bug.

Even nautilus is affected here, as it should provide an EmptyTrash method that also takes the timestamp of the action that triggered it, or the dialog won't be focused when this method is called.

Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Fedya (fedya-rtafov) wrote :

I confirm this report. More technical information in my bug reports:
https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1452157

tags: added: nautilus unity
Unixuser (unixuser) wrote :

+1

Slava (zvvubuntu) wrote :

I have the same bug. Ubuntu 15.04 - fresh install

Adolfo Jayme (fitojb) wrote :

Yeah – usually bugs don’t go away by themselves, so if you see no updates, you can assume the bug is still there.

Please don’t post more “confirmations” or void +1s, which are annoying for bug subscribers – but more importantly, are anti-ecological.

Elfy (elfy) on 2015-05-19
tags: added: wily
mmagnis (mmagnis) wrote :

I have the same bug. Ubuntu 15.04 - fresh install

Me too. Same behaviour.

delsol (nattersep) wrote :

Same behavior in 15.04; problem arose after upgrade from 14.04. Any progress on this?

delsol (nattersep) on 2015-06-08
description: updated
LaRusCat (larionenkoruslan) wrote :

Have the same bug. Fresh install Ubuntu 15.04.

Seth (seth-666-tl) wrote :

how do we repair this bug?

Digital Boy (kakuro69) wrote :

News regarding the fix for the bug?

Will Cooke (willcooke) on 2015-08-17
tags: added: rls-w-incoming
Seth (seth-666-tl) wrote :

si nici un raspuns?

fprietog (fprietog) wrote :

IMHO this is an important bug; well, it doesn't break any important OS feature but it affects the general image of Unity & Ubuntu the users should have because it happens with a usually frequent task execution.

Dan-cer (4-in) wrote :

Yes, I agree. Same bug here in 15.04 64bit.

kriom (rg-8) wrote :

Same bug here in 15.04 64bit.
As fprietog said, this is not a low importance bug :
- It occurs often
- It is a very very boring bug.
It should be fixed faster or please give a workaround.
Thanks

summary: - Empty Trash Results in File Windows Opening
+ Empty trash from Launcher results in Nautilus window opening
description: updated
fprietog (fprietog) wrote :

Amr Ibrahim (amribrahim1987) wrote on 2015-08-26:
Is this related?
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1040158

-----------------------------------------------

It's related but not the same. The report you pointed seems to be quite old and states that nautilus takes focus only when it's open and the trash is emptied. Now it's worse because even if nautilus is closed (I mean, no nautilus windows are currently opened) and you empty trash, nautilus is opened and focused.

Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Low
importance: Low → High
Changed in nautilus (Ubuntu):
importance: Low → High
Changed in unity (Ubuntu):
importance: Low → High
Changed in unity:
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: High → Medium
Changed in hundredpapercuts:
importance: High → Medium
Changed in unity (Ubuntu):
importance: High → Medium
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1445595

tags: added: iso-testing
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Medium → High

Experiencing the same behavior on brand new Ubuntu 15.04 64-bit installation. Empty Trash always opens Nautilus. This did not happen in 14.04

This error is occurring from 14.04LTS version of Ubuntu. The 15.04 version and also in version 15.10 is also occurring. But in version 12.04LTS not occurring.

I can confirm that it is still occurring in 15.10. I have this problem since 15.04.

Tonton Manu (dubreucq) wrote :

I can even confirm that this bugs affects Ubuntu 15.10 (development branch). Hope it will be solved for the official release!

Still an issue on 15.10 Release.

Dusan Stojadinovic (dstoya) wrote :

Same here after upgrade from 15.04 to 15.10.

Seth Johnson (sethj) on 2015-10-27
tags: added: desktop-bugscrub-triaged
tags: added: regression-release
removed: nautilus unity

Is there a workaround? This is just insanely annoying :(

Joshua Max (joshumax) wrote :

I've narrowed the problem down to https://bazaar.launchpad.net/~unity-team/unity/trunk/view/head:/unity-shared/GnomeFileManager.cpp#L216. Calling GnomeFileManager::Activate() from GnomeFileManager::EmptyTrash() seems to no longer be necessary and causes Nautilus to open a window at the user's home directory. Simpy removing the function call from my copy of the unity sources fixes the problem with no side-effects as far as I can tell.

Seth Johnson (sethj) on 2015-10-28
Changed in unity:
assignee: nobody → Seth Johnson (sethj)
Seth Johnson (sethj) on 2015-10-29
Changed in unity:
status: Confirmed → In Progress
tags: added: rls-x-incoming
removed: rls-w-incoming
Dylan Coakley (dylan-coakley) wrote :

I've had this really annoying bug since 14.10 all the way to 15.10. 1 year for a critical user experience bug to be fixed??

Will this fix be released soon?

Will Cooke (willcooke) on 2015-11-16
tags: removed: rls-x-incoming
Seth Johnson (sethj) on 2015-11-28
Changed in unity:
status: In Progress → Confirmed
assignee: Seth Johnson (sethj) → nobody
liamdawe (liamdawe) wrote :

Ah, glad to see I'm not the only one with this issue, been driving me a bit mad.

Launchpad Janitor (janitor) wrote :
Download full text (10.3 KiB)

This bug was fixed in the package nautilus - 1:3.18.2-1ubuntu1

---------------
nautilus (1:3.18.2-1ubuntu1) xenial; urgency=medium

  * New version (lp: #1463662) and resynchronize on Debian
    - better layout in the icons view (lp: #589433, #1019298)
    - can move link type .desktop (lp: #1278437)
  * The update uses GtkHeaderBar decorations and has no menubar for now,
    the menus are coming back later and UI is likely to be tweaked again
    based on the feedback from this version
  * Removed changed, deprecated or included in the new version
  * debian/patches/revert_remove_unused_GtkActions.patch:
  * debian/patches/restore-traditional-menu-bar.patch:
    - not needed with the new proper menubar changeset
  * debian/patches/11_copy_skipping_pager.patch:
    - the new version has no copy dialog
  * debian/patches/14_bring_del_instead_ctrl_del.patch:
    - resolved in the new version
  * debian/patches/git_name_column.patch,
    debian/patches/git_multiple_desktop_names.patch,
    debian/patches/git_file_dnd.patch,
    debian/patches/git_sidebar_selection.patch,
    debian/patches/git_slot_order.patch,
    debian/patches/git_unmount_seg.patch,
    debian/patches/git_valid_list.patch,
    debian/patches/git_nomodel_segfault.patch,
    debian/patches/git_open_dir_with.patch,
    debian/patches/git_wrap_label.patch,
    debian/patches/git_null_uri.patch,
    debian/patches/git_revert_location_entry.patch,
    debian/patches/ignore-no-desktop-if-not-first-launch.patch,
    0001-application-use-correct-order-to-watch-for-GSettings.patch:
    - included in the new version
  * Remaining changes
  * debian/control.in:
    - Build-Depends on dh-migrations, libunity-dev,
      updated gnome-pkg-tools requirement
    - lower gnome-sushi Recommends to a Suggests
    - don't recommends gnome-icon-theme-symbolic it's deprecated
    - nautilus-data should not need to recommends nautilus,
      lower to a suggests so file-roller doesn't bring in nautilus
  * debian/changelog, debian/rules: set epoch number (which was added by error)
  * debian/mount-archive.desktop:
  * debian/mount-archive.desktop.in:
    - New nautilus context menu item to allow mounting zip, iso, etc
  * debian/nautilus.install:
    - don't move the autostart to usr
    - install mount-archive menu
    - install nautilus-folder-handler.desktop
  * debian/nautilus-data.install:
    - install apport hook
  * debian/nautilus-folder-handler.desktop:
    - ship a copy of nautilus.desktop with NoDisplay=true since some user
      configurations refer to it
  * debian/nautilus.migrations,
    debian/nautilus-unity-launcher-icon-rename.py:
    - change the nautilus.desktop entry in the unity configuration to the
      new org.gnome.Nautilus name (lp: #1436297)
  * debian/source_nautilus.py:
    - Apport hook to list versions of files in /usr/lib/nautilus and reassign
      the crashes when there are not due to nautilus code directly
  * debian/rules:
    - use dh_migrations and build compat desktop entries
  * debian/patches/03_translations_list_update.patch:
    - Translate the mount-archive menu entry
  * debian/patches/04_suppress_umount_in_ltsp.patch:
    - Don't list unmount and eject...

Changed in nautilus (Ubuntu Xenial):
status: Triaged → Fix Released

>This bug was fixed in the package nautilus - 1:3.18.2-1ubuntu1

Sounds good, but I wonder when this reaches Ubuntu then. Mine is currently at 1:3.14.2-0ubuntu13.

@Rasmus:

The fix for nautilus is not enough, there's also an unity change needed for this.
Also this will likely only hit xenial.

Changed in unity (Ubuntu Xenial):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in nautilus (Ubuntu Xenial):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → ubuntu-16.04
Changed in unity (Ubuntu Xenial):
milestone: none → ubuntu-16.04
status: Triaged → In Progress

Why would this only hit Xenial?

>>This bug was fixed in the package nautilus - 1:3.18.2-1ubuntu1
>
> Sounds good, but I wonder when this reaches Ubuntu then. Mine is
> currently at 1:3.14.2-0ubuntu13.

It will, but in Ubuntu 16.04.

Vincent Thiele (vincentthiele) wrote :

Common guys please fix this on other releases.

liamdawe (liamdawe) wrote :

For such an irritating bug, could we at least get it in the current release? 15.10, it would be really nice to have it go away.

Is there a reason it's not hitting 15.10?

pst007x (turone) wrote :

Confirmed the same bug. Ubuntu 15.10 - fresh install

the bug is back with nautilus 3.14.3 in ubuntu xenial

tomras (tomas-rasymas) wrote :

same problem, after Empty Trash nautilus opens Home folder. Ubuntu version 15.10.

Still problem today.

liamdawe (liamdawe) wrote :

On Ubuntu 16.04 it was fixed, and now it's back again. Extremely irritating.

Daniel BRUN-PICARD (dbp) wrote :

It's same as liamdawe for me ! Will this bug be corrected a day? It is really very contrary!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.4.0+16.04.20160223.1-0ubuntu1

---------------
unity (7.4.0+16.04.20160223.1-0ubuntu1) xenial; urgency=medium

  [ Andrea Azzarone, Didier Roche ]
  * Gnome-software launcher integration.

  [ Marco Trevisan (Treviño) ]
  * GnomeFileManager: use *WithTimestamp file operations instead of
    using Activate workaround (LP: #1445595)
  * unity.migrations: add 04_unity_update_software_center_desktop_file

  [ Robert Ancell ]
  * Drop unused build-dependency on libgee-dev.
  * Switch from Ubuntu Software Center to GNOME Software. (LP: #1547129)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 23 Feb 2016 22:39:18 +0000

Changed in unity (Ubuntu Xenial):
status: In Progress → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
Richard Somlói (ricsipontaz) wrote :

Finally! :) Thanks, it works well on 16.04.

working well now

liamdawe (liamdawe) wrote :

Also confirmed fixed here, thanks a lot!

Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → Fix Committed
milestone: none → 7.4.0
Daniel Rodriguez (animusoft) wrote :

Fresh install Ubuntu 15.10 - still happening.. Assume only fixed in 16.04 correct?

2016-03-08 5:32 GMT+01:00 Daniel Rodriguez <email address hidden>:
> Fresh install Ubuntu 15.10 - still happening.. Assume only fixed in
> 16.04 correct?

Yep.

frizzle21 (frederik-nnaji) wrote :

I'm on 16.04.
Have run into this situation as well, no idea what's causing it.
A tail -f /var/log/* doesn't show me anything when i rightclick the thrash, select "Empty trash" from the context menu and confirm in the popup dialog.

frizzle21 (frederik-nnaji) wrote :

I'm on 16.04.
Have run into this situation as well, no idea what's causing it.
A tail -f /var/log/* doesn't show me anything when i rightclick the thrash, select "Empty trash" from the context menu and confirm in the popup dialog.

My homefolder is encrypted btw.

Tonton Manu (dubreucq) wrote :

On Ubuntu 16.04 / Unity 7.4.0+16.04.20160415-0ubuntu1

No more affected, nautilus doesn't show anymore when I empty trash. Thanks!

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers