Active windows loses focus after returning from HUD if another "Always on top" window is present

Bug #1366583 reported by Rohan Deshmukh on 2014-09-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Christopher Townsend
7.2
Fix Committed
Medium
Christopher Townsend
unity (Ubuntu)
Medium
Christopher Townsend
Trusty
Medium
Unassigned

Bug Description

Active window looses focus after returning from HUD if "Always on top" window like VLC is already running. The focus is given to VLC instead of the window on which HUD was invoke.

How to reproduce?
1. Open vlc and set it always on top
2. Open nautilus, try to rename a file using hud
3. As soon as rename option is pressed on hud, nautilus looses its focus and the focus is given to VLC.
4. To rename I have to re-select nautilus

[Test Case]
1. Open vlc and set it always on top
2. Open nautilus, try to rename a file using hud
3. Make sure that when the hud closes, nautilus is focused.

[Regression Potential]
None.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity 7.2.2+14.04.20140714-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
CurrentDmesg: Error: command ['sh', '-c', 'dmesg | comm -13 --nocheck-order /var/log/dmesg -'] failed with exit code 1: comm: /var/log/dmesg: Permission denied
Date: Sun Sep 7 23:05:07 2014
DistUpgraded: Fresh install
DistroCodename: trusty
DistroVariant: ubuntu
DkmsStatus:
 i915-3.15-3.13, 0.01, 3.13.0-19-generic, x86_64: installed
 i915-3.15-3.13, 0.01, 3.13.0-24-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Samsung Electronics Co Ltd Device [144d:c652]
InstallationDate: Installed on 2014-04-13 (146 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
Lsusb:
 Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 003: ID 0ac8:c349 Z-Star Microelectronics Corp.
 Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: SAMSUNG ELECTRONICS CO., LTD. 300E4C/300E5C/300E7C
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-24-generic root=UUID=4a883016-3392-4731-824d-ac87981ccaef ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/07/2012
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: P03RAC
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NP300E5X-A04IN
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvrP03RAC:bd05/07/2012:svnSAMSUNGELECTRONICSCO.,LTD.:pn300E4C/300E5C/300E7C:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rnNP300E5X-A04IN:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 300E4C/300E5C/300E7C
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
version.compiz: compiz 1:0.9.11.2+14.04.20140714-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.54-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.2.2-0intel1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.2.2-0intel1
version.xserver-xorg-core: xserver-xorg-core 2:1.15.1-0ubuntu2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.8.2-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.3.0-1ubuntu3
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.911-0intel1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.10-1ubuntu2
xserver.bootTime: Sun Sep 7 22:23:30 2014
xserver.configfile: default
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 5539
 vendor CMO
xserver.version: 2:1.15.1-0ubuntu2

Related branches

Rohan Deshmukh (rohan1024) wrote :
information type: Public → Private Security
information type: Private Security → Public Security
information type: Public Security → Public
Andrea Azzarone (azzar1) on 2014-09-10
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2014-09-10
Changed in unity:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in unity:
milestone: none → 7.3.1
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2014-09-10
Changed in unity:
status: In Progress → Triaged
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Andrea Azzarone (azzar1) on 2015-02-11
Changed in unity:
milestone: 7.3.1 → 7.3.2
Stephen M. Webb (bregma) on 2015-03-13
summary: - Active windows looses focus after returning from HUD if another "Always
+ Active windows loses focus after returning from HUD if another "Always
on top" window is present
Changed in unity:
importance: Undecided → Medium
Changed in unity (Ubuntu):
importance: Undecided → Medium
Stephen M. Webb (bregma) on 2015-03-19
Changed in unity:
milestone: 7.3.2 → 7.3.3
Changed in unity:
assignee: Andrea Azzarone (azzar1) → Christopher Townsend (townsend)
Changed in unity (Ubuntu):
assignee: Andrea Azzarone (azzar1) → Christopher Townsend (townsend)
Changed in unity:
status: Triaged → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.3.2+15.10.20150512-0ubuntu1

---------------
unity (7.3.2+15.10.20150512-0ubuntu1) wily; urgency=medium

  [ Chris Townsend ]
  * Add new signal to tell the Launcher to terminate keynav mode and use
    that signal when a BFB quicklist item is chosen. (LP: #1052024,
    #1444643)
  * Add option to enable and disable Unity low graphics mode on the fly
    in ccsm or via gsettings. (LP: #1412937)
  * Remove code that is no longer needed and broke opening application
    spread while in Launcher keynav mode. (LP: #1445082)
  * Save the active window when showing the Dash so the correct window
    is focused when hiding the Dash. Fixes issue when "Always on Top"
    windows are present. (LP: #1446634)
  * Save the active window when showing the Hud so the correct window is
    focused when hiding the Hud. Fixes issue when "Always on Top"
    windows are present. (LP: #1366583)
  * Send signal to ensure the Dash will show when entering keynav mode
    since the first icon always highlighted is the BFB. (LP: #1444113)
  * When looking for the top-most valid window in a VP, also check if
    the window is focused if the window is set to Always on Top. This
    allows Launcher icon spread to work properly when a window is
    minimized an Always on Top exists in the group. (LP: #1131385)
  * When using the left arrow to exit a Quicklist, Launcher keynav is
    implied and should be active regardless of how the Quicklist was
    opened. (LP: #1444626)

  [ Eleni Maria Stea ]
  * The skydome rendering of the cube plugin was wrong with unity
    because transformation matrices set by the unityshell plugin were
    left in the opengl matrix stacks affecting other compiz plugins.
    Saving the compiz state at the beginning of the unityshell plugin
    rendering functions and restoring it at the end of them fixes the
    problem. (LP: #1446165)

 -- CI Train Bot <email address hidden> Tue, 12 May 2015 13:10:15 +0000

Changed in unity (Ubuntu):
status: In Progress → Fix Released
Changed in unity:
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2015-10-23
description: updated
Changed in unity:
status: Fix Committed → Fix Released

Hello Rohan, or anyone else affected,

Accepted unity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/unity/7.2.6+14.04.20151021-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in unity (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in unity (Ubuntu Trusty):
importance: Undecided → Medium

Installed on 𝐔𝐛𝐮𝐧𝐭𝐮 𝟏𝟒.𝟎𝟒𝐋𝐓𝐒 "Trusty" all 3 patched 𝐔𝐧𝐢𝐭𝐲 𝟕 version 7.2.6+14.04.20151021-0ubuntu1 packages:

unity
unity-services
libunity-core-6.0-9

from the 𝒑𝒓𝒐𝒑𝒐𝒔𝒆𝒅 repo. Did the testcase with VLC v2.2.1 while playing video. Although the VLC window still stays on top playing the video (as it should), focus is still retained on Gnome Files (nautilus) window. I can rename a file from HUD without having to click to bring back focus.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 7.2.6+14.04.20151021-0ubuntu1

---------------
unity (7.2.6+14.04.20151021-0ubuntu1) trusty; urgency=medium

  * New upstream release

  [ Andrea Azzarone ]
  * Merge patch from https://launchpadlibrarian.net/216276242/low-gfx-
    override.patch (LP: #1491913)
  * Properly hide decorations when on "Show Desktop" mode. (LP: #1485073)
  * Do not handle events coming from viewports not actually containing the window.
    (LP: #1449654)
  * Make sure new icons are added to the model before calling SortAndUpdate
    (LP: #1458950)
  * GnomeSessionManager: Do not allow shutdown when screen is locked. (LP: #1460626)
  * GnomeSessionManager: Do not allow shutdown when screen is locked.

  [ Chris Townsend ]
  * When looking for the top-most valid window in a VP, also check if the window
    is focused if the window is set to Always on Top. This allows Launcher icon
    spread to work properly when a window is minimized an Always on Top exists in
    the group. (LP: #1131385)
  * Wait on Spread to be terminated before showing the Quicklist. (LP: #1441626)
  * If dragging an application:// uri type from the Dash to the desktop, change it
    to a file:// uri type so Nautilus can understand the type a make a copy of it
    on the desktop. (LP: #1241972)
  * Enable real page up/page down key navigation in the Dash. When using these
    keys the view scrolls the length of the visible view. (LP: #913612)
  * Save the active window when showing the Hud so the correct window is focused
    when hiding the Hud. Fixes issue when "Always on Top" windows are present.
    (LP: #1366583)
  * Save the active window when showing the Dash so the correct window is focused
    when hiding the Dash. Fixes issue when "Always on Top" windows are present.
    (LP: #1446634)
  * When using keyboard navigation in the Dash, skip category headers that are not
    expandable. Also, do not highlight the category header when the mouse cursor
    is over it. (LP: #1045933)
  * Also use the Compiz show() method when forcing an unmapped window to be
    visible when clicking on it's active Launcher icon. (LP: #989588)
  * Add option to enable and disable Unity low graphics mode on the fly in ccsm or
    via gsettings. (LP: #1412937)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

  [ Marco Trevisan (Treviño) ]
  * ResultViewGrid: wait for double-click event only if the relative result needs
    the Preview (LP: #1291950)
  * OverlayWindowButtons: trigger a queuedraw also when a child requires a redraw
    (LP: #1461618)
  * GnomeSessionManager: Request ScreenSaver (de)activation on VT changes (LP:
    #1405349)
  * UScreen, PanelService: get monitor at position, ignoring pre-multipled Gdk
    scale factor (LP: #1351591)
  * UScreen, PanelService: get monitor at position, ignoring pre-
    multipled Gdk scale factor (LP: #1351591)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 21 Oct 2015 15:54:44 +0000

Changed in unity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for unity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Unity 7.2.6 fixed this bug and is now available in Ubuntu 14.04LTS's updates repo. So, I'm marking this bug as "Fix Released" for Unity .2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers