Ubuntu

Unity through llvmpipe is slow

Reported by Nicolas Delvaux on 2012-09-05
142
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Unity
High
Nicolas d'Offay
6.0
High
Nicolas d'Offay
unity (Ubuntu)
High
Unassigned

Bug Description

I have a two years old laptop (AMD, 1core@1.6Ghz) which video card is not supported by any driver (ATI radeon X1200).

On Precise, it ran with Unity 2D. It was not really fast, but it was usable.
I tested Quantal (latest daily-live) and I found that the desktop was not usable.

- the opening/closing animation of a window or menu takes 3 seconds each time
- opening the dash takes around 5 seconds
- moving windows is horribly jerky
- when idle (just with a terminal and a top), compiz eat ~8% of the CPU

AFAIK, compiz supports degrading the user experience according to the computer capabilities.
So why not applying a custom profile to llvmpipe to disable menu fade in/out, windows animations, blur and/or transparency?

Such (supposedly) simple changes could boost FPS quite a bit and lead weak computers to be usable again in this use case.
I could not test myself because ccsm is no longer available in Quantal (I don't know how to tweak Compiz/Unity without it).

Related branches

Omer Akram (om26er) wrote :

ccsm is available you may need to run: sudo apt-get update.

and we should try to do something about the situation :/

affects: compiz (Ubuntu) → unity (Ubuntu)

Le 05/09/2012 21:52, Omer Akram a écrit :
> ccsm is available you may need to run: sudo apt-get update.

Indeed, sorry.

Disabling the "Animations" plugin helped a bit. I also disabled the blur
and set the launcher opacity to 1.

With this, the desktop is still not usable but it is quicker (the Dash
opens in 2 seconds instead of 5, moving from one indicator to another
takes 2 seconds instead of 3).

The worst seems to be with scale, workspace switching/overview and
windows movements. I did not found any setting to really improve them.

Changed in unity:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
tags: added: llvmpipe
Changed in compiz:
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
madbiologist (me-again) wrote :

The ATI Radeon X1200 should be supported by the open-source radeon driver. Can you please attach the contents of your dmesg file and the outputs of the following commands:

lspci -vvnn
glxinfo |grep render

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Nicolas Delvaux (malizor) wrote :

@madbiologist: This specific card has some quirks.
https://bugs.freedesktop.org/show_bug.cgi?id=37679
https://bugs.freedesktop.org/show_bug.cgi?id=35457

These issues are being addressed upstream, but in the mean time I have to use Unity 2D or llvmpipe (by setting the nomodeset kernel option).

However, the point of this bug report is that Unity through llvmpipe is not usable when one only has a weak CPU.

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Neil J. Patel (njpatel) on 2012-10-01
Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10
Changed in unity:
assignee: nobody → Nicolas d'Offay (nicolas-doffay)
milestone: none → 6.8.0
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:unity at revision 2774
Fix committed into lp:unity/6.0 at revision 2748

Changed in unity:
milestone: 6.8.0 → 7.0.0
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package unity - 6.8.0-0ubuntu1

---------------
unity (6.8.0-0ubuntu1) quantal-proposed; urgency=low

  [ Ángel Guzmán Maeso ]
  * debian/unity-crashdb.conf:
    - Update dictionary option for follow latest apport spec

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - unity 6.8 candidate segfaults on "app expose" with low gfx mode
      (LP: #1060148)
    - [regression] Dash - Left separator is missing (LP: #1057798)
    - unity-panel-service crashed with SIGSEGV in
      panel_indicator_entry_accessible_get_n_children() from
      atk_object_get_n_accessible_children() (LP: #913324)
    - [regression] If unity is started with maximized dash, unmaximizing the
      dash does not wrap rows (LP: #1053116)
    - Dash lens buttons don't work after changing form factor to maximize on
      desktop (LP: #1053316)
    - Clicking on Workspace Switcher icon when the expo is showing, not always
      closes it 1059759 convert files list deprecated keys (LP: #1059594)
    - Unity through llvmpipe is slow (LP: #1046497)
    - compiz crashed with SIGSEGV in unity::QuicklistView::Show() from
      unity::QuicklistManager::ShowQuicklist() (LP: #1055995)
    - compiz crashed with SIGSEGV from
      unity::dash::HomeLens::Impl::LensSearchFinished() (LP: #1054219)
    - [regression] Starting an app & then locking to launcher is not persistent
      across sessions (LP: #1054645)
    - [regression] Dash, Launcher, Menu Bar - Unintended shadows are rendered
      for the Unity Launcher and Panel, when the dash is open (LP: #1043260)
    - [Unity 6.x] Active blur doesn't update if you disable CCSM > OpenGL >
      Framebuffer object (LP: #1039999)
    - Alt+Tab/Alt+grave brings other window to the front but loses focus
      entirely. (LP: #1035628)
    - Spread - Scaling all the windows is too slow (LP: #1055643)
    - Window management - Middle clicking on a window inside the spread should
      close that window (equivalent action to clicking on the close button)
      (LP: #1052821)
    - Scale window decorations don't have properly rounded corners
      (LP: #1055610)
    - Scale window decorations text does not match theme style (Radiance)
      (LP: #1055609)
    - Spread window decorations does not match the theme when changed
      (LP: #1055605)
    - scaled window decorations are sometimes wider than the window
      (LP: #1053225)
    - Launcher should not auto-hide after dragging an icon, if mouse is still
      over it (LP: #1053978)
    - unity spread window on second click not working when ibus language panel
      is shown. (LP: #1035895)
    - windows.push_back(<uninitialized value>) in
      BamfLauncherIcon::GetFocusableWindows (LP: #1053220)
    - Category emblems are blurry (LP: #1056874)
    - Rendering flaws of the dash previews (LP: #1055455)
    - [UIFe] Social Lens doesn't have authorised and meaningful icon
      (LP: #1056191)
    - [dash] Preview fade out animation hangs occasionally (LP: #1058145)
    - Dash - rendering of ribbons shouldn't be relative (LP: #1057971)
    - Horizontal alignment search box and views below (LP: #1055544)
    - Compiz crashed in cairo_save() from
      unity::Unit...

Read more...

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
diego (marcodiegomesquita) wrote :

It would also be a good idea to disable animations when in low graphics mode. In a slow computer, more time is spent waiting for animations to finish then using applications.

David Lawson (deej) wrote :

This hasn't actually fixed my case, that of unity being incredibly slow when using fallback software rendering in Virtual Box. My machine is pretty beefy, so I don't think it's a capacity problem, I'm perfectly happy to re-open the original bug I filed about this if this doesn't seem an appropriate place to address it.

Owais Lone (loneowais) wrote :

Is it possible to force Unity to run in the low-gfx-mode on regular gfx card? LIke Aero interface can be disabled on Windows 7 to improve performance and possibly save energy. Something like this in Unity would be awesome. I mean we already have this low-gfx-mode, all we need is an option in CCSM to force it.

Carnalbeast (carnalbeast) wrote :

I have a quadcore 3.4ghz , 8gb ram , amd gts 250 (also i have an atiradeon hd) and i can't even play a video on youtube are you people got crazy ???
This sucks 5 times more than vista (without service pack)

madbiologist (me-again) wrote :

@carnalbeast - The GTS 250 sounds like an NVIDIA card, not AMD. Both that card and the Radeon HDxxxx should not need to fallback to software rendering. Are you sure you are using llvmpipe? If not, you wil have more success if you file a separate bug report?

madbiologist (me-again) wrote :

Please ignore the final question mark on my previous comment.

Daniel van Vugt (vanvugt) wrote :

I agree the fix to Unity 6.8.0 is inadequate to address the fundamental slowness of LLVMpipe. The low-gfx-mode branch should not have been linked to this bug.

However it is done now and fix released. If you still have performance problems then it's more appropriate to open a new bug to discuss them. Sorry about that.

Changed in unity:
status: Fix Committed → Triaged

I have tested four different types of graphic cards running Unity using Intel Core 2 Processors and found this:

- AMD64 edition performs so much slower than i386 one, and it's more noticeable when playing Adobe Flash videos.

- The Unity interface has some glitches using Nvidia GeForce 8500GT with nouveau drivers, and performs somehow slow with the propiertary ones due to insuficient graphic procesing power.

- Intel G33 and ATI Radeon Mobility X1400 perform slow due to insuficient graphic procesing power.

- Using xorg drivers, ATI Radeon HD5750 performs somehow slow under 32-bits edition and very slow under the 64-bits. Using fglrx, performs very slow in any case.

So I conclude:

- It will be very difficult to end users to know at this time which graphics procesor to buy, since these tests suggest lots of cards are experiencing issues right now and it's not very obvious which of them are before buying.

- It is better for me to stay using Ubuntu 12.04 in almost two of three computers I have, specially when derivatives as Xubuntu have many bugs at this time.

- This is a big thread for Ubuntu and will decrease its adoption by a lot, since it concers for many people a critical part of the operating system: the interface.

- And the most important: Ubuntu livecircle must improve to stop these big issues to happen to time to time. Perhaps developers of many Debian packages are only interested in finding bugs just before next Debian release rather than Ubuntu's ones, so these packages enter deeply untested into the final version of Ubuntu.

I have this problem on my Asus EEEPC 1225c which Intel Atom N2600 (2 generic and 2 theards = 4x1.6 Ghz) and Intel GMA3600 graphics card.
Ubuntu 12.10 loaded, but it's horrible! Dash too very slow, windows rendering between 5-7 secunds.

Well, I think I exaggerated a bit. Although AMD64 edition is performing slow, i386 one seems not too bad. Lag in 32-bit only happens under special circumstances, like when playing Adobe Flash videos, and it is not so relevant.

Albert Pool (albertpool) wrote :

As said at bug 1074779, some users (Intel graphics) get llvmpipe where they shouldn't.

Daniel van Vugt (vanvugt) wrote :

Fix committed in lp:unity. I can see the original proposal for lp:unity/6.0 is present in lp:unity too but not sure what revision it appeared in.

Changed in unity:
status: Triaged → Fix Committed
Daniel van Vugt (vanvugt) wrote :

That said, the problem is not fixed at all. Now tracking in bug 1055936.

no longer affects: compiz
Stephen M. Webb (bregma) on 2013-02-19
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Released → Fix Committed
Stephen M. Webb (bregma) wrote :

Fix Released in Unity Unity 7.0.0 "R series".

Changed in unity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers