FFe: webapps, previews and coverflow support to Unity/bamf/nux

Bug #1043676 reported by Timo Jyrinki on 2012-08-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Unassigned
Unity
Fix Released
High
Unassigned
bamf (Ubuntu)
High
Unassigned
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

== Feature ==

bamf and Unity would be ready for releasing with the webapps support included, and Unity with Dash previews feature and coverflow support. Nux includes an animation framework needed by coverflow.

== Issues causing need for exception ==

There were delays getting the webapps code merged, which was the last feature wanted in. Additionally we have needed to prepare and test the new bamf and Unity together with the updated nux and the compiz GLES work (that landed in trunk only after FF), complicating delivery. The intertwined FFe about compiz GLES is bug #1043589, since for properly working Compiz GLES needs to be bundled with fixes that are included now in Unity.

Testing has been conducted with help of a PPA at https://launchpad.net/~unity-team/+archive/release that contains packaged versions of nux, Compiz 0.9.8.0 (GLES support), bamf and a selected snapshot of unity.

description: updated
description: updated
description: updated
summary: - FFe: webapps support to Unity and bamf
+ FFe: webapps, previews and coverflow support to Unity/bamf/nux
description: updated
description: updated
Changed in bamf (Ubuntu):
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu):
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Hey release team,

We decided to have one FFe bug for landing the current unity trunk since there is no real way to land features individually at this point, it will have to be land the new unity with everything it includes or not...

That FFe depends on bug #1043589 (GLES support for compiz), both need to land together.

If you need motivation to accept it for beta1, we need that to land if we want an arm* desktop back.

It would also be problematic to not land some of the unity dash work and we better get that included in beta1 and tested than after beta1.

The work has already got quite some ppa testing and the unity developpement team has focussed on precise on getting everything that land tested through automated or manual test and has built a good testsuit which helps on assuring the quality

Iain Lane (laney) wrote :

Ack. Approved.

Changed in unity (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
Changed in nux (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
Changed in bamf (Ubuntu):
milestone: none → ubuntu-12.10-beta-1
Changed in bamf (Ubuntu):
status: Confirmed → Triaged
Changed in nux (Ubuntu):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Kate Stewart (kate.stewart) wrote :

Need a status update on this, since a unity trunk landed and we have an ARM desktop - what's still left? and when will it be landing?

Timo Jyrinki (timo-jyrinki) wrote :
Download full text (6.9 KiB)

Fixed in the below releases, uploaded to quantal-proposed on Aug 31 and quantal on Sep 1.

(note: Unity changelog seems to lack a mention of webapps support in its description of the new upstream release, but the support was committed on Aug 24 at http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2624 but didn't include a bug number directly - unity 6.4.0 was branches from bzr 2632 so it's included. The changelog unfortunately also has only indirect mentions of coverflow and previews feature, which were also included and first committed at http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2592 and http://bazaar.launchpad.net/~unity-team/unity/trunk/revision/2568)

---------------

nux (3.4.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release.
    - introduced NuxCore animation framework
    - nux::ScrollView::FindAreaUnderMouse takes scroll-bars into account when
      they are disabled. (LP: #1039480)

bamf (0.3.0-0ubuntu1) quantal-proposed; urgency=low

  * Note that while technically that update breaks compatibility by
    dropping some public functions the corresponding code never worked and
    it has been verified those were not used by any rdepends.
  * debian/control:
    - Build-Depends on libunity-webapps-dev to prepare the landing of the
      branch using it
  * debian/libbamf3-0.symbols:
    - updated as well

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - added webapps support
  * debian/libbamf0.symbols:
    - updated symbol file, removed some broken methods

unity (6.4.0-0ubuntu1) quantal-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream release.
    - Software Center add to launcher icon animation is delayed when the
      launcher is in auto-hide mode (LP: #1012896)
    - Home lens: Applications show up in Music category (LP: #1040101)
    - WARN unity.hud.hud Hud.cpp:185 Attempted to close the hud connection
      without starting it (LP: #1039451)
    - Text field textures do not update when maximum width changes.
      (LP: #1037187)
    - An application is closed if manually removed from favorites on gsettings
      (LP: #1032157)
    - The switcher (Alt+Tab) is showing incorrect windows after using Deskop
      Wall (Ctrl+alt+<direction>) (LP: #1031959)
    - Dragging icons to reorder -away from launcher causes the dragged icon
      image edges to fade away(cut off) (LP: #1026247)
    - Screen flickers when changing launcher icon size. (LP: #1024113)
    - Arrow for indicating lenses points empty space on alt+F2 (LP: #998752)
    - [previews] Music album tracks do not have a scroll-bar when needed.
      (LP: #1039462)
    - [USE_MODERN_COMPIZ_GL] With unity scrollbar support enabled, hotplugging
      monitors doesn't work (LP: #1039410)
    - [previews] Track titles aren't escaped (LP: #1039020)
    - Launcher - Edge of tiles (with backlight disabled) is too opaque
      (LP: #1038138)
    - [USE_MODERN_COMPIZ_GL] Benchmark window appears behind the Unity shell
      now (LP: #1036609)
    - [GLES] [USE_MODERN_COMPIZ_GL] Unity shell (Launcher and Panel) are
      missing if framebuffer_object is disabled (LP: #1036569)
    - [USE_MO...

Read more...

Changed in bamf (Ubuntu):
status: Triaged → Fix Released
Changed in nux (Ubuntu):
status: Triaged → Fix Released
Changed in unity (Ubuntu):
status: Triaged → Fix Released
Changed in unity:
importance: Undecided → High
status: New → Fix Released
Changed in nux:
importance: Undecided → High
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers