Unity does not display on desktop after fresh Quantal daily install

Bug #1041942 reported by Carla Sella
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Expired
Undecided
Unassigned
unity (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

I had just installed Ubuntu Quantal Daily (http://cdimage.ubuntu.com/daily-live/20120825/quantal-desktop-amd64.iso) on my HP G62 laptop, rebooted for first login, but after entering my password I get an empty desktop, with only the purple background and nothing else, I tried to reboot (using command line as I have nothing on my Desktop), but nothing changed, I rebooted a second time, tried to launch apt-get update and apt-get upgrade, but still nothing changes, my desktop is completly empty.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: unity (not installed)
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Sun Aug 26 22:34:00 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120825)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Carla,

Could you please run this command on the affected machine
    /usr/lib/nux/unity_support_test -p
and post the output here?

Please also run:
    apport-collect 1041942
which will upload more details about your system.

Changed in unity (Ubuntu):
status: Confirmed → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
Revision history for this message
Carla Sella (carla-sella) wrote :

Daniel,
Here is the output of the "/usr/lib/nux/unity_support_test -p -d :0" command, as I wasn't able to open terminal on my desktop I ran this command from the terminal got with CTRL+ALT+F1:

OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile
OpenGL version string: 2.1 Mesa 8.1-devel

Not software rendered: #[32;01myes#[00m
Not blacklisted: #[32;01myes#[00m
GLX fbconfig: #[32;01myes#[00m
GLX texture from pixmap: #[32;01myes#[00m
GL npot or rect textures: #[32;01myes#[00m
GL vertex program: #[32;01myes#[00m
GL fragment program: #[32;01myes#[00m
GL vertex buffer object: #[32;01myes#[00m
GL framebuffer object: #[32;01myes#[00m
GL version is 1.4+: #[32;01myes#[00m

Unity 3D supported: #[32;01myes#[00m

Changed in unity (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Carla Sella (carla-sella) wrote :
Download full text (4.6 KiB)

Daniel,
I'm having problems with apport-collect, here's the output:

letozaf@letozaf-HP-G62-Notebook-PC:/usr/bin$ sudo apport-collect 1041942
[sudo] password for letozaf:
The authorization page:
 (https://launchpad.net/+authorize-token?oauth_token=9KVVl9Pq1q8GMskpHMD4&allow_permission=DESKTOP_INTEGRATION)
should be opening in your browser. Use your browser to authorize
this program to access Launchpad on your behalf.
Press any key to continue or wait (5) seconds...
Waiting to hear from Launchpad about your decision...
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-ja-jp.conf", line 141: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-zh-tw.conf", line 79: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 9: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 26: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 31: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 40: Having multiple values in <test> isn't supported and may not works as expected
Running global cleanup code from study base classes.
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-ja-jp.conf", line 141: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/69-language-selector-zh-tw.conf", line 79: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 9: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 22: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 26: Having multiple <family> in <alias> isn't supported and may not works as expected
Fontconfig warning: "/etc/fonts/conf.d/90-fonts-nanum.conf", line 31: Having multiple values in <test> isn't supported and may not works as expected
Fontconfig warnin...

Read more...

Revision history for this message
Carla Sella (carla-sella) wrote :

This is what I managed to collect running: "apport-cli -f -p unity --save filename" this is the output of filename (not much):

ProblemType: Bug
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Mon Aug 27 18:24:53 2012
DistroRelease: Ubuntu 12.10
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120825)
Package: unity (not installed)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
SourcePackage: unity
Tags: quantal
Uname: Linux 3.5.0-11-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Carla,

When the bug occurs, please log in to a virtual terminal (Ctrl+Alt+F1) and run:
    pidof compiz
Do you get any result?

Please also copy and attach the file .xsession-errors from your home directory.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Carla,

In the description it says:
    Package: unity (not installed)
which is probably the real problem.

In a virtual terminal again, you can use these commands to update your system and get the missing packages:
    sudo apt-get update
    sudo apt-get dist-upgrade

If there are any conflicting webapps packages, please remove them with:
    sudo apt-get remove ....

Revision history for this message
Carla Sella (carla-sella) wrote :

Daniel,
For comment #6, the result of "pidof compiz" was:
1790

I am attaching the .xsessions-errors from my home directory.

Revision history for this message
Carla Sella (carla-sella) wrote :

Daniel,
For comment #7, I ran sudo apt-get update and sudo apt-get dist-upgrade from a terminal, got no conflicting webapps packages and rebooted, but the situation has not changed, when I logon, I only get my desktop background and no icons, seems like unity did not install.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Carla,

You are missing at least two critical packages, which is why Unity is not visible:
    compiz-gnome
    unity

If you cannot fix this yourself, please attach the full package list from:
    dpkg -l > pkglist.txt

Changed in compiz (Ubuntu):
status: Incomplete → Invalid
Changed in unity (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
Changed in compiz (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
Carla Sella (carla-sella) wrote :

Daniel,

I solved the problem using:
apt-get install unity

But my aim wasn't solve the problem on my own but to help you understand why a clean install of an Ubuntu daily ISO didn't work and after reboot unity was missing.
I was installing just for testing and did not have any urgency to solve the problem.
If I can do anything to help, I'm here.
Thanks.

Revision history for this message
Simon Yeats (yeatsie) wrote :

Had a blank desktop, as above described. managed to fix it by doing this;

sudo apt-get remove fglrx
sudo reboot

Now its all back to normal again (although i may not have optimal gfx
drivers)

Revision history for this message
Carla Sella (carla-sella) wrote :

It didn't work for me:

sudo apt-get remove fglrx
[sudo] password for letozaf:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'fglrx' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Revision history for this message
Carla Sella (carla-sella) wrote :

Just to give it a try I installed fglrx, but when I rebooted all I got was a black desktop whith a white arrow cursor, had to uninstall it to go back do my destkop wihtout anything on it.
Anyway do not know what caused it but now my desktop is also all messed up, see screenshot.

Revision history for this message
Carla Sella (carla-sella) wrote :
Revision history for this message
Carla Sella (carla-sella) wrote :

When I open a window it remains on the background, and the labels of the launcher remain visible even when I move away from an icon.

Revision history for this message
Carla Sella (carla-sella) wrote :

I had reported bug #1066264 after testing an upgrade from Precise to Quantal.
My problems have been solved installing missing ubuntu-desktop.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for unity (Ubuntu) because there has been no activity for 60 days.]

Changed in unity (Ubuntu):
status: Incomplete → Expired
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for compiz (Ubuntu) because there has been no activity for 60 days.]

Changed in compiz (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers