flaky autopkgtests cause migration issues

Bug #1532358 reported by Michał Sawicz
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
High
Alejandro J. Cura
unity-scope-click (Ubuntu)
Fix Released
High
dobey
unity-scopes-shell (Ubuntu)
Fix Released
High
Marcus Tomlinson

Bug Description

A few times recently when unity8 got into xenial-proposed for migration, unity-scope-click's autopkgtest failed on the first run, having passed on the next:

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/u/unity-scope-click/20160105_174239@/log.gz
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/armhf/u/unity-scope-click/20160108_185317@/log.gz
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-ci-train-ppa-service-landing-030/xenial/armhf/u/unity-scope-click/20160111_213558@/log.gz

This delays migration until someone notices the failure and asks for a re-run, which usually passes.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: unity-scope-click 0.1.1+16.04.20151216.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.3.0-5.16-generic 4.3.3
Uname: Linux 4.3.0-5-generic x86_64
ApportVersion: 2.19.3-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Jan 9 00:29:21 2016
SourcePackage: unity-scope-click
UpgradeStatus: Upgraded to xenial on 2015-10-28 (72 days ago)

Related branches

Revision history for this message
Michał Sawicz (saviq) wrote :
Michał Sawicz (saviq)
description: updated
dobey (dobey)
Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in unity-scopes-shell (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Pawel Stolowski (stolowski)
Changed in unity-scope-click (Ubuntu):
assignee: nobody → Pawel Stolowski (stolowski)
status: Confirmed → In Progress
Changed in unity-scopes-shell (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
milestone: none → ww08-2016
status: New → In Progress
Revision history for this message
Paweł Stołowski (stolowski) wrote :

I can easily reproduce this failure on a slow VM (cpu cap of 10% of my host cpu) and I see where it fails, but after spending a few hours debugging it I got nowhere close to an explanation or a fix. May be a race. It's definately not a click scope fault, the problem is either in scope-harness or shell plugin itself. Since I cannot focus on this problem right now, perhaps as a temporary workaround it's best to disable this test for now.

dobey (dobey)
Changed in unity-scope-click (Ubuntu):
assignee: Pawel Stolowski (stolowski) → Rodney Dawes (dobey)
Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Triaged
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

If you think it's ok, please proceed with temporary disabling as this is indeed causing trouble now that all silos depend on autopkgtests in order to get into QA.

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
dobey (dobey)
Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1.1+16.04.20160210-0ubuntu1

---------------
unity-scope-click (0.1.1+16.04.20160210-0ubuntu1) xenial; urgency=medium

  * Always convert query to lowercase. Add operator override to read
    call params back out for testing. Refactor tests to be able to test
    that query is lowercase. (LP: #1420528)
  * Disable harness tests during build for now. (LP: #1532358)
  * Refactor showing review widget to only do work if app is installed.
    Add qualifier to only show review widget if app has download_url
    from store. Don't check review.rating again to see if review is
    being submitted or not. (LP: #1392307, #1421710)

 -- Rodney Dawes <email address hidden> Wed, 10 Feb 2016 17:09:17 +0000

Changed in unity-scope-click (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
dobey (dobey)
Changed in unity-scopes-shell (Ubuntu):
assignee: Paweł Stołowski (stolowski) → Pete Woods (pete-woods)
Changed in unity-scopes-shell (Ubuntu):
assignee: Pete Woods (pete-woods) → Marcus Tomlinson (marcustomlinson)
dobey (dobey)
Changed in unity-scope-click (Ubuntu):
status: Fix Released → In Progress
Changed in unity-scopes-shell (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

http://autopkgtest.ubuntu.com/packages/unity-scope-click has been passing for a while again, thanks!

Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Michael Terry (mterry) wrote :

Running the tests during autopkg run were disabled. The script simply builds the package again. So it's not a surprise that they pass. (unless I'm missing some new information)

But it would be good to have a fix for the underlying issue so that we can re-enable the tests for real.

Changed in unity-scope-click (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Michael Terry (mterry) wrote :

(er, or we could use a new bug for the root problem and leave this fix-released)

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

Let's continue to use this bug. It was technically incorrect for it to have been marked Fixed.

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This bug is being held back by the following issue: https://bugs.launchpad.net/ubuntu/+source/qtbase-opensource-src/+bug/1618590

(i.e. the click scope is set faulting upon shutdown causing the autopkgtests to bomb out)

Revision history for this message
Michael Terry (mterry) wrote :

Hmm, bummer it's in qt, that's a little slow to be patched. From Timo in that bug:

"For qtbase, we can continue to follow http://code.qt.io/cgit/qt/qtbase.git/log/src/dbus?h=5.6 and https://codereview.qt-project.org/#/q/owner:%22Thiago+Macieira%22+status:open,n,z for any patches to try, but otherwise we should try to workaround the issue."

So is there a workaround for this to get autopkgtests going again? Timo points at some other package workarounds, I don't know if they'd be suitable here.

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

Other than ignore that the scope crashed during the test (https://code.launchpad.net/~marcustomlinson/unity-scope-click/update-harness-tests/+merge/306428), there's no easy way around this issue.

The bug is clearly in the depths of Qt, we could attempt to sidestep that code path but the effort is nontrivial and misplaced imo.

I've left a comment about our situation on the relevant Qt bug (https://bugreports.qt.io/browse/QTBUG-52988). Let's keep an eye on it.

Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :
Changed in unity-scopes-shell (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1.1+16.10.20161003-0ubuntu1

---------------
unity-scope-click (0.1.1+16.10.20161003-0ubuntu1) yakkety; urgency=medium

  * Update and re-enable the harness tests. (LP: #1532358)

 -- Rodney Dawes <email address hidden> Mon, 03 Oct 2016 13:50:18 +0000

Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers