scoperunner crashed with SIGSEGV in QObject::disconnect()

Bug #1618590 reported by Emanuele Antonio Faraone on 2016-08-30
148
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
qtbase-opensource-src (Ubuntu)
Critical
Timo Jyrinki
unity-scope-click (Ubuntu)
Undecided
Rodney Dawes

Bug Description

crash

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: unity-scope-click 0.1.1+16.10.20160808-0ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Uname: Linux 4.4.0-9136-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
Date: Tue Aug 30 17:54:20 2016
ExecutablePath: /usr/lib/x86_64-linux-gnu/unity-scopes/scoperunner
InstallationDate: Installed on 2016-08-27 (3 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
ProcCmdline: /usr/lib/x86_64-linux-gnu/unity-scopes/scoperunner /usr/lib/x86_64-linux-gnu/unity-scopes/clickapps/clickscope.ini
Scope: Apps
Signal: 11
SourcePackage: unity-scope-click
StacktraceTop:
 QObject::disconnect(QObject const*, char const*, QObject const*, char const*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
 ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
 start_thread (arg=0x7fae9eade700) at pthread_create.c:333
Title: scoperunner crashed with SIGSEGV in QObject::disconnect()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

information type: Private → Public

StacktraceSource:

StacktraceTop:

Changed in unity-scope-click (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for libgflags2v5
no debug symbol package found for liburcu4

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace

The system is up to date, I still encounter the crash.

every time I log out of the unity 8 environment and log into unity 7 environment a bunch of random crashes pop up

Timo Jyrinki (timo-jyrinki) wrote :

I'm getting this one too.

Changed in unity-scope-click (Ubuntu):
status: Invalid → Confirmed
Ken VanDine (ken-vandine) wrote :

I suspect this might be a bug in qtdbus 5.6.

https://codereview.qt-project.org/#/c/161056/

Rodney Dawes (dobey) wrote :

This appears to be a crash inside Qt itself, and only occurs with 5.6+, apparently due to QDBus changing to use threading instead of the event loop, for asynchronous operations. There seems to be some fixes in Qt Code Review that should theoretically fix this. It would be nice if we could test these and get them into our release of Qt. I'm afraid there won't be any way to work around this crash in the scope or ubuntu-download-manager (we're keeping a u-d-m singleton object around, which is destroyed on exit) code itself.

affects: unity-scope-click (Ubuntu) → qtbase-opensource-src (Ubuntu)
Rodney Dawes (dobey) wrote :

Sorry, the fix in Qt's code review system is at https://codereview.qt-project.org/#/c/161056/

Timo Jyrinki (timo-jyrinki) wrote :

Was the fix tested already with a qtbase compilation?

Both it and its pre-requirement https://codereview.qt-project.org/#/c/157488 are not merged in upstream, so would need to be merged first. There may be some trouble they are causing since they are not yet merged.

Timo Jyrinki (timo-jyrinki) wrote :

Please test from https://requests.ci-train.ubuntu.com/#/ticket/1960 and report back - builds are complete now.

Rodney Dawes (dobey) wrote :

Sorry, no, I didn't build qtbase from source to test.

I've added the silo, but I still get a crash with this same stack trace when the scope is destroyed. I guess further fixes in Qt are required beyond these changes perhaps.

Changed in qtbase-opensource-src (Ubuntu):
status: Confirmed → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

Ok then :( If you also double-chcecked your libqt5core5 (etc) are version 5.6.1+dfsg-3ubuntu6~1

For qtbase, we can continue to follow http://code.qt.io/cgit/qt/qtbase.git/log/src/dbus?h=5.6 and https://codereview.qt-project.org/#/q/owner:%22Thiago+Macieira%22+status:open,n,z for any patches to try, but otherwise we should try to workaround the issue.

If you can describe the remaining problems or even produce an easy test case for upstream, please file a bug at https://bugreports.qt.io/ for Thiago to see.

Gustavo Boiko has been hard at reworking telepathy-qt to work with the new QDBus behaviors in 5.6, here are references to what kind of changes he has needed to do:

http://launchpadlibrarian.net/280893997/telepathy-qt_0.9.6.1-6ubuntu1_0.9.6.1-7ubuntu2.diff.gz
http://launchpadlibrarian.net/284273846/telepathy-qt_0.9.6.1-7ubuntu2_0.9.6.1-9ubuntu6.diff.gz

tags: added: qt5.6
Changed in canonical-devices-system-image:
milestone: none → x1
Changed in unity-scope-click (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
Changed in qtbase-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed

According to https://bugreports.qt.io/browse/QTBUG-52988, those patches worked when applied on top of Qt5.7, I wonder if we're missing something important between 5.6 -> 5.7

Timo Jyrinki (timo-jyrinki) wrote :

https://codereview.qt-project.org/#/c/140750/ (Stop unloading plugins in QPluginLoader and QFactoryLoader) mentioned in a comment was still missing from our build.

It's now building (ubuntu6~2 and ubuntu6~xenialoverlay1~2). Let's test all three patches once the builds are completed.

Yes! I've just confirmed that the packages in https://bileto.ubuntu.com/#/ticket/1960 fix the issue! Thanks Timo!

Changed in unity-scope-click (Ubuntu):
status: Confirmed → Invalid
Timo Jyrinki (timo-jyrinki) wrote :

I've pushed now also updated gles packages to the PPA. After that, I'll start the autopkgtests which will take 1-2 days to finish.

I've also asked if upstream could consider the third patch for their 5.6 LTS series, as it's not currently there and it would always be better if they also carry the patch.

Changed in qtbase-opensource-src (Ubuntu):
status: Incomplete → In Progress
Changed in canonical-devices-system-image:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1618590

tags: added: iso-testing
Timo Jyrinki (timo-jyrinki) wrote :

Unfortunately upstream won't be merging the third patch to 5.6 series, so it's only in Qt 5.8. It hides the problem instead of fixing the problem, which is that there is a plugin that doesn't unregister its objects before unloading.

I've prepared another silo https://bileto.ubuntu.com/#/ticket/2015 with alternative third patch that _is_ being considered for 5.6: https://codereview.qt-project.org/#/c/172173/

Let's test it and if it fixes the problem too, land that one instead.

Timo Jyrinki (timo-jyrinki) wrote :

Marcus confirmed the new patch also fixes the issue! I will start landing ticket #2015 now instead. Again autopkgtests will unfortunately take 1-2 days.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.6.1+dfsg-3ubuntu6~4

---------------
qtbase-opensource-src (5.6.1+dfsg-3ubuntu6~4) yakkety; urgency=medium

  [ Dmitry Shachnev ]
  * Mark allow_native_menubar.diff as applied upstream.
  * debian/patches/dbustray_cleanup_notifier.diff:
    - Fix a bug in QSystemTrayIcon code where the notifier was not cleaned
      up and the callback was called multiple times.

  [ Timo Jyrinki ]
  * debian/patches/Fix-some-QtDBus-crashes-during-application-destructi.patch
    debian/patches/Merge-the-QDBusMetaType-s-custom-information-to-QDBu.patch
    debian/patches/Make-the-bearer-QFactoryLoader-a-member-variable-not.patch:
    - More D-Bus fixes (LP: #1618590)

 -- Timo Jyrinki <email address hidden> Wed, 28 Sep 2016 18:14:12 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
status: Confirmed → Fix Committed
Changed in qtbase-opensource-src (Ubuntu):
importance: Undecided → Critical
Changed in canonical-devices-system-image:
importance: Undecided → Critical

now i forgot how to submit bugs

another thing is o found some new bugs in 17.04 Zesty Zapus

1.unable to use Unity 8

2. Software center is missing

3. technically everything is missing in unity 8 that was in unity 7

4. Every time i use software updater i get this error "Repository failed" i can't remember what the error was.

5. This does not seem the correct link for bug reporting but my memory sucks.

6.in details it says i'm running 16.10 but if i go into terminal and type "lsb_release -a" is says i'm using 17.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers