Unity Greeter - Dialogs in unity-greeter are not using Unity shutdown dialogues

Bug #857577 reported by Frederik Elwert
182
This bug affects 37 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Fix Committed
High
Mika Meskanen
unity-greeter (Ubuntu)
Fix Released
Medium
Robert Ancell

Bug Description

In the unity lightdm greeter, the default GTK theme is used. Thus, dialogs like the shutdown dialog do not match Ubuntu’s default theme (Ambiance). This affects the visible coherence and beauty of the login screen.

Desired Solution:
- Unity Greeter should use the same shutdown dialogues as targeted for Precise, see section 1.1.2 in https://docs.google.com/a/canonical.com/document/d/1ILTJDiDCd25Npt2AmgzF8aOnZZECxTfM0hvsbWT2BxA/edit?hl=en_GB for full details

Revision history for this message
Frederik Elwert (frederik-elwert) wrote :
affects: lightdm (Ubuntu) → unity-greeter (Ubuntu)
Changed in unity-greeter (Ubuntu):
status: New → Confirmed
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Robert Roth (evfool)
Changed in unity-greeter (Ubuntu):
status: Confirmed → Triaged
Changed in unity-greeter (Ubuntu):
importance: High → Low
summary: - default GTK theme in LightDM unity greeter
+ Dialogs in unity-greeter are not using Ambiance style
Revision history for this message
eZFlow (breakdevize) wrote : Re: Dialogs in unity-greeter are not using Ambiance style

final release is just a few days away and bugs like this are still in.. amazing.

Revision history for this message
Joschi Poschi (joschiposchi) wrote :

Can't quite understand why this isn't fixed yet, it looks really ugly compared to the unity-greeter's design.

Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote :

It is just not fixed yet. If you want to spped this up, contribute a patch!

Revision history for this message
Sebastien Bacher (seb128) wrote :

seems to be a race or something since it doesn't happen to all configurations (i.e it happens on my netbook but not on my laptop config there)

Changed in unity-greeter (Ubuntu Oneiric):
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Lilian A. Moraru (lilianmoraru) wrote :

Fitoschido, oh how I like this kind of response... Most of us here are just simple users which care for the project enough to hassle to take some time to report the bug and have no programming skills and that's the response that they receive?

John Lea (johnlea)
description: updated
tags: added: udp
Changed in ayatana-design:
assignee: nobody → Mika Meskanen (mesq)
importance: Undecided → High
status: New → Triaged
description: updated
summary: - Dialogs in unity-greeter are not using Ambiance style
+ Unity Greeter - Dialogs in unity-greeter are not using Ambiance style
Changed in unity-greeter:
status: New → Triaged
importance: Undecided → Low
importance: Low → Medium
Changed in unity-greeter (Ubuntu):
importance: Low → Medium
Changed in ayatana-design:
status: Triaged → Fix Committed
Revision history for this message
Fritz Heinrichmeyer (fritz-heinrichmeyer) wrote : Re: Unity Greeter - Dialogs in unity-greeter are not using Ambiance style

i see this behavior still on a system with kde installed, but not on another "pure gnome" box. I use default config files.

Revision history for this message
Fritz Heinrichmeyer (fritz-heinrichmeyer) wrote :

WORKAROUND:
configure gtk3 in the home directory of lightdm user

/var/lib/lightdm/.config/gtk-3.0/settings.ini

with following text:

[Settings]
gtk-theme-name = Ambiance
gtk-icon-theme-name=ubuntu-mono-dark
gtk-fallback-icon-theme=ubuntu-mono-dark

so somehow the lightdm user environment seems not configured properly. If this the reason, on my box without this annoyance there should be a more complete set of config files. I can look for it on monday.

Revision history for this message
Satchit Bhogle (satchitb) wrote :

Fritz Heinrichmeyer, the file mentioned in your workaround does not exist.

Revision history for this message
Andrew Heil (heilandrew) wrote :

Create the directory and file and add the contents to it that Fritz Heinrichmeyer suggests. It works.

Revision history for this message
Adolfo Jayme Barrientos (fitojb) wrote :
summary: - Unity Greeter - Dialogs in unity-greeter are not using Ambiance style
+ Unity Greeter - Dialogs in unity-greeter are not using Unity shutdown
+ dialogues
John Lea (johnlea)
no longer affects: unity-greeter (Ubuntu Oneiric)
Changed in unity-greeter (Ubuntu):
assignee: Robert Ancell (robert-ancell) → nobody
Changed in unity-greeter (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
Revision history for this message
Robert Ancell (robert-ancell) wrote :
Changed in unity-greeter:
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Changed in unity-greeter (Ubuntu):
status: In Progress → Fix Committed
no longer affects: unity-greeter
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-greeter - 14.04.0-0ubuntu1

---------------
unity-greeter (14.04.0-0ubuntu1) trusty; urgency=low

  * New upstream release:
    - Use Unity style shutdown dialogs (LP: #857577)
    - Handle hardware power button in greeter (LP: #903306)
    - Use an Upstart process to start indicator services (LP: #1185565)
    - Fix build with Vala 0.22
    - Clean up compile warnings
 -- Robert Ancell <email address hidden> Mon, 11 Nov 2013 17:16:17 +1300

Changed in unity-greeter (Ubuntu):
status: Fix Committed → Fix Released
tags: added: rls-w-incoming
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers