Indicators fail to load

Bug #724717 reported by Johan Kiviniemi on 2011-02-25
64
This bug affects 13 people
Affects Status Importance Assigned to Milestone
unity-2d
Critical
Aurélien Gâteau
unity-2d (Ubuntu)
High
Aurélien Gâteau
Natty
High
Aurélien Gâteau

Bug Description

Binary package hint: unity-2d-panel

Indicators fail to load in unity-2d. The following lines appear in .xsession-errors:

(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libapplication.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed
(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libmessaging.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed
(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libsoundmenu.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed
(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libdatetime.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed
(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libme.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed
(<unknown>:14941): libindicator-WARNING **: File '/usr/lib/indicators/4/libsession.so' does not exist.
(<unknown>:14941): libindicator-CRITICAL **: indicator_object_get_entries: assertion `INDICATOR_IS_OBJECT(io)' failed

The likely culprit:

unity-2d/panel/applets/indicator/indicator.c:#define INDICATOR_DIR "/usr/lib/indicators/4/"

% tree /usr/lib/indicators
/usr/lib/indicators
└── 5
    ├── libapplication.so
    ├── libappmenu.so
    ├── libdatetime.so
    ├── libme.so
    ├── libmessaging.so
    ├── libsession.so
    └── libsoundmenu.so

If I patch the /usr/bin/unity-2d-panel binary to point to /usr/lib/indicators/5/ the indicators work again.

ProblemType: BugDistroRelease: Ubuntu 11.04
Package: unity-2d 3.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic-pae 2.6.37
Uname: Linux 2.6.37-12-generic-pae i686
NonfreeKernelModules: fglrx wl
Architecture: i386
Date: Fri Feb 25 05:28:36 2011
EcryptfsInUse: Yes
PackageArchitecture: allSourcePackage: unity-2d

Related branches

Johan Kiviniemi (ion) wrote :
Johan Kiviniemi (ion) on 2011-02-25
description: updated
Omer Akram (om26er) wrote :

yes I have seen this for a few days, but thought it might be my system but its because unity-2d was not adapted to the libindicator change.

Changed in unity-2d (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in unity-2d:
status: New → Confirmed
Florian Boucault (fboucault) wrote :

It should be fixed in Natty now. Thanks a lot Johan for reporting the issue! If there is still a problem please reopen the bug.

Omer Akram (om26er) wrote :

this issue is still there, re-opening

Changed in unity-2d (Ubuntu):
milestone: none → natty-alpha-3
Ugo Riboni (uriboni) on 2011-02-28
Changed in unity-2d:
milestone: none → 3.8
Johan Kiviniemi (ion) wrote :

Wouldn’t it be better not to hardcode the path but get it from libindicator-dev instead?

% pkg-config --variable=indicatordir indicator
/usr/lib/indicators/5/

Omer Akram (om26er) wrote :

changing unity-2d/panel/applets/indicator/indicator.c:#define INDICATOR_DIR "/usr/lib/indicators/4/ to /5/ brings back the indicators but not the application menus.

Omer Akram (om26er) wrote :

a recent update to dbusmenu and other appindicator stack brought the AppMenus too but something like this happens when you try to access them. see the video

Aurélien Gâteau (agateau) wrote :

@Johan: Very good idea. I was not aware this information was in the pkg-config files. I implemented it in: lp:~agateau/unity-2d/fix-indicator-dir (ready for review)

Changed in unity-2d:
status: Confirmed → In Progress
importance: Undecided → Critical
assignee: nobody → Aurélien Gâteau (agateau)

I got the update today and get the same issue as Omer... By the way, I still don't have the app indicators nor color on the background of launcher icons (Mine looks different than attached video) Is this a bug?

Martin Pitt (pitti) on 2011-03-01
Changed in unity-2d (Ubuntu Natty):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Changed in unity-2d:
status: In Progress → Fix Committed
Simeon (simeon5) wrote :

I too still have the issue. Its hard to logoff without any panel buttons :)

Omer Akram (om26er) on 2011-03-12
Changed in unity-2d (Ubuntu Natty):
status: Confirmed → Triaged
Changed in unity-2d (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
David Barth (dbarth) on 2011-03-23
Changed in unity-2d (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Aurélien Gâteau (agateau)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-2d - 3.8-0ubuntu1

---------------
unity-2d (3.8-0ubuntu1) natty; urgency=low

  * New upstream bugfix release
   - fixes (LP: #580295),(LP: #670403),(LP: #676457),(LP: #706247),
   (LP: #708429),(LP: #719507),(LP: #724717),(LP: #726712),(LP: #726715),
   (LP: #726727),(LP: #727164),(LP: #727409),(LP: #730499),(LP: #733244),
   (LP: #733960),(LP: #738025),(LP: #739417),(LP: #740137),(LP: #740280),
   (LP: #691114),(LP: #701543),(LP: #701546),(LP: #703389),(LP: #703396),
   (LP: #705642),(LP: #706248),(LP: #706713),(LP: #709280),(LP: #711081),
   (LP: #714707),(LP: #716167),(LP: #721049),(LP: #722711),(LP: #722713),
   (LP: #723604),(LP: #726630),(LP: #726682),(LP: #726716),(LP: #727883),
   (LP: #729699),(LP: #730638),(LP: #730880),(LP: #732978),(LP: #733154),
   (LP: #733897),(LP: #733959),(LP: #734143),(LP: #738332),(LP: #683026),
   (LP: #718866),(LP: #721121),(LP: #724316),(LP: #731165),(LP: #734074),
   (LP: #735500),(LP: #716506),(LP: #733150),(LP: #672447),(LP: #716580),
   (LP: #728291),(LP: #730884),(LP: #731263),(LP: #731266)
 -- Oliver Grawert <email address hidden> Wed, 23 Mar 2011 15:31:16 +0100

Changed in unity-2d (Ubuntu Natty):
status: Triaged → Fix Released
Changed in unity-2d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers