package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade: ErrorMessage: под процеса инсталиран е скрипта post-installation върна грешка за състояние за излизане от 127

Bug #549285 reported by Totalchaos on 2010-03-27
86
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Plymouth
Incomplete
Undecided
christos katsogiannis
ubuntustudio-look (Ubuntu)
High
Scott Lavender
Lucid
High
Scott Lavender

Bug Description

Binary package hint: ubuntustudio-look

the package ubuntustudio-plymouth-theme 0.38 is giving error 127 during install/uninstall

ProblemType: Package
Architecture: amd64
Date: Sat Mar 27 04:01:58 2010
DistroRelease: Ubuntu 10.04
ErrorMessage: ErrorMessage: под процеса инсталиран е скрипта post-installation върна грешка за състояние за излизане от 127
InstallationMedia: Ubuntu-Studio 10.04 "Lucid Lynx" - Alpha amd64 (20100326)
NonfreeKernelModules: nvidia
Package: ubuntustudio-plymouth-theme 0.38
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.32-17.26-preempt 2.6.32.10+drm33.1
SourcePackage: ubuntustudio-look
Title: package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade: ErrorMessage: под процеса инсталиран е скрипта post-installation върна грешка за състояние за излизане от 127
Uname: Linux 2.6.32-17-preempt x86_64

Revision history for this message
Totalchaos (biser-angelov) wrote :
Revision history for this message
Steve Langasek (vorlon) wrote :

The ubuntustudio-plymouth-theme package's postinst calls:

                /usr/sbin/plymouth-set-default-theme --rebuild-initrd ubuntustudio-logo

plymouth-set-default-theme has been dropped from the plymouth package intentionally. This theme package needs to be updated to use update-alternatives instead. Please see the plymouth-theme-ubuntu-logo package for an example.

Changed in ubuntustudio-look (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in ubuntustudio-look (Ubuntu Lucid):
status: Triaged → In Progress
assignee: nobody → Scott Lavender (slavender)
Revision history for this message
Scott Lavender (slavender) wrote :

Thanks Steve.

Revision history for this message
Adam Stovicek (arstovicek) wrote :

I just came across this issue while trying out the lubuntu-desktop packages. Same condition exists in the postinst and postrm calls for the lubuntu-plymouth-theme package.

affects: ubuntustudio → lnr
Changed in lnr:
assignee: nobody → Lubuntu Packages Team (lubuntu-packaging)
affects: lnr → plymouth
Revision history for this message
Julien Lavergne (gilir) wrote :

See bug 550011 for lubuntu-artwork

Changed in plymouth:
assignee: Lubuntu Packages Team (lubuntu-packaging) → nobody
Revision history for this message
varun (varun-magical) wrote :

I had same problem.. just ran update manager & it fixed the issue after updating.

Revision history for this message
miguelator (miguel+angel) wrote :

In my case plymouth works well but the agent of updates says to me that I have updates of plymouth and that it is that desintalar "ubuntustudio-themes-plymouth" and 127 gives me the error on having tried desintalar, and does not continue with the update, the curious thing of all this that it is that this topic is not installed in the team bony does not exist.

Revision history for this message
miguelator (miguel+angel) wrote :

In/lib/plymouth/themes 'ubuntustudio-logo' is not, in Synaptic if it is but allows me neither to do anything with, nor to install it not desinstalarlo not desinstalarlo completely, this seems slightly more than a bug.

Revision history for this message
miguelator (miguel+angel) wrote :

Solved =gksu nautilus = to think about how plymouth to erase everything of ubuntustudio and fact everything works again.

Revision history for this message
miguelator (miguel+angel) wrote :

Solved =gksu nautilus = to look about how plymouth to erase everything of ubuntustudio and fact everything works again.

Revision history for this message
Scott Lavender (slavender) wrote :

Just to explain for ubuntustudio-plymouth-theme (which is similar to xubuntu-plymouth-theme and lubuntu-plymouth-theme I believe):

ubuntustudio-plymouth-theme-0.37 relied on the "plymouth-set-default-theme" command, which has since been intentionally removed from the plymouth package in plymouth-0.8.1-1ubuntu1, to set ubuntustudio-plymouth-theme as the default Plymouth theme.

When ubuntustudio-plymouth-theme-0.37 is installed, the proper files should be copied to your computer but when the installation tries to invoke "plymouth-set-default-theme" to set the default Plymouth theme it fails and gives an error (127) which stops the installation.

Similarly, if you try to remove ubuntustudio-plymouth-theme-0.37 it also gives the same error because, once again, it tries to invoke "plymouth-set-default-theme" to revert away from the ubuntustudio-plymouth-theme to another theme. Again, this stops the process.

So, if your plymouth package is updated beyond what is installed from the Beta 1 ISO (I forget which version of plymouth it was but I believe it was 0.8.0.12 or something similar) ubuntustudio-plymouth-theme-0.37 will no longer work.

Last night I updated ubuntustudio-plymouth-theme to use 'update-alternatives' instead and tested it with a ppa build. Tonight I should be committing 0.38 to bzr for merging before Beta 2 freeze.

Changed in ubuntustudio-look (Ubuntu Lucid):
status: In Progress → Fix Committed
Revision history for this message
christos katsogiannis (katsogiannisc) wrote :

i had the same problem yesterday. apt-get could not locate a shell-script on the /usr/sbin folder and giving an error.
i had to create this file manually with permissions and try to take updates again.
worked fine and plymouth works fine with every theme.

Revision history for this message
Paolo (simonato-mail) wrote : Re: [Bug 549285] Re: package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade: ErrorMessage: под процеса инсталиран е скрипта post-installation върна грешка за състояние за излизане от 127

Many thanks, i made the same... all ok.

Thank
Bye

2010/3/30 christos katsogiannis <email address hidden>

> i had the same problem yesterday. apt-get could not locate a shell-script
> on the /usr/sbin folder and giving an error.
> i had to create this file manually with permissions and try to take updates
> again.
> worked fine and plymouth works fine with every theme.
>
> --
> package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade:
> ErrorMessage: под процеса инсталиран е скрипта post-installation върна
> грешка за състояние за излизане от 127
> https://bugs.launchpad.net/bugs/549285
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Plymouth splash screen: New
> Status in “ubuntustudio-look” package in Ubuntu: Fix Committed
> Status in “ubuntustudio-look” source package in Lucid: Fix Committed
>
> Bug description:
> Binary package hint: ubuntustudio-look
>
> the package ubuntustudio-plymouth-theme 0.38 is giving error 127 during
> install/uninstall
>
> ProblemType: Package
> Architecture: amd64
> Date: Sat Mar 27 04:01:58 2010
> DistroRelease: Ubuntu 10.04
> ErrorMessage: ErrorMessage: под процеса инсталиран е скрипта
> post-installation върна грешка за състояние за излизане от 127
> InstallationMedia: Ubuntu-Studio 10.04 "Lucid Lynx" - Alpha amd64
> (20100326)
> NonfreeKernelModules: nvidia
> Package: ubuntustudio-plymouth-theme 0.38
> PackageArchitecture: all
> ProcVersionSignature: Ubuntu 2.6.32-17.26-preempt 2.6.32.10+drm33.1
> SourcePackage: ubuntustudio-look
> Title: package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade:
> ErrorMessage: под процеса инсталиран е скрипта post-installation върна
> грешка за състояние за излизане от 127
> Uname: Linux 2.6.32-17-preempt x86_64
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/plymouth/+bug/549285/+subscribe
>

Revision history for this message
Krishna (kpulusu) wrote :

what is the content of the shell script and the file name to be created in /usr/sbin. I would really appreciate for your help

Revision history for this message
christos katsogiannis (katsogiannisc) wrote :

Hello Krishna.

the name of the scell script file on the /usr/sbin folder was "plymouth-set-default-theme"
i don't know the content of the file, since the file was missing. That's why i had this error.
i create the file using the following command
"sudo chmod +x /usr/sbin/plymouth-set-default-theme" and then i try to take the updates again.
hope that helps

Revision history for this message
Krishna (kpulusu) wrote :

Hey it worked. thank you very much. appreciate your prompt reply.

Thanks and have a nice day
Krishna

2010/3/30 christos katsogiannis <email address hidden>

> Hello Krishna.
>
> the name of the scell script file on the /usr/sbin folder was
> "plymouth-set-default-theme"
> i don't know the content of the file, since the file was missing. That's
> why i had this error.
> i create the file using the following command
> "sudo chmod +x /usr/sbin/plymouth-set-default-theme" and then i try to take
> the updates again.
> hope that helps
>
> --
> package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade:
> ErrorMessage: под процеса инсталиран е скрипта post-installation върна
> грешка за състояние за излизане от 127
> https://bugs.launchpad.net/bugs/549285
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The Plymouth splash screen: New
> Status in “ubuntustudio-look” package in Ubuntu: Fix Committed
> Status in “ubuntustudio-look” source package in Lucid: Fix Committed
>
> Bug description:
> Binary package hint: ubuntustudio-look
>
> the package ubuntustudio-plymouth-theme 0.38 is giving error 127 during
> install/uninstall
>
> ProblemType: Package
> Architecture: amd64
> Date: Sat Mar 27 04:01:58 2010
> DistroRelease: Ubuntu 10.04
> ErrorMessage: ErrorMessage: под процеса инсталиран е скрипта
> post-installation върна грешка за състояние за излизане от 127
> InstallationMedia: Ubuntu-Studio 10.04 "Lucid Lynx" - Alpha amd64
> (20100326)
> NonfreeKernelModules: nvidia
> Package: ubuntustudio-plymouth-theme 0.38
> PackageArchitecture: all
> ProcVersionSignature: Ubuntu 2.6.32-17.26-preempt 2.6.32.10+drm33.1
> SourcePackage: ubuntustudio-look
> Title: package ubuntustudio-plymouth-theme 0.38 failed to install/upgrade:
> ErrorMessage: под процеса инсталиран е скрипта post-installation върна
> грешка за състояние за излизане от 127
> Uname: Linux 2.6.32-17-preempt x86_64
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/plymouth/+bug/549285/+subscribe
>

Changed in plymouth:
assignee: nobody → christos katsogiannis (katsogiannisc)
status: New → In Progress
Revision history for this message
Scott Lavender (slavender) wrote :

ubuntustudio-look (0.38.1) lucid; urgency=low

  * 'update-alternatives' replaces 'plymouth-set-default-theme' in
    postinst and postrm files (LP #549285)

  * added ${misc:Depends} to -theme, -gdm-theme, -wallpaper and -look

  * upped debhelper depends version from (>= 5) to (>= 5.0.51~)

  * added Depends: ubuntustudio-plymouth-theme to ubuntustudio-look

 -- Scott Lavender <email address hidden> Sun, 28 Mar 2010 08:55:44 -0500

Changed in ubuntustudio-look (Ubuntu Lucid):
status: Fix Committed → Fix Released
Revision history for this message
Scott Lavender (slavender) wrote :

Setting this bug to incomplete for Plymouth as the Ubuntu Studio package did not implement the Plymouth theme correctly rather than a bug existing in Plymouth.

Changed in plymouth:
status: In Progress → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers