ubuntuone-syncdaemon crashed with OSError in _upgrade_metadata_2()

Bug #405688 reported by Eric Casteleijn on 2009-07-28
100
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
John Lenton
ubuntuone-client (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ubuntuone-client

On karmic, directly after rebooting. I'm on a wireless connection, that may be intermittently working.

ProblemType: Crash
Architecture: i386
Date: Tue Jul 28 10:04:04 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: ubuntuone-client 0.91.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/ubuntuone-client/ubuntuone-syncdaemon
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-4.23-genusername
PythonArgs: ['/usr/lib/ubuntuone-client/ubuntuone-syncdaemon']
SourcePackage: ubuntuone-client
Title: ubuntuone-syncdaemon crashed with OSError in _upgrade_metadata_2()
Uname: Linux 2.6.31-4-generic i686
UserGroups: adm admin audio cdrom couchdb dialout dip disk fax floppy fuse lpadmin netdev plugdev powerdev pulse pulse-access pulse-rt sambashare scanner tape uml-net vboxusers video

Eric Casteleijn (thisfred) wrote :
tags: removed: need-duplicate-check
dobey (dobey) on 2009-08-12
Changed in ubuntuone-client (Ubuntu):
status: New → Triaged
status: Triaged → Confirmed
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → John Lenton (chipaca)
tags: added: foundations+ karmic-blocker
Eric Casteleijn (thisfred) wrote :

This still happens every time I boot, and I haven't been able to start the client since the upgrade. Please let me know if I can provide more information.

Eric Casteleijn (thisfred) wrote :

After an upgrade yesterday it started crashing once per second, and the only way I could stop it was to kill -9 the applet. Today, however, the problem is gone! I don't know if this is an intentional fix or collateral damage from other bugfixes, but I'm happy!

Eric Casteleijn (thisfred) wrote :

Actually that is false. I don't know why things worked for one whole dat on the 21st but when I booted this morning, the crash report per second behavior was back, and after a dist-upgrade and another reboot it does not go away...

visibility: private → public
John Lenton (chipaca) on 2009-08-27
Changed in ubuntuone-client:
status: Triaged → In Progress
dobey (dobey) on 2009-08-27
Changed in ubuntuone-client:
status: In Progress → Fix Committed
dobey (dobey) on 2009-08-27
Changed in ubuntuone-client (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntuone-client - 0.93.1-0ubuntu1

---------------
ubuntuone-client (0.93.1-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Fix AttributeError in __hide_icon (LP: #419488)
    - Fix OSError crash in syncdaemon (LP: #419533)
    - Fix OSError in _upgrade_metadata_2 (LP: #405688)

ubuntuone-client (0.93.0-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Fix crash with KeyError in __getitem__ (LP: #404934)
    - Fix fatal error constant occurrances (LP: #414635)
    - Fix ability to reauthorize (LP: #406897)
    - Get rid of animated icon, and false activity status (LP: #414925)
  * Update Standards-Version to 3.8.3

 -- Rodney Dawes <email address hidden> Thu, 26 Aug 2009 17:15:00 -0400

Changed in ubuntuone-client (Ubuntu):
status: Fix Committed → Fix Released
Elliot Murphy (statik) on 2009-09-04
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
tags: added: ubuntuone-karmic
removed: karmic-blocker
papukaija (papukaija) on 2010-08-05
tags: added: karmic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers