do-release-upgrade --sandbox fails

Bug #1605259 reported by Kaleb Hornsby on 2016-07-21
142
This bug affects 25 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Fails to create AUFS mount

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.220.8
ProcVersionSignature: Ubuntu 3.19.0-64.72~14.04.1-generic 3.19.8-ckt22
Uname: Linux 3.19.0-64-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.21
Architecture: amd64
CrashDB: ubuntu
Date: Thu Jul 21 09:33:50 2016
DistributionChannelDescriptor:
 # This is a distribution channel descriptor
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-trusty-amd64-osp1-20150720-0
InstallationDate: Installed on 2016-06-30 (21 days ago)
InstallationMedia: Ubuntu 14.04 "Trusty" - Build amd64 LIVE Binary 20150720-04:06
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/usr/bin/fish
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to trusty on 2016-07-21 (0 days ago)

Related branches

Kaleb Hornsby (kzh) wrote :
Dave Morley (davmor2) wrote :

See attached screenshot I am able to reproduce this issue the sandbox environment fails. And launches an apport instance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Dave Morley (davmor2) wrote :

It appears that this feature has been broken for a while so should either be dropped or fixed.

tags: added: rls-y-incoming
tags: added: bugpattern-written
tags: added: rls-z-incoming
removed: rls-y-incoming
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:17.10.3

---------------
ubuntu-release-upgrader (1:17.10.3) artful; urgency=medium

  * Remove --sandbox (aufs support) as it has been broken for some time and
    was rather unused. (LP: #1605259)

 -- Brian Murray <email address hidden> Thu, 18 May 2017 10:51:34 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Brian Murray (brian-murray) wrote :

Come to find out you can also pass the --sandbox switch to update-manager so that needs fixing too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:17.10.1

---------------
update-manager (1:17.10.1) artful; urgency=medium

  [ Steve Langasek ]
  * ubuntu-support-status: instead of checking the Release timestamp in
    the releases file for every single package on the system, get the
    release date from distro-info-data because it will always be the same.
    This speeds up the script by > 50% in testing.

  [ Brian Murray ]
  * update-manager: Clarify that the "-d" switch is only for upgrading from
    the latest supported release to the development release, not any release.
    (LP: #1700829)
  * Remove --sandbox (aufs support) as it has been broken for some time and
    was rather unused. (LP: #1605259)

 -- Brian Murray <email address hidden> Wed, 12 Jul 2017 15:03:18 -0700

Changed in update-manager (Ubuntu):
status: New → Fix Released
To post a comment you must log in.