Comment 3 for bug 1424426

dsa42 (davidsangulo) wrote :

Thanks for the help.

I did this:

$ sudo do-release-upgrade -d

During the upgrade, the following error was reported:

Preparing to unpack .../util-linux_2.25.2-4ubuntu2_amd64.deb ...
Unpacking util-linux (2.25.2-4ubuntu2) over (2.20.1-5.1ubuntu20.4) ...
Processing triggers for man-db (2.7.0.2-2) ...
Processing triggers for mime-support (3.55ubuntu1.1) ...
Setting up util-linux (2.25.2-4ubuntu2) ...
Installing new version of config file /etc/cron.weekly/fstrim ...
insserv: Service mountdevsubfs has to be enabled to start service hwclock
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 util-linux
Error in function:

SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/problem_report.py", line 416, in add_to_existing
    self.write(f)
  File "/usr/lib/python3/dist-packages/problem_report.py", line 369, in write
    block = f.read(1048576)
  File "/usr/lib/python3.4/codecs.py", line 313, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0x8b in position 1: invalid start byte

Original exception was:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).