not possible to calculate upgrade from T to U with lubuntu-core as the metapkg

Bug #1424426 reported by dsa42 on 2015-02-22
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Unassigned

Bug Description

automatic

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-release-upgrader-core 1:0.220.7
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: LXDE
Date: Sun Feb 22 13:29:59 2015
InstallationDate: Installed on 2013-10-15 (494 days ago)
InstallationMedia: Lubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to trusty on 2015-02-22 (0 days ago)
VarLogDistupgradeTermlog:

mtime.conffile..etc.update.manager.release.upgrades: 2015-02-22T13:26:05.969655

dsa42 (davidsangulo) wrote :
Brian Murray (brian-murray) wrote :

It looks like you have the lubuntu-core meta pkg installed and not the lubuntu-desktop meta package. If you want to upgrade you might just try upgrading via apt (you can find instructions on-line). This issue should be fixed by the following change in Vivid, although that won't help upgrading to utopic.

ubuntu-release-upgrader (1:15.04.8) vivid; urgency=medium

  * data/DistUpgrade.cfg: Add xubuntu-core and lubuntu-core to MetaPkgs and
    add KeyDependencies for them. Thanks to LP user Unit 193 for working on
    this.

 -- Brian Murray <email address hidden> Mon, 23 Feb 2015 10:28:34 -0800

summary: - automatic
+ not possible to calculate upgrade from T to U with lubuntu-core as a
+ metapkg
summary: - not possible to calculate upgrade from T to U with lubuntu-core as a
+ not possible to calculate upgrade from T to U with lubuntu-core as the
metapkg
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: lubuntu
dsa42 (davidsangulo) wrote :

Thanks for the help.

I did this:

$ sudo do-release-upgrade -d

During the upgrade, the following error was reported:

Preparing to unpack .../util-linux_2.25.2-4ubuntu2_amd64.deb ...
Unpacking util-linux (2.25.2-4ubuntu2) over (2.20.1-5.1ubuntu20.4) ...
Processing triggers for man-db (2.7.0.2-2) ...
Processing triggers for mime-support (3.55ubuntu1.1) ...
Setting up util-linux (2.25.2-4ubuntu2) ...
Installing new version of config file /etc/cron.weekly/fstrim ...
insserv: Service mountdevsubfs has to be enabled to start service hwclock
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package util-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 util-linux
Error in function:

SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/problem_report.py", line 416, in add_to_existing
    self.write(f)
  File "/usr/lib/python3/dist-packages/problem_report.py", line 369, in write
    block = f.read(1048576)
  File "/usr/lib/python3.4/codecs.py", line 313, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0x8b in position 1: invalid start byte

Original exception was:
SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)

Could not install the upgrades

The upgrade has aborted. Your system could be in an unusable state. A
recovery will run now (dpkg --configure -a).

dsa42 (davidsangulo) wrote :

After doing the above, I did the following:
    dan@Latitude-E6410:~$ lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 15.04
    Release: 15.04
    Codename: vivid
    dan@Latitude-E6410:~$ sudo /usr/bin/update-manager
    [sudo] password for dan:

and I received a bunch of errors including the following:

Error loading .desktop file /usr/share/applications/kde4/knetattach.desktop: constructor returned NULL
Error loading .desktop file /usr/share/app-install/desktop/kde-runtime:kde4__knetattach.desktop: constructor returned NULL
Error loading .desktop file /usr/share/applications/lubuntu-screenlock.desktop: constructor returned NULL
Error loading .desktop file /usr/share/applications/lubuntu-logout.desktop: constructor returned NULL
Error loading .desktop file /usr/share/applications/scid.desktop: constructor returned NULL
Error loading .desktop file /usr/share/app-install/desktop/scid:scid.desktop: constructor returned NULL
ERROR:root:Bad upgrade: 'vivid' != 'trusty'
dan@Latitude-E6410:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers