[UIFe] Messaging menu title icons are indistinct

Bug #1056488 reported by Matthew Paul Thomas on 2012-09-25
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
humanity-icon-theme (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned
ubuntu-mono (Ubuntu)
Undecided
Matthieu James
Quantal
Undecided
Matthieu James

Bug Description

ubuntu-mono 0.0.45, Ubuntu Q

1. gthumb /usr/share/icons/Humanity/status/*/user-* /usr/share/icons/ubuntu-mono-*/status/*/indicator-messages-*

What you see:

A. Humanity's standalone IM status icons are a bit hard to see against a white background -- such as Empathy's status menu -- because the tops of the icons are white with no outline.

B. The corresponding emblems are similarly hard to see against the light grey, black, or blue envelopes in Ubuntu Mono's messaging menu icons. <http://cloudfront.omgubuntu.co.uk/wp-content/uploads/2012/08/new-icons.jpg> The Offline and mixed-status icons are particularly bad.

C. The "Invisible" icons and emblems have a pure black or white interior, which just looks weird. <http://cloudfront.omgubuntu.co.uk/wp-content/uploads/2012/09/Screen-Shot-2012-09-19-at-10.34.18.png>

D. The "Available" and "Away" icons look bigger than the others.

What you should see:

A. All the icons, while beautiful, are robust enough to be thoroughly distinct against a white, light grey, or dark grey background.

B. The icons remain simple enough that in emblem form they are thoroughly distinct against a bright blue, light grey, or dark grey background. If necessary, the envelope could have an emblem-shaped chunk bitten out of its bottom right corner, to make the emblem distinct.

C. The "Invisible" icons and emblems have a transparent interior.

D. All the chat status icons look the same size.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-mono (Ubuntu):
status: New → Confirmed
Sam Hewitt (snwh) wrote :

First and foremost I'll apologize if these )proposed) patches are incorrect I'm not entire familiar with creating them.

What I've done is created patches using icons I created screenshots here:

https://dl.dropbox.com/u/7027392/icons-screenshot-ambiance.png
https://dl.dropbox.com/u/7027392/icons-screenshot-radiance.png
https://dl.dropbox.com/u/7027392/messaging-menu-ambiance.png
https://dl.dropbox.com/u/7027392/messaging-menu-radiance.png

Just in case, an archive of the icons here: https://dl.dropbox.com/u/7027392/alternate-messaging-menu-icons.tar.gz

For Humanity/status/*/user-* icons:
1. I thought a uniform shape and size would be most elegant, and the simplest shape: a circle
2. Applied the same colour gradient as the old icons, but no drop shadow.
3. To convey status with out purely being colour different, I emblazoned the circles with symbols to convey status.

For the ubuntu-mono-*/status/*/indicator-messages-* I simply used 16px icon of the Humanity icons as an overlay, but making it larger than the pre-existing.

Sam Hewitt (snwh) wrote :

Just another comment with the second patch.

The attachment "Humanity Icon Theme Patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Sam, unfortunately your icons have much the same problem as the existing ones: they're indistinct against the background. Particularly with indicator-messages-available-new.svg, indicator-messages-invisible.svg, indicator-messages-invisible-new.svg, and indicator-messages-invisible-mixed.svg.

This is not a hard problem. It is not necessary to change the shape or the symbols. Just have enough contrast inside each icon that its outline is clear against blue, black, and silver.

Changed in ubuntu-mono (Ubuntu):
assignee: Matthew Chapman (mattchapman) → Matthieu James (tiheum)
Ivanka Majic (ivanka) wrote :

Attached is an updated set of icons.

1. They increase contrast between the chat status color and the
    envelope colors.

2. They add slight spacing around the chat status to make the shapes
    clearer.

Two other bug fixes will also improve the appearance:

3. By mistake, the previous icons were too small and a bit blurry.
    David Calle fixed that yesterday.

4. The "Available" icon appears by default even when you're offline.
    Ken VanDine will fix that soon, so that by default you get just the
    envelope. Bug 1046360

I propose that we look into these icons in more detail for 13.04 and will file and target a bug.

Ivanka Majic (ivanka) wrote :

New bug filed and proposed for R: Bug #1060301

summary: - Messaging menu title icons are indistinct
+ [UIFe] Messaging menu title icons are indistinct
Sebastien Bacher (seb128) wrote :
Changed in ubuntu-mono (Ubuntu):
status: Confirmed → In Progress
Jeremy Bicha (jbicha) wrote :

I don't understand why the colored status shape still needs to have a gradient as though light is shining on it. My vision of mono icons is that they should be "flat" and simple. Anyway, we're way too late for Quantal to tweak these icons so that suggestion should probably be considered for R instead.

This is clearly a bug fix for Radiance users and I think this should definitely improve the "fuzziness" introduced late in the Quantal cycle to the messaging menu icons.

I talked to the Ubuntu Manual guys and they haven't yet finalized their screenshots (but they will be very soon). +1 from the Docs Team to fix this. Please, please land as soon as possible (i.e. tomorrow would be great, next week would be bad). I believe the absolute final deadline for ubuntu-docs uploads pre-release is next Tuesday, and I have other things I was planning to do this weekend. :-)

tags: added: uife
Stéphane Graber (stgraber) wrote :

Looks reasonable (not a huge change) and doc gave a +1, accepting.

Approved through the queue.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.48

---------------
ubuntu-mono (0.0.48) quantal; urgency=low

  * Improved indicator-messages icons,
    thanks Matthieu James and Lars Uebernickel (lp: #1056488)
 -- Sebastien Bacher <email address hidden> Tue, 02 Oct 2012 21:04:10 +0200

Changed in ubuntu-mono (Ubuntu Quantal):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in humanity-icon-theme (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.6.1

---------------
humanity-icon-theme (0.6.1) quantal; urgency=low

  [ Lars Uebernickel ]
  * Update chat status icons (lp: #1056488)
 -- Sebastien Bacher <email address hidden> Wed, 03 Oct 2012 11:52:11 +0200

Changed in humanity-icon-theme (Ubuntu Quantal):
status: Confirmed → Fix Released

Al 02/10/12 21:08, En/na Sebastien Bacher ha escrit:
> Hey everyone,
>
> The Canonical designer would like to slightly tweak the
> indicator-messages icon to fix some of the background-contrast-issues
> with the current set.
> Those don't change the form or color of the icons and should invalidate
> the documentation screenshots...
>
> The bug used for the UIFe is
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-mono/+bug/1056488
>
> You can get the update package for testing in
> https://launchpad.net/~ubuntu-desktop/+archive/ppa (ubuntu-mono
> uploaded, humanity-icon-theme to follow)
>
> Thanks for considering the update,
> Sebastien Bacher
>

Does not affect translations, so no objections here.

Cheers,
David.

--
David Planella
Ubuntu Translations Coordinator
www.ubuntu.com / www.davidplanella.wordpress.com
www.identi.ca/dplanella / www.twitter.com/dplanella

Changed in ubuntu-mono (Ubuntu Quantal):
status: Fix Released → Triaged
Sebastien Bacher (seb128) wrote :

Sorry guys but the sabdfl asked to revert to the precise icons for this cycle for the indicator (only for the icons in the panel, not the status icons in the menu), the use of emblems,colors for the indicator is problematic apparently ... I did another ubuntu-mono upload with the quantal changes for indicator-messages* reverted (uploaded to the desktop ppa as well if anyone want to test)

Reverted upload accepted.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mono - 0.0.49

---------------
ubuntu-mono (0.0.49) quantal; urgency=low

  * Revert indicator-messages icons to the precise ones (lp: #1056488)
 -- Sebastien Bacher <email address hidden> Wed, 03 Oct 2012 15:44:18 +0200

Changed in ubuntu-mono (Ubuntu Quantal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers