restart notification via ubufox isn't displayed on update of firefox 3.6

Bug #511250 reported by Micah Gersten on 2010-01-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubufox Extension
Undecided
Unassigned
ubufox (Ubuntu)
Undecided
Unassigned
Lucid
High
Unassigned
Maverick
High
Chris Coulson

Bug Description

Binary package hint: ubufox

Reopen Bug #403581 for Firefox 3.6

The notification to restart doesn't display when upgrading Firefox 3.6 - even though ubufox is installed and enabled.

Firefox: 3.6.2+nobinonly-0ubuntu1 to 3.6.3+nobinonly-0ubuntu1
ubufox: 0.9~rc1-0ubuntu1
Ubuntu 10.04(Lucid)

Nobuto Murata (nobuto) on 2010-04-06
summary: - restart notification doesn't display on upgrade to all-in-one 3.6
+ restart notification via ubufox isn't displayed on update of firefox 3.6
Nobuto Murata (nobuto) on 2010-04-06
description: updated
tags: added: regression-potential
Changed in ubufox (Ubuntu):
status: New → Confirmed
Changed in ubufox:
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Is it still an issue in lucid final, and if it is, it fixed in maverick ?

tags: added: lucid regression-release
removed: regression-potential
Changed in ubufox (Ubuntu Lucid):
status: New → Incomplete
Nobuto Murata (nobuto) wrote :

At least in Maverick, it is still an issue.
firefox: 3.6.11+build3+nobinonly-0ubuntu0.10.10.1
ubufox: 0.9~rc2-0ubuntu5

Jean-Baptiste Lallement (jibel) wrote :

thanks for confirming. I'm adding a task for the maverick then.

Changed in ubufox (Ubuntu Maverick):
status: New → Confirmed
Changed in ubufox (Ubuntu Lucid):
status: Incomplete → Confirmed
Chris Coulson (chrisccoulson) wrote :

Will look at this when I arrive at UDS. Unfortunately, I've not noticed this before as I'm not really using 3.6 anymore

Changed in ubufox (Ubuntu Maverick):
importance: Undecided → High
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in ubufox (Ubuntu Lucid):
importance: Undecided → High
Chris Coulson (chrisccoulson) wrote :

Ok, can see what is happening here

Changed in ubufox (Ubuntu Maverick):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubufox - 0.9~rc2-0ubuntu7

---------------
ubufox (0.9~rc2-0ubuntu7) natty; urgency=low

  * Add patch to update for Firefox 4:
    - Rename AboutHome to AboutStartup, and have it handle about:startup now
      (to not conflict with the new about:home handler in Firefox
    - Set default home page to about:startpage
    - Add support for the XPCOM changes in Gecko 2.0
    - In the restart notifier, don't hardcode a list of filenames for different
      browser versions, but just use MOZ_APP_LAUNCHER instead. This will
      indirectly fix LP: #511250 and should prevent it from happening again
    - Look in the new location for the restart-required trigger, it has moved
      to a location not monitored by update-notifier now, so we only get the
      restart required notification in the browser
    - Merge the plugin finder code from Firefox 4. This now uses AddonManager,
      so the MinVersion needs to be bumped
    - Drop the FF2.0 specific code
    - Drop the AddonsOverlay and associated code, this hasn't worked for
      several releases since we started using software-center, and nobody
      really noticed so far. We can reimplement this at a later date if wanted,
      but it throws JS exceptions when loading in FF4.0 now
    - Specify for the extension to be unpacked by the installer. Without this,
      the prefs aren't used
    - Get the distributionID field for the pfs URL from the preferences, rather
      than hard-coding a value
 -- Chris Coulson <email address hidden> Sat, 01 Jan 2011 14:30:25 +0000

Changed in ubufox (Ubuntu):
status: Confirmed → Fix Released
Changed in ubufox:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.8 KiB)

This bug was fixed in the package ubufox - 0.9.3-0ubuntu0.10.10.3

---------------
ubufox (0.9.3-0ubuntu0.10.10.3) maverick-security; urgency=low

  * Fix LP: #918052 - Error migrating extensions to be in-profile
    - Migrate the addon to a profile addon even if there is a system-wide
      addon with the same version. It seems this got broken during some recent
      refactoring.
    - For newly installed addons, display the new addon tab, otherwise the
      addon stays disabled

ubufox (0.9.3-0ubuntu0.10.10.1) maverick-security; urgency=low

  * New upstream release.
    - Support Firefox 9 and 10 (LP: #904594)
  * New upstream release v0.9.2
    - Bump maxVersion to 8.*
  * New upstream release v0.9.1
    - Rename AboutHome to AboutStartpage, and have it handle about:startpage now
      (to not conflict with the new about:home handler in Firefox)
    - Set default home page to about:startpage
    - Add support for the XPCOM changes in Gecko 2.0
    - In the restart notifier, don't hardcode a list of filenames for different
      browser versions, but just use MOZ_APP_LAUNCHER instead. This will
      indirectly fix LP: #511250 and should prevent it from happening again
    - Merge the plugin finder code from Firefox 4. This now uses AddonManager,
      so the MinVersion needs to be bumped
    - Drop the FF2.0 specific code
    - Drop the AddonsOverlay and associated code, this hasn't worked for
      several releases since we started using software-center, and nobody
      really noticed so far. We can reimplement this at a later date if wanted,
      but it throws JS exceptions when loading in FF4.0 now
    - Specify for the extension to be unpacked by the installer. Without this,
      the prefs aren't used
    - Get the distributionID field for the pfs URL from the preferences, rather
      than hard-coding a value
    - Fix LP: #579091 - ubufox interferes with toolbar buttons for other add-ons
      Don't initialize or assign any value to gBrowser in alternatePlugins.js.
      It runs in the context of browser.xul, so gBrowser will always exist
      once the browser window has loaded
    - Fix LP: #333799 - set a default dictionary language
    - Don't duplicate preferences that we're already setting in Firefox
    - Update Japanese(ja) translations (LP: #746538)
    - Fix LP: #750305 - Don't hard-code links and configs for each release.
      Rather than doing this manually for every release, we add a dist.js with
      distro information (populated at build time with lsb_release) and just
      do all this automatically.
    - Fix LP: #752364 - Plugin Finder Service never finds anything. Use the
      release info in dist.js to construct the URL, now that this got dropped
      from Firefox
    - Fix LP: #728826 - Update icons to new versions.
    - Drop the pluginGlue.js module. This didn't work, as we can no longer
      use a modules registerSelf method to use nsICategoryManager at startup,
      due to the XPCOM registration changes in Firefox 4. Instead, add
      category entries with the chrome.manifest
    - Fix LP: #709125 - User agent doesn't include Ubuntu in it so
      apt.ubuntu.com doesn't work. We add an extra X-Ub...

Read more...

Changed in ubufox (Ubuntu Maverick):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.2 KiB)

This bug was fixed in the package ubufox - 0.9.3-0ubuntu0.10.04.3

---------------
ubufox (0.9.3-0ubuntu0.10.04.3) lucid-security; urgency=low

  * Fix LP: #918052 - Error migrating extensions to be in-profile
    - Migrate the addon to a profile addon even if there is a system-wide
      addon with the same version. It seems this got broken during some recent
      refactoring.
    - For newly installed addons, display the new addon tab, otherwise the
      addon stays disabled

ubufox (0.9.3-0ubuntu0.10.04.1) lucid-security; urgency=low

  * New upstream release v0.9.3
    - Support Firefox 9 and 10 (LP: #904594)
  * New upstream release v0.9.2
    - Bump maxVersion to 8.*
  * New upstream release v0.9.1
    - Rename AboutHome to AboutStartpage, and have it handle about:startpage now
      (to not conflict with the new about:home handler in Firefox)
    - Set default home page to about:startpage
    - Add support for the XPCOM changes in Gecko 2.0
    - In the restart notifier, don't hardcode a list of filenames for different
      browser versions, but just use MOZ_APP_LAUNCHER instead. This will
      indirectly fix LP: #511250 and should prevent it from happening again
    - Merge the plugin finder code from Firefox 4. This now uses AddonManager,
      so the MinVersion needs to be bumped
    - Drop the FF2.0 specific code
    - Drop the AddonsOverlay and associated code, this hasn't worked for
      several releases since we started using software-center, and nobody
      really noticed so far. We can reimplement this at a later date if wanted,
      but it throws JS exceptions when loading in FF4.0 now
    - Specify for the extension to be unpacked by the installer. Without this,
      the prefs aren't used
    - Get the distributionID field for the pfs URL from the preferences, rather
      than hard-coding a value
    - Fix LP: #579091 - ubufox interferes with toolbar buttons for other add-ons
      Don't initialize or assign any value to gBrowser in alternatePlugins.js.
      It runs in the context of browser.xul, so gBrowser will always exist
      once the browser window has loaded
    - Fix LP: #333799 - set a default dictionary language
    - Don't duplicate preferences that we're already setting in Firefox
    - Update Japanese(ja) translations (LP: #746538)
    - Fix LP: #750305 - Don't hard-code links and configs for each release.
      Rather than doing this manually for every release, we add a dist.js with
      distro information (populated at build time with lsb_release) and just
      do all this automatically.
    - Fix LP: #752364 - Plugin Finder Service never finds anything. Use the
      release info in dist.js to construct the URL, now that this got dropped
      from Firefox
    - Fix LP: #728826 - Update icons to new versions.
    - Drop the pluginGlue.js module. This didn't work, as we can no longer
      use a modules registerSelf method to use nsICategoryManager at startup,
      due to the XPCOM registration changes in Firefox 4. Instead, add
      category entries with the chrome.manifest
    - Fix LP: #709125 - User agent doesn't include Ubuntu in it so
      apt.ubuntu.com doesn't work. We add an extra X-Ub...

Read more...

Changed in ubufox (Ubuntu Lucid):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers