Ubiquity desktop icon text looks messy

Bug #942539 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-02-28
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Sebastien Bacher
Precise
Medium
Sebastien Bacher
ubiquity (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

On a live CD/USB of Ubuntu the icon for Ubiquity looks like this:-

"Install Ubuntu 12.
            04 LTS"

(with the 04 LTS on the second line, and centred).

It would look more pretty like this:-

"Install Ubuntu
    12.04 LTS"

Can we add a soft carriage return in there, or some other way to make it look less disjointed?

Related branches

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/942539

tags: added: iso-testing
Changed in ubiquity (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: bitesize
tags: added: precise
Stéphane Graber (stgraber) wrote :

I don't think there's much Ubiquity can do here, we simply ship a .desktop file containing a Name= entry.

Now we don't have any control on how gtk/nautilus will wrap it and trying to add spaces or other ugly trick will likely break flavours and translations (where "Install" can be translated to "installieren" for example causing a proper split of 12.04 on a second line).

Brian Murray (brian-murray) wrote :

I wonder if the version information is really useful here. You can't choose to install 11.10 if you've booted a 12.04 live CD. Instead just having "Install Ubuntu" would make more sense to me.

Not having the version number kinda makes sense. I know however in the past I've booted random CDRs and USB sticks and figured out what they were from that icon legend. That said we do say what the version number is in Ubiquity fairly near the start as I recall, so removing the version number wouldn't be too much of a disaster. Wouldn't be a pain to fix the translations either as it's all in that one file.

James Hunt (jamesodhunt) wrote :

Nautilus seems to be considering the period as a sentence end and therefore a legitimate place to wrap the text. However, that is wrong as there is no space following the period.

Note that the '\n' escape sequence _is_ supported:

http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s03.html

This is a hack, but note that it is possible to fool the wrapping code by using a non-ASCII period (such as 'middle-dot' ('·' (0x00B7)), however that does look a little strange :)

Stéphane Graber (stgraber) wrote :

non-ASCII period would work as a workaround, though it indeed looks a bit weird and might change quite a bit depending on the font, so might be problematic with the languages using a non-ubuntu font.

The problem with \n although supported (thanks for that I didn't know) is with translations, you can't assume that putting a \n before the version number will always be right as you might get a language where the version number comes before the "Install Ubuntu" part.

Anyway, this bug should definitely be fixed in nautilus/pango/gtk (or wherever it's) :)

Brian Murray (brian-murray) wrote :

Per a discussion with seb128 and slangasek on #ubuntu-devel I've opened a nautilus bug task for this. The text should not be wrapped after a . that is not followed by a space.

09:41 < seb128> slangasek, bdmurray: yeah, seems a nautilus icon grid bug, when renaming the text entry wraps it correctly

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Paolo Sammicheli (xdatap1) wrote :

Today's image look even more worse: https://launchpadlibrarian.net/97791526/Screenshot%20from%202012-03-21%2020%3A42%3A25.png

It looks like we append the description to the icon name. We found it in the Italian locale but it affected all the languages, including English

@Paolo, this is a different problem report in bug 961141

Steve Langasek (vorlon) on 2012-04-11
Changed in nautilus (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
James Hunt (jamesodhunt) wrote :

This problem appears to be resolved for me on an installed precise system. Copying bar.desktop to ~/Desktop/ and once I allow the file to be "executable" (right click, properties), the icon text shows line 1 as "Install Ubuntu 12.04" and line 2 as "LTS".

Brian Murray (brian-murray) wrote :

Using a Live CD from 20120410 I confirm that the break is between 12.04 and the word LTS.

Yup, booted 12.04 daily AMD64 in VirtualBox (so Unity 2D) and it seemed okay, but not tried Unity 3D.

It is only fixed for English and the default label, the problem is still there for other language. For example in French the the break is between '12.' and '04'

Tested with Ubuntu Desktop amd64 20120412

Martin Pitt (pitti) wrote :

For the record, adding a \n at the place where the word wrap should occur works fine. But that would need to be done in all translations individually, too (at least the ones we care about).

Martin Pitt (pitti) wrote :

Seb and I will look into a proper nautilus fix on Monday. Milestoning for final, as we cannot sensibly SRU this (well, not at least for 12.04 final, just for .1).

Closing ubiquity task, as the workaround is not really appropriate.

Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
status: Invalid → Won't Fix
Changed in nautilus (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Martin Pitt (pitti)
milestone: none → ubuntu-12.04
Martin Pitt (pitti) on 2012-04-13
Changed in nautilus (Ubuntu Precise):
assignee: Martin Pitt (pitti) → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.0-0ubuntu3

---------------
nautilus (1:3.4.0-0ubuntu3) precise; urgency=low

  * debian/patches/dont_wrap_labels_after_dots.patch:
    - don't wrap labels after a dot if they are followed by a number,
      the upstream code has a hack for 3 digit version numbers which
      doesn't really make sense (lp: #942539)
  * debian/patches/git_utf_undo.patch:
    - git patch, fix undo failing to restore files with non ascii chars
      (lp: #973620)
 -- Sebastien Bacher <email address hidden> Sun, 15 Apr 2012 11:46:05 +0200

Changed in nautilus (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers