Ubuntu

Fails to copy directory over symlink (e.g. /var/lock when downgrading from 11.10 to 11.04)

Reported by Brian Murray on 2011-11-17
404
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
High
Unassigned
Natty
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

If one has a running Ubuntu 11.10 system and then boots an Ubuntu 11.04 CD and chooses to install Ubuntu you are presented with an option to "Upgrade from 11.10 to 11.04". Choosing this option results in a crash.

TEST CASE
1) Install Ubuntu 11.10
2) Try to reinstall Ubuntu 11.04 (because you are dissatisfied with the new release for some reason)
3) At the allocate drive space screen choose "Upgrade 11.10 to 11.04" (because you don't want to lose your data)
4) During the copying files phase observe a crash

After the crash ubiquity became non-responsive and I went to a tty to reboot the system. The system fails to boot after choosing either the regular or recovery boot option from 11.10.

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :
Brian Murray (brian-murray) wrote :
description: updated
summary: - "Upgrade" from 11.10 to 11.04 results in a failure
+ "Upgrade" from 11.10 to 11.04 results in a unusable system
description: updated
Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Triaged

I guess the problem is the /run transition, /var/lock is now /run/lock afaik - so a check in install.py if the path is there already for /var/lock may be enough to fix that?

Brian Murray (brian-murray) wrote :

This is Won't Fix for Natty as it would require a respin of the ISOs.

Changed in ubiquity (Ubuntu Natty):
status: New → Won't Fix
importance: Undecided → High
Changed in ubiquity (Ubuntu Oneiric):
importance: Undecided → High
description: updated
tags: added: testcase
tags: added: ubiquity-2.6.10
tags: added: natty
Brian Murray (brian-murray) wrote :

I tested downgrading from 12.04 to 11.10 by installing 12.04 and then booting off an 11.10 CD. I was presented with the same choice to "upgrade from precise to 11.10". I choose this option and have a usable 11.10 system, however I didn't do any thorough testing of it.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Oneiric):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

In the event that you have tried downgrading from Ubuntu 11.10 to Ubuntu 11.04 using an Ubuntu 11.04 CD / DVD and now have a system failing to boot the following steps should allow you to reinstall Ubuntu 11.04 and have a working system.

1) Boot and 11.04 CD
2) Choose Try Ubuntu
3) Download "Install downgrade patch" from this bug report
4
) Open a terminal
5) Execute "sudo patch /usr/share/ubiquity/install.py < ubiquity-downgrade-patch.py" in the terminal
6) Run the installer from the desktop
7) After the install completes reboot the system
8) In the grub menu from the installed system choose "Previous Linux versions"
9) Select the first 2.6.38 kernel version

Now you should be running 11.04 and have access to all your documents.

Brian Murray (brian-murray) wrote :

You also need to manually remove the kernel from 11.10 using the following steps in a terminal:

1) cd /boot
2) sudo rm *3.0.0-12*
3) sudo update-grub

thanks but i already safed my files through knoppix...

but that upgradeproblem was strange, first i tried to upgrade from 11.04 to 11.10...that crashed, after trying downgrading, it also crashes
--
NEU: FreePhone - 0ct/min Handyspartarif mit Geld-zurück-Garantie!
Jetzt informieren: http://www.gmx.net/de/go/freephone

Thanks Brian for your patch, that is really good work!

Thanks for your help.
In the event I used another machine to rescue my private files and then did a clean install of 9.10.
I don't think I will upgrade for a while!
Thanks again

Morris J F Smith

-----Original Message-----
From: Brian Murray <email address hidden>
To: morrissmi <email address hidden>
Sent: Fri, 18 Nov 2011 18:05
Subject: [Bug 891711] Re: "Upgrade" from 11.10 to 11.04 results in a unusable system

You also need to manually remove the kernel from 11.10 using the

following steps in a terminal:

1) cd /boot

2) sudo rm *3.0.0-12*

3) sudo update-grub

--

You received this bug notification because you are subscribed to a

duplicate bug report (886036).

https://bugs.launchpad.net/bugs/891711

Title:

  "Upgrade" from 11.10 to 11.04 results in a unusable system

Status in Release Notes for Ubuntu:

  New

Status in “ubiquity” package in Ubuntu:

  Triaged

Status in “ubiquity” source package in Natty:

  Won't Fix

Status in “ubiquity” source package in Oneiric:

  Confirmed

Status in “ubiquity” source package in Precise:

  Triaged

Bug description:

  If one has a running Ubuntu 11.10 system and then boots an Ubuntu

  11.04 CD and chooses to install Ubuntu you are presented with an

  option to "Upgrade from 11.10 to 11.04". Choosing this option results

  in a crash.

  TEST CASE

  1) Install Ubuntu 11.10

  2) Try to reinstall Ubuntu 11.04 (because you are dissatisfied with the new

release for some reason)

  3) At the allocate drive space screen choose "Upgrade 11.10 to 11.04" (because

you don't want to lose your data)

  4) During the copying files phase observe a crash

  After the crash ubiquity became non-responsive and I went to a tty to

  reboot the system. The system fails to boot after choosing either the

  regular or recovery boot option from 11.10.

To manage notifications about this bug go to:

https://bugs.launchpad.net/ubuntu-release-notes/+bug/891711/+subscriptions

OK im still a little new at this but i upgraded from 11.04 to 11.10 to 12.04 now i want to go back to 11.10 clean install or at least a downgrade and that's where the problem starts. OH I'm also duel booted with win-xp. So I ran the live DVD disk of 11.10 and I tell it I want to install, then I select language, the next screen that I see is the partition window, there it says that I dont have any OS's on my HDD. OH BTW (dell Inspiron 9400)..... So now i have to back up every thing on win xp and deal with hrs of BS of updates....HELP... when I boot my pc up it loads with out problems all OS's are here .......

Colin Watson (cjwatson) on 2012-02-15
summary: - "Upgrade" from 11.10 to 11.04 results in a unusable system
+ Fails to copy directory over symlink (e.g. /var/lock when downgrading
+ from 11.10 to 11.04)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.9.19

---------------
ubiquity (2.9.19) precise; urgency=low

  * Install pixmaps/windows_square.png in ubiquity-frontend-gtk.
  * Make it possible to run the test suite against installed packages, and
    add a DEP-8 control file for this.
  * Refactor copy_all to be more robust, handle some more cases, and be
    testable and tested. It can now:
    - copy a directory over an existing non-directory (LP: #891711);
    - copy device nodes and sockets over existing non-directories
      (LP: #495217);
    - handle all cases of copying a non-directory over an existing empty
      directory;
    - copy a symlink over a non-empty directory by attempting to move the
      directory to the symlink target (LP: #188976);
    - if all else fails, copy a non-directory over an existing non-empty
      directory by moving the target aside to a backup location.
  * Ignore all failures to set timestamps (LP: #411307, #654929).
  * Update translations from Launchpad.
  * Update imported translations from gtk+3.0 3.3.14-0ubuntu2 and
    gnome-panel 1:3.3.5-0ubuntu2.
 -- Colin Watson <email address hidden> Wed, 15 Feb 2012 17:52:19 +0000

Changed in ubiquity (Ubuntu Precise):
status: Triaged → Fix Released
Pete Graner (pgraner) on 2012-04-26
Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.