ubiquity crashed during install with: plugininstall.py: DebconfError: (10, "oem-config/enable doesn't exist")

Bug #739632 reported by Dave Morley on 2011-03-21
354
This bug affects 36 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

Binary package hint: ubiquity

Crash happened during install of the current iso, ie the iso in current on cdimages.

Error from syslog:
 plugininstall.py: Exception during installation:
 plugininstall.py: Traceback (most recent call last):
 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1510, in <module>
 plugininstall.py: install.run()
 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 55, in wrapper
 plugininstall.py: func(self)
 plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 194, in run
 plugininstall.py: self.next_region()
 plugininstall.py: File "/usr/lib/ubiquity/ubiquity/install_misc.py", line 676, in next_region
 plugininstall.py: self.db.progress('SET', self.count)
 plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 65, in <lambda>
 plugininstall.py: lambda *args, **kw: self.command(command, *args, **kw))
 plugininstall.py: File "/usr/lib/python2.7/dist-packages/debconf.py", line 101, in command
 plugininstall.py: raise DebconfError(status, data)
 plugininstall.py: DebconfError: (10, "oem-config/enable doesn't exist")

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubiquity 2.5.27
ProcVersionSignature: Ubuntu 2.6.38-7.36-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Mon Mar 21 18:59:43 2011
ExecutablePath: /usr/bin/ubiquity-dm
InterpreterPath: /usr/bin/python2.7
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110321)
ProcCmdline: /usr/bin/python /usr/bin/ubiquity-dm vt7 :0 hostname /usr/bin/ubiquity --greeter --only
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/ubiquity-dm', 'vt7', ':0', 'hostname', '/usr/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity-dm crashed with ValueError in command(): invalid literal for int() with base 10: ''
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) on 2011-03-21
visibility: private → public
Ramón Rocha (ramon.rocha) wrote :

Hi, I'm here from the dupe #739891. Attached are requested files.

Ramón Rocha (ramon.rocha) wrote :
Changed in ubiquity (Ubuntu):
status: New → Confirmed
visibility: public → private
Ramón Rocha (ramon.rocha) wrote :
visibility: private → public
Kevin Kwan (kevinkwan-kk) wrote :

same error in amd64 iso

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #652916, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check

I'm removing the duplicate, the traces in syslog are not the same.

description: updated
summary: - ubiquity-dm crashed with ValueError in command(): invalid literal for
- int() with base 10: ''
+ ubiquity crashed during install with: plugininstall.py: DebconfError:
+ (10, "oem-config/enable doesn't exist")
Changed in ubiquity (Ubuntu Natty):
importance: Undecided → High
Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in ubiquity (Ubuntu Natty):
assignee: Canonical Foundations Team (canonical-foundations) → nobody
VastOne (vastone) wrote :

Would you need my latest syslog and partman from today?

Changed in ubiquity (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
tags: added: iso-testing
Colin Watson (cjwatson) wrote :

Please start the installer entirely afresh (i.e. reboot). Enter a live session ("Try Ubuntu"), start a terminal, and run 'ubiquity -d'. Let the installer run through until it fails. Before rebooting, I then need /var/log/syslog and /var/log/installer/debug from the failed installation - please attach them to this bug.

Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Incomplete
VastOne (vastone) wrote :

Will have it for you in 25 minutes

VastOne (vastone) wrote :

as requested

syslog

VastOne (vastone) wrote :

as requested

debug

Ramón Rocha (ramon.rocha) wrote :

Just an FYI: The debug log file produced from running 'ubiquity -d' will include the password you used in plain text so don't use a password you would normally use. Just make it 'test' or something.

VastOne (vastone) wrote :

@Ramon

Thank you ... Good information to know

Evan (ev) on 2011-03-28
Changed in ubiquity (Ubuntu Natty):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.31

---------------
ubiquity (2.5.31) natty; urgency=low

  * Put build-dependencies in the right place.
  * Add python-apt to the build-depends for the test harness.
  * Use the standard nocheck DEB_BUILD_OPTIONS argument instead of
    UBIQUITY_NO_TESTS. Thanks Steve Langasek!
  * Run the tests on all architectures.
  * Don't feed jockey's output into debconf (LP: #739632).
 -- Evan Dandrea <email address hidden> Mon, 28 Mar 2011 23:21:15 +0100

Changed in ubiquity (Ubuntu Natty):
status: Fix Committed → Fix Released
VastOne (vastone) wrote :

An hour ago I was able to apt-get update ubiquity to 2.5.31 and resumed the installation

On my AMD64 Natty Daily 20110328.1

MD5Sum: (b1b2873564bce6372b04c04bd5403ee6)

I was able to successfully install!!

I will reinstall the full ISO from DVD when it is released

Hansen (moteprime) wrote :

I also confirm that daily Natty Desktop i386 ISO dated 29. march, installation completed successfully.

Nick Dolan (nick-dolan) wrote :

I did the update, and the used Gparted to re partition the drive and was able to move forward

To post a comment you must log in.