No restart option after choosing to "Continue Testing"

Bug #657086 reported by Erick Brunzell on 2010-10-08
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Stéphane Graber
Natty
High
Evan

Bug Description

Binary package hint: casper

I wondered what package to blame this on, but I can in no way reproduce this on an installed OS so casper got it.

I've been testing what I consider "confusing behaviour" in the new ubiquity and I've been saving screenshots to the desktop so I could later copy them to a flash drive.

But after selecting "Continue testing" rather than "restart now" there is NO gui option to restart. I'm aware that it's been removed from the Main Menu, but even clicking on the indicator applet only allows suspend or hibernate.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: casper 1.248
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
Architecture: i386
Date: Fri Oct 8 16:14:06 2010
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: casper
---
Architecture: i386
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
Package: ubiquity 2.6.5
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty natty
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:
---
Architecture: i386
DistroRelease: Ubuntu 11.04
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
Package: ubiquity 2.6.5
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Tags: natty natty
Uname: Linux 2.6.38-8-generic i686
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

Erick Brunzell (lbsolost) wrote :
tags: added: iso-testing
Erick Brunzell (lbsolost) wrote :

I've reproduced this bug continuously, it's simple but time consuming.

Boot to the Live Desktop, then click on Install, after installation choose to "Continue Testing". Once you're done testing and/or saving any info there is no gui option to restart, only Suspend & Hibernate.

Not a show stopper but something we should fix in Natty IMO.

Not sure if it's worth a mention in the Release Notes or not.

Changed in casper (Ubuntu):
status: New → Confirmed
Ari Asril (jasbutut) wrote :

I confirm this.
Actually, it is easy to type in sudo reboot at terminal but it will confuses first timers and of course it is still a bug to fix.

Erick Brunzell (lbsolost) wrote :

I'm iso-testing the first Natty Beta1 i386 image and I was saving screenshots during installation. Upon completing the install I chose to continue testing so I could save those screenshots to an external drive. When complete I found that there was no option to restart.

Not a big deal, I just chose to Alt>SysReq>K and restart from GDM.

Colin Watson (cjwatson) wrote :

I couldn't reproduce this in KVM; it may be specific to one of the desktop options.

Erick Brunzell (lbsolost) wrote :

I'm performing actual hardware installs.

I used the default Unity desktop with this hardware:

JetWay JATOM-GM1-230-LF Motherboard
Intel Atom 230 CPU @ 1.60GHz
System Memory 2GB DIMM
Intel 82945G/GZ Integrated Graphics
Intel N10/ICH 7 Family High Def Audio Controller

Two hard drives, a WD 80GB IDE and a WD 500GB SATA.

And it was running the true default unity desktop amazingly well, which tells me most of my Unity complaints require a fresh install ;^/

Just going to go for a manual partitioning install w/screenshots so I'll see if it's a continuous problem.

Erick Brunzell (lbsolost) wrote :

Well, I was unable to reproduce this performing a manual install on the same hardware with the same disc.

The only difference was that I took only 2 screenshots instead of 8, so this requires more testing.

Wash, rinse, repeat ;^)

At the very worst it's fairly insignificant anyway. Hardly a show-stopper.

Erick Brunzell (lbsolost) wrote :

This is gonna be a tough one!

I originally encountered this with yesterdays iso-testing build, but I performed at least 2 more tests and it didn't happen again. So that was a total of 3 installation tests with the same disc, all 3 starting from the live desktop and only one resulted in this bug.

I ran 4 more tests with the first of todays iso-testing builds, one of which I aborted, and this bug never appeared.

Then when the second iso-test build was released I ran two more successful installs and only one resulted in this bug. Both of those tests were "side-by-side" installs.

So two out of nine installs result in this bug using three different isos and ATM I can't come up with a method to continuously reproduce the bug.

I should however point out that Alt>SysReq>B does not reboot, but rather brings up the screenshot tool. Alt>SysReq>K does take you back to gdm so you can then reboot from there. Since it's only happened twice I can't be sure, but I'd think sudo reboot should also work.

I'm not sure if this is worth a mention in the Beta1 release notes or not but I'm subscribing the Release Team so they can decide.

Sorry to be a pain and thanks in advance.

Erick Brunzell (lbsolost) wrote :

One thing I left out of my last post:

To reproduce you must start the installation from the live desktop and then upon completion choose to continue testing, but it's a real crap-shoot. Seven out of nine times it worked fine.

Evan (ev) wrote :

It's definitely a bug in ubiquity. The installer takes care to prevent you from restarting or shutting down during installation (for the obvious reasons), but its hook to undo that at completion is not running in this scenario for some reason.

affects: casper (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-11.04
Changed in ubiquity (Ubuntu Natty):
assignee: nobody → Evan Dandrea (ev)
Erick Brunzell (lbsolost) wrote :

Quite probably not at all related but Evan would know.

I was poking about gathering info regarding minimum install size, and I'd have sworn earlier that most installs came in about 3.06 or 3.08 GB according to gparted, but my last install yesterday (the same one that resulted in this bug) shows 3.64GB.

Now, in the process of poking about, I see that installations home folder contains a folder titled "buildd". I don't recall ever having seen that before. I just wondered if the failure to "purge" something post-install could be related to this, but I'm just grabbing at straws :^)

Evan (ev) wrote :

No, the code is constructed so that it runs even on error.

Evan (ev) wrote :

I've committed a hopeful workaround for ubiquity 2.5.35 that just calls unlock_environment a bit earlier. The .manifest files on http://cdimage.ubuntu.com/daily-live will tell you the version of ubiquity included on that particular CD build.

Let me know if this is still occurring with CDs that have ubiquity 2.5.35, and please run `sudo apport-collect 657086` from the desktop on that installation attempt to attach the necessary logs to this bug report.

Changed in ubiquity (Ubuntu Natty):
status: Confirmed → Incomplete
Erick Brunzell (lbsolost) wrote :

Evan,

I realize 2.5.35 has not yet rolled out but I have one stupid question. Do I need to use apport-collect regardless of success or failure?

This is going to be a tough one because with the Beta 1 iso-test images it happened only 2 times out of 9.

Many thanks to both you and Colin. I know I've been a real pain.

Erick Brunzell (lbsolost) wrote :

I've completed three installation tests with the i386 Beta 2 iso-testing image and not had this reoccur.

I have at least two more tests to run, to familiarize myself with some of the changes to ubiquity (BTW thanks for that link Evan), so I'll keep watching.

Tom Fouch (yakilaky) wrote :

I've done two upgrades from 10.10 and each time I experienced the same bug. The latest upgrade was done on April 11th, so the bug is still there. I just hit the 3-finger reset button <ctrl> <alt> <del>

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

apport information

apport information

Erick Brunzell (lbsolost) wrote :

Darn! This just cropped up again using the Ubuntu Desktop i386 [20110413] Beta2 candidate after completing my first installation test.

I completed a total of 5 installs with the first iso-testing image, and 1 install with the 2nd image without this error appearing.

However that's not particularly indicative of a difference between the images given the fact that this appeared only 2 out of 9 times with the Beta1 test image.

Erick Brunzell (lbsolost) wrote :

This is indeed very inconsistent. I just completed another test and all worked fine. There were two differences:

1) The first test was an "alongside" with the installer using a pre-created 20GB free space, the second install was a "manual" install.

2) The first test was performed using the default Unity DE, the second was performed using classic w/o effects.

At any rate I don't think this is hardly serious enough to warrant a rebuild, I intend to do quite a bit of testing between now and Natty final iso-testing just to truly get a handle on all of the changes outlined here:

https://docs.google.com/View?id=dfkkjjcj_101gnkrpg5v#4_5_1

I will try and be very attentive to any commonalities that help to trigger this.

Setting to triaged because it is still an issue with 2.6.5 and Eric has attached the requested information.

Changed in ubiquity (Ubuntu Natty):
status: Incomplete → Triaged

And I can reproduce it with latest Ubuntu Desktop ISO (2011-04-17) and ubiquity 2.6.5

Erick Brunzell (lbsolost) wrote :

It has been difficult for me to reproduce reliably. I had thought it may be dependent on which DE I was using (Unity, classic, or classic w/o effects) but in repeated testing that appears not to be the case.

The only difference between DE's is the fact that if using either classic DE, and if the restart option does not appear under the button in the upper right hand corner, the shutdown menu does still exist in the main menu.

If memory serves me correctly, in Maverick that option only appeared in the main menu if the shutdown applet was removed from the panel.

Regardless it appears to be limited only to that applet as the shutdown options still show up in the main menu even when lacking under that applet. I hope that makes sense.

BTW the method by which I select a different DE on the live desktop is simply to logout (either via menu or Alt + SysReq + K) then login as ubuntu, select the preferred DE, and leave the password blank.

Actually, the issue I see today looks like a regression introduced by bug 750140. There's no more restart and shutdown menu on the Live session.

apport information

description: updated

apport information

apport information

apport information

apport information

Erick Brunzell (lbsolost) wrote :

Good! I see the info I tried to send actually made it.

I lucked out this time, after booting the Beta 2 i386 Live CD and selecting try Ubuntu I first checked out what was up with bug 750140. I then resized the existing partition on my drive sdb to provide about 10GB free space to test "install to existing free" which still appears as "alongside".

The installation was successful, no problem other than needing to complete the UI so "side-by-side" is separate from "use existing", but here's the part pertinent to this bug:

I was using classic w/o effects and no restart option appears when I click on the applet in the upper right hand corner.

But if I click on System the shutdown menu shows up just fine and the option to restart works from there. So I'm thinking this is not so much a Casper bug as something to do with that applet/function.

Evan Dandrea will know. I'm attaching three screenshots as verification.

Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :
Erick Brunzell (lbsolost) wrote :

Oh, although I'm using the Beta 2 I did check to see if any updates were available for casper or ubiquity and it appeared I was up-to-date.

I hope this is all helpful.

I'd still consider this a very low priority bug as I think most people won't choose to continue testing and I'd hope that those who do know how to reboot w/o pushing the power button.

Evan (ev) wrote :

Marking this as Won't Fix for natty. I have not been able to track the route cause of it, and it is as you suggest a minor bug given the circumstances.

Changed in ubiquity (Ubuntu Natty):
status: Triaged → Won't Fix
Changed in ubiquity (Ubuntu):
milestone: ubuntu-11.04 → ubuntu-11.10
tags: added: ubiquity-2.6.5
Stéphane Graber (stgraber) wrote :

I just commited a few changes to ubiquity porting the indicator session keys from gconf to gsettings.
Once we get an ubiquity build with these changes (likely tomorrow or the day after) it'd be great if you could test a daily build and see if it still happens.

Stéphane Graber (stgraber) wrote :

http://cdimage.ubuntu.com/daily-live/20111004/ contains the new ubiquity, would be great if you could give it a try.

Thanks

Erick Brunzell (lbsolost) wrote :

I'm zsyncing the image now and I'll burn it after running a few urgent errands.

Stéphane Graber (stgraber) wrote :

Don't bother, I just noticed that for some reason the new code doesn't seem to be called at the end of the install :(

I'll be working on it today.

Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → Stéphane Graber (stgraber)
Stéphane Graber (stgraber) wrote :

Tracked down the source of the problem. Testing a fix now.

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) on 2011-10-04
Changed in ubiquity (Ubuntu Natty):
milestone: ubuntu-11.04 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.8.3

---------------
ubiquity (2.8.3) oneiric; urgency=low

  * Skip LTSP from the list of networks to copy to the target.
    This is a temporary network created by Edubuntu's LTSP live.
  * Fix PROXY url as the gsettings host key already contains http://
  * Only disable set the gsettings keys once in gtk_ui (LP: #657086)
  * Properly handle keys in gsettings that are empty/not set.
  * Don't crash when the no-proxy list is empty. (LP: #867620)
  * Clear the console just before killing X in ubiquity-dm. (LP: #813065)
 -- Stephane Graber <email address hidden> Tue, 04 Oct 2011 21:01:09 -0400

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers