Ubuntu

Username starting with upper letter marked as OK during install and the refused

Reported by Jaroslav Šmíd on 2010-04-05
108
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

When you type username starting with upper letter during Ubuntu 10.04 installation, it is marked as it is correct with green tick. Then if you click "Forward" button, such username is refused with message that it should not start with upper letter. Well, you should either allow it (as OpenSUSE does) or not mark it as OK when it is typed.

Related branches

lp:ubiquity
Adolfo Jayme (community): Disapprove on 2014-04-02
Ondrej Pačay: Pending requested 2013-12-11
Kamus (kamus) on 2010-04-05
affects: ubuntu → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
Andrea Olivo (andryandrew) wrote :

affects me too, as i described in this (https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/553967). The problem appear with every username, it seems that the green tick always appear, also when I type something like "andrea**./KKs", that of course can't be accepted

Colin Watson (cjwatson) on 2010-10-14
Changed in ubiquity (Ubuntu):
status: New → Fix Committed
assignee: nobody → Colin Watson (cjwatson)
importance: Low → Medium
kaefert (kaefert) wrote :

My Bug #658651 was marked as duplicate of this. However, in Ubuntu 10.10 this bug is a lot worse than what was discribed here for 10.04, since there is no warning what so ever of what causes the inability to finish the setup. You get a green tick beside the username but the next button is disabled.

Colin Watson (cjwatson) wrote :

Yes, I know. But nevertheless it's the same bug.

Jaymes Reed (jaymes) wrote :

I started the previous question having not seen this one. Anyway, someone answered it yesterday, and I now have it installed. Works great and thanks to everyone involved for a lovely OS ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.5.0

---------------
ubiquity (2.5.0) natty; urgency=low

  [ Colin Watson ]
  * Log which package (albeit only the first one) caused us to declare
    language support incomplete.
  * Initialise release_notes_found in KDE prepare plugin, so that it doesn't
    break in oem-config mode (LP: #656983).
  * Re-enable alpha warning for natty.
  * Fix ubiquity.i18n.string_extended set creation syntax.
  * GTK frontend:
    - Display inline error messages for bad usernames, rather than just
      silently greying out the Forward button (LP: #555896).
    - Use gobject.timeout_add_seconds rather than gobject.timeout_add in a
      couple of places where the exact timeout period isn't critical.
  * Adjust for changes in base-installer 1.113ubuntu1.
  * Install new files from apt-setup 1:0.48ubuntu1.
  * Automatic update of included source packages: apt-setup 1:0.48ubuntu1,
    base-installer 1.113ubuntu1, choose-mirror 2.35ubuntu1, clock-setup
    0.104ubuntu1, debian-installer-utils 1.80ubuntu1, hw-detect 1.80ubuntu1,
    netcfg 1.56ubuntu1, partconf 1.34, partman-auto 93ubuntu1, partman-base
    145ubuntu1, partman-basicfilesystems 67ubuntu1, partman-basicmethods 45,
    partman-btrfs 3, partman-ext3 60ubuntu1, partman-jfs 31,
    partman-newworld 23, partman-partitioning 77ubuntu1, partman-reiserfs
    48, partman-target 69ubuntu1, partman-xfs 45, preseed 1.46,
    yaboot-installer 1.1.17ubuntu1.

  [ Evan Dandrea ]
  * Merge with the maverick-cleanup branch.

  [ Martin Pitt ]
  * debian/rules: Run dh_scour to compress shipped SVG images. Add
    python-scour build dependency.
 -- Colin Watson <email address hidden> Mon, 08 Nov 2010 14:00:56 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers