Installer completion popup window hidden behind netbook-launcher after installation complete

Bug #462178 reported by Tobin Davis on 2009-10-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
netbook-launcher (Ubuntu)
Medium
Unassigned
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

End of installation popup appears minimised at the end of some UNR installations.

Workaround:
Press alt-tab to show this popup window at the end of an UNR installation if you don't see it, or click on its icon in the list of open windows in the top panel.

Proposed release note:
The confirmation of a successful Ubuntu Netbook Remix installation might be hidden in some cases; the popup window offering to reboot is just minimised, you may click on it in the list of windows in the top panel or press Alt-Tab until you switch to it. See Bug:462178.

Tobin Davis (gruemaster) wrote :

netbook-launcher-2.1.12-0ubuntu3 installed.

Marc Deslauriers (mdeslaur) wrote :

The popup window was underneath for me also, but I did get an icon in the taskbar to make it appear on top.

Paul Larson (pwlars) wrote :

Added netbook-launcher at Tobin's request. I will try to reproduce also, but haven't seen this so far.

Loïc Minier (lool) wrote :

I didn't get this in recent installations myself

Jamie Bennett (jamiebennett) wrote :

I got this issue. Notification icon was in the panel but no pop-up window.

Marc Deslauriers (mdeslaur) wrote :

Just got this again with the 20091028.3 iso installed from a USB key onto a Dell Mini 9.

Loïc Minier (lool) wrote :

I think this happens when ubiquity isn't focused at the end of installation

description: updated
Loïc Minier (lool) wrote :

Wasn't sure whether to release note it; davidm decided to.

description: updated
Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/KarmicKoala/ReleaseNotes#UNR%20install%20confirmation%20dialog%20may%20be%20hidden>:

In some cases, the confirmation dialog at the end of a successful Ubuntu Netbook Remix installation will be hidden. To reach the popup window prompting for reboot, you may click on it in the list of windows in the top panel or press Alt-Tab until you switch to it. (Bug:462178)

Changed in ubuntu-release-notes:
status: New → Fix Released
Evan (ev) wrote :

I've set the flags for "always on top" for the finished dialog in Lucid.

Changed in ubiquity (Ubuntu):
status: New → Fix Committed
Paul Larson (pwlars) wrote :

I believe the intent is to put a better fix in for this going forward.

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.1.0

---------------
ubiquity (2.1.0) lucid; urgency=low

  [ Evan Dandrea ]
  * Run X with -nolisten tcp (LP: #462394).
  * Make sure we never try to install onto the live filesystem.
  * Only print the filenames being blacklisted if in debug mode.
  * Provide human readable sizes in the partitions-too-small warning
    (LP: #298974).
  * Mark the "Installation Complete" window as always on top
    (LP: #462178).
  * Fixes from Pychecker for the KDE frontend (kde_ui):
    - Don't import datetime or math. The timezone code is in a separate
      module now.
    - Remove some unused variables.
    - Don't assign to a variable that's going to be immediately discarded.
  * Signal to GTK+ when using a right-to-left language, so that it
    composes the interface from right to left (LP: #222845).
  * Signal to the slideshow when the installer is using a right-to-left
    language (LP: #446989).
  * Set SUDO_UID and SUDO_GID in ubiquity-dm so ubiquity knows what user
    to drop privileges to (LP: #422254).
  * Do not try to configure networking in oem-config (LP: #471498).
  * Make migration-assistant import failures non-fatal to the overall
    install.
  * pkgsel now provides a debconf question to avoid warning the end user
    when the language packs could not be installed (LP: #471553).
  * Make sure a device exists as part of the grub target device
    validation.
  * Allow the user to retry grub installation with a different device on
    failure.
  * Automatic update of included source packages: apt-setup
    1:0.42ubuntu1, choose-mirror 2.29ubuntu2, clock-setup 0.100ubuntu1,
    debian-installer-utils 1.71ubuntu1, grub-installer 1.47ubuntu1, hw-
    detect 1.73ubuntu1, netcfg 1.51ubuntu1, partman-base 135ubuntu1,
    tzsetup 1:0.26ubuntu1, user-setup 1.28ubuntu1.

  [ Colin Watson ]
  * Add a debian/rules target to run pychecker. I've fixed several warnings,
    but there are still several left so this is not yet enabled by default.
  * Fix debconf frontend:
    - Start oem-config on stopping rc, as well as when starting display
      managers.
    - Add some missing imports (ubiquity.frontend.base.Controller,
      ubiquity.plugin.Plugin, ubiquity.i18n, signal,
      ubiquity.components.install).
    - If there's a containing debconf frontend, talk to it rather than using
      debconf-communicator.
    - Set a controller in the language plugin.
    - Use spaces rather than ${!TAB} in localechooser when using the debconf
      frontend, since debconf doesn't support the latter yet.
    - Don't handle user-setup preseeding for the debconf frontend.
    - Remove unused progress_position handling.
    - Fix exception names in ubi-network and ubi-tasks.
  * Require Python 2.5, so we can now use hashlib rather than md5 and avoid
    a slew of warnings.
  * Add an intro message noting that we're alpha again.
 -- Evan Dandrea <email address hidden> Fri, 13 Nov 2009 10:41:42 +0000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
tags: added: iso-testing
Didier Roche (didrocks) on 2010-02-12
Changed in netbook-launcher (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers